Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

switch to router config

Hi All,

Got a 2821 router and two 3750 switches (stacked). I have the ip 192.168.200.2 on the vlan 1 int of the stacked switches (i know i should use a different vlan). the only way I can ping the router is to have one of the gig interfaces and then put a sub int of that gig interface with the ip address. I wanted to use both of the gig interfaces to go to the stacked 3750 to create an etherchannel. when i try to do the following, i cannot ping across:

interface Port-channel15

description EtherChannel to 3750

no ip address

hold-queue 150 in

!

interface Port-channel15.1

encapsulation dot1Q 1 native

ip address 192.168.200.1 255.255.255.0

no snmp trap link-status

I place the two gig interfaces in the port channel, but nada. is there another way i should be doing this?

TIA,

R

7 REPLIES
Cisco Employee

Re: switch to router config

Try configuring "vlan dot1q tag native" on the switch side to force the switch to tag a native vlan.

That should solve the issue.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: switch to router config

Thanks for your reply. I tried your suggestion with the same results.

Maybe this will help?

2821

- - -

!

interface Port-channel15

description EtherChannel to 3750

no ip address

hold-queue 150 in

!

interface Port-channel15.1

encapsulation dot1Q 1 native

ip address 192.168.200.1 255.255.255.0

no snmp trap link-status

3750

- - -

vlan internal allocation policy ascending

vlan dot1q tag native

!

interface Port-channel15

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 15 mode on

!

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 15 mode on

New Member

Re: switch to router config

Can someone take a look at the config i posted?

New Member

Re: switch to router config

Hi,

config seem fine ..can you try by adding

'switchport trunk native vlan 1' under interface port-channel15 on 3750.

Regards,

Rajesh

New Member

Re: switch to router config

Thanks for the reply. this did not work though. one thing I thought was odd, i can do "show cdp neighbor" on the 3750 and see the 2821, but not vice versa.

thanks

New Member

Re: switch to router config

Hi Guys,

I finally called TAC about this, low and behold I got an answer.

From Cisco.com:

"Q. Are there differences between the on-board Gigabit Ethernet ports and the HWIC-1GE-SFP?

A. Two copper Gigabit Ethernet ports are built into the Cisco 2821, 2851, and 3800 Integrated Service Router platforms. On the Cisco 3800 Series platform, an SFP Gigabit Ethernet port can be used instead of one of the copper Gigabit Ethernet ports. The feature set of the on-board Gigabit Ethernet ports and the HWIC-1GE-SFP is the same, except that Cisco EtherChannel® is not supported on the on-board Gigabit Ethernet interfaces"

So...etherchannel is not supported on the gig interfaces on the 2821 if anyone would like this info.

Thanks

New Member

Re: switch to router config

Thanks, this is something I plan on testing soon - too bad the answer is no!

348
Views
4
Helpful
7
Replies
CreatePlease to create content