Cisco Support Community
Community Member

Switches not updating VLAN's

I currenlty have fourty vlans configured on my network. The 6509 switch is setup as a server and when I do a show VTP Domain it says vlan-count 40. When I look at other switches on my network they are only showing 21 vlans. Each switch is configured as a client with the proper VTP Domain and VTP V2 Mode is enabled. I have also configured each interface for trunking. Please let me know what I'm missing. I'll post my configs on the next post. Thanks in advance for your help

Community Member

Re: Switches not updating VLAN's

Here is the 6509 config:

show vtp domain

Domain Name illumina2

Domain 1

Vtp Verison 2

Local Mode Server

Password Configured

Vlan-Count 40

Max-vlan-storage 1023

Config 91

Notifications enabled

V2 MOde enabled

Prunning disabled

PruneEligible on Vlans 2-1000

and here is the 3550 config:

show vtp status

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 1005

Number of existing VLANs : 21

VTP Operating Mode : Client

VTP Domain Name : illumina2

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

MD5 digest : 0x97 0x1E 0x7C 0x8E 0xC8 0x1A 0xF4 0x1F

Configuration last modified by at 2-7-06 23:39:42

Re: Switches not updating VLAN's


What configuration Revision is on your 6509 for vtp.

If its the same revision as the 3550, the 3550 won't accept any updates thinking it already has a current version of the vlans. To fix that just create a couple of vlans on the 6509 and then delete them to increase its revision number.


Community Member

Re: Switches not updating VLAN's

Thanks for your help. I fixed the problem before I saw your post. I had to set a password for the VTP on each switch and when I did that the VLAN's updatated. Thanks for your help.

CreatePlease to create content