Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switching to Routing Mismatch

Hi. Interesting issue. I configure BOTH sides of a Cat 5 cable to be Full Duplex / 100... one side a 3550; the other a 2600. They BOTH state FULL DUPLEX in the configs. They are directly connected with a crossover cable. I still get the output at the bottom of the following snippet....

ecrouter#sh run

Building configuration...

Current configuration : 1363 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ecrouter

!

boot system flash

boot system flash c2600-i-mz.122-1.bin

logging rate-limit console 10 except errors

enable secret 5 $1$6vmb$PAy58YpGUM2hHm2UIDXee.

enable password 7 14031A0E0E547F7E

!

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

no ip dhcp-client network-discovery

!

!

!

interface Ethernet0/0

description connected to EastCampus

ip address 172.16.23.249 255.255.240.0

no keepalive

full-duplex

!

interface Serial0/0

description connected to wcrouter

ip address 192.168.2.1 255.255.255.0

!

interface BRI0/0

no ip address

shutdown

cdapi buffers regular 0

cdapi buffers raw 0

cdapi buffers large 0

!

router eigrp 105

redistribute static

network 172.16.16.0 0.0.15.255

network 192.168.2.0

neighbor 172.16.20.1 Ethernet0/0

neighbor 172.16.20.5 Ethernet0/0

neighbor 192.168.2.2 Serial0/0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.20.1

ip route 10.10.1.0 255.255.255.0 172.16.23.254

ip http server

!

!

line con 0

exec-timeout 0 0

password 7 0958460C1B554247

login

transport input none

line aux 0

line vty 0 4

password 7 111D110015425E59

login

line vty 5 15

password 7 0014430B140B06

login

!

no scheduler allocate

end

ecrouter#

9w3d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on Ethernet0/0 (not full duplex), with NYC89EAST FastEthernet0/12 (full duplex).

10 REPLIES
Green

Re: Switching to Routing Mismatch

What happens when you set them both to "Auto" ?

Also note that switch to router doesn't require a crossover cable.

Try a regular cable (preferably not hand-made).

Good Luck

Scott

Bronze

Re: Switching to Routing Mismatch

Hi,

If you manually set the duplex mode to Full on one side of the link and leave the other side in autonegotiation mode, the link ends up in half-duplex.

Check ur config on fa 0/12 it might be in auto

Check this link it might help you if both are set to full duplex manually still u recieving the CDP error messages

http://www.cisco.com/en/US/tech/tk389/tk214/technologies_tech_note09186a0080094781.shtml

HTH

Thanks

Raj

Re: Switching to Routing Mismatch

Hi Trev,

infact even i was facing such probz yile connecting cisco 1700 series router to cisco 6509 switch, what i have done is i have juz set my 1700 series router to half-duplex & thatz it started working.

Note: cisco 1700 on-board 100Mbps

WIC-1ENET - 10Mbps,

i have juz made WIC-1ENET as half-duplex & nothing else, so i avoided getting this message.

hope you can try this.

Silver

Re: Switching to Routing Mismatch

Hi agree with ScottMac ... why crossover cable?

Regards

Andrea

Hall of Fame Super Silver

Re: Switching to Routing Mismatch

I also note that the original post indicated that both interfaces were set 100 Mb and full. But the interface is Ethernet nor FastEthernet. This inidcates that it is a 10 Mb interface not 100 Mb. If the speed is not consistent the duplex might be inconsistent also.

If the original poster would post the output of show interface Ethernet0/0 it might shed light on what is going on here.

HTH

Rick

New Member

Re: Switching to Routing Mismatch

Hi.

This is the router's Ethernet interface.....

interface Ethernet0/0

description connected to EastCampus

ip address 172.16.23.249 255.255.240.0

no keepalive

full-duplex

Here is the sh e0/0....THE GOOD THING IS THAT THERE ARE NO ERRORS...

Ethernet0/0 is up, line protocol is up

Hardware is AmdP2, address is 0006.2895.88c0 (bia 0006.2895.88c0)

Description: connected to EastCampus

Internet address is 172.16.23.249/20

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 2d20h

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 4000 bits/sec, 7 packets/sec

5 minute output rate 1000 bits/sec, 3 packets/sec

5460017 packets input, 1084781074 bytes, 0 no buffer

Received 545941 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

5676034 packets output, 3938279869 bytes, 0 underruns(0/0/0)

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Here is the switch output...NEGLIGIBLE ERRORS

NYC89EAST#sh int fas

NYC89EAST#sh int fastEthernet 0/12

FastEthernet0/12 is up, line protocol is up

Hardware is Fast Ethernet, address is 000c.316b.ed8c (bia 000c.316b.ed8c)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 10Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:21, output 00:00:00, output hang never

Last clearing of "show interface" counters 2d20h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

5691280 packets input, 3976691790 bytes, 0 no buffer

Received 18473 broadcasts, 25 runts, 0 giants, 0 throttles

105 input errors, 80 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 4095 multicast, 0 pause input

0 input packets with dribble condition detected

5761579 packets output, 1162049630 bytes, 0 underruns

0 output errors, 7 collisions, 0 interface resets

0 babbles, 0 late collision, 16 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

The config snippet...

interface FastEthernet0/12

switchport access vlan 2

switchport mode access

no ip address

duplex full

speed 10

YOU CAN SEE BOTH ARE SET RIGHT --- OH, AND MY MISTAKE, IT IS A STRAIGHT THROUGH CABLE...

I STILL GET ..... ON THE SWITCH

NYC89EAST#sh log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)

Console logging: disabled

Monitor logging: level debugging, 0 messages logged

Buffer logging: level debugging, 4871 messages logged

File logging: disabled

Trap logging: level informational, 4875 message lines logged

Log Buffer (4096 bytes):

05:57:22.034: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet

0/12 (not half duplex), with ecrouter Ethernet0/0 (half duplex).

NYC89EAST#

Hall of Fame Super Silver

Re: Switching to Routing Mismatch

Steve

Thanks for posting the additional information. It does help clarify that both interfaces are operating at 10 Mb.

I was expecting to see in the output of show interface from the router something about duplex setting and am surprised to see no mention of duplex in the output from the router.

Another thing that seems a bit odd is this line in the output from the switch:

0 output errors, 7 collisions, 0 interface resets

If the switch interface is full duplex there should be NO collisions. So where do these 7 collisions come from?

I note that the router interface is configured with no keepalive. Is there some reason for that?

Can you ping from the router to the address of VLAN2 on the switch? Is data passing over this connection?

HTH

Rick

New Member

Re: Switching to Routing Mismatch

Hi Rick. THANKS SO MUCH for your quick response. I think this may be a bug somewhere because ANY OTHER mix/match of speed duplex / auto .... etc generates errors!! Yes, traffic is great - VLAN2 is reachable. There are NO issues - just the error message, which we can live with - it's just frustrating.

Purple

Re: Switching to Routing Mismatch

We have seen in early versions of the 2600's that even though the full duplex command was there on a 10 meg interface it in fact does not work and you need to run it at 10 /half . If you have one side at 10/half the other must be coded to the same , that is why you are seeing the duplex mismatch .

New Member

Re: Switching to Routing Mismatch

Hey... That makes sense. The only thing that would make this interesting is that even when both sides are 'hard-coded' at 10-half, errors get recorded on the ethernet interface of the router. With both sides hard-coded 10-full, no errors on port BUT error comes up on console....

THANKS!

508
Views
0
Helpful
10
Replies