Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Switching

how switches routing between VLANs without any routing protocol?

5 REPLIES
Purple

Re: Switching

Hi Mate,

When you configure SVI (Switch virtual interfaces) on a L3 switch, the switch will treat each subnet configured on the SVIs as a connected interface. Therefore, it know where each of the connected networks resides. It does not, therefore, need a routing protocol to route between these subnets.

If you have a more complicated network, with multiple routers, a layer 3 switch that does inter-vlan routing will need to use a routing protocol to exchange routes with the routers. But in a simple network, you can get away with just using a switch/router for inter-vlan routing without running any routing protocols.

Hope that helps - pls rate the post if it does.

Paresh

Silver

Re: Switching

Hi,

Network devices in different VLANs cannot communicate with one another without a router/L3 Switch to route traffic between the VLANs.

Just go thro, this link to understand the concept with some configuration examples,

http://www.cisco.com/en/US/products/hw/switches/ps679/products_configuration_guide_chapter09186a008007d1b7.html#xtocid30231

Rgs,

Balaji

Community Member

Re: Switching

Can i get any sample config please

Purple

Re: Switching

With a L3 switch, you would have config such as the following:

interface VLAN10

description SVI for VLAN 10

ip address 10.1.1.1 255.255.255.0

!

interface VLAN20

description SVI for VLAN 20

ip address 10.2.1.1 255.255.255.0

The above will result in two directly connected routes being installed in the routing table:

10.1.1.0/24

10.2.1.0/26

Therefore, the switch will be able to route between nodes belonging to the above two subnets.

Hope that helps - pls rate the post if it does.

Paresh

Silver

Re: Switching

Hi,

As a addition to Paresh, if u have router instead of L3 Switch,

create a subinterface in router where the uplink from the switch is connected,

In a switch,

interface FastEthernet0/1

description connectivity to router

switchport trunk allowed vlan 2000,1000

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 2000

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 1000

switchport mode access

!

In a Router,

interface FastEthernet0/0

description *** TO Switch *****

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1000

description Connectivity to 1000 vlan thro. switch

encapsulation dot1Q 1000

ip address 10.10.10.1 255.255.255.0

!

interface FastEthernet0/0.2000

description Connected to 2000 vlan thro. switch.

encapsulation dot1Q 2000

ip address 20.20.20.1 255.255.255.0

!

Rgs,

194
Views
5
Helpful
5
Replies
CreatePlease to create content