Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Telnet a router

Dear all

Help urgently

I had one E1 link with one router

I am able to ping router serial interface 59.x.x.126 (My end 59.x.x.125) but not able to telnet

command on that router are

line vty 0 4

password cisco

login

I want to know does anything else required

Regards

Mahesh

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Telnet a router

Hi,

There are no issues with the configuration from my observation.

Firstly, where are you telnetting from? I.e. is it from the other router, or from somewhere else on the network?

Also, what exactly happens when you try to telnet to the router? Does it just time out, or do you get a "connection refused"?

The only other possibility is that all the vty lines are used up and the router won't allow anyone else in. You will get a "connection refused" error if this is the case.

Hope this helps,

Michael.

11 REPLIES
Bronze

Re: Telnet a router

Hi Mahesh,

To get a login prompt what you have stated is correct.

However, if you want to enter privileged exec mode (enable mode), then you will also need the lines:

enable secret 0 password

or

enable password 0 password

You cannot enter privileged exec mode through a telnet session unless you have a enable password set.

You should also confirm that there are no access-lists applied to the VTY line. You will see this if there is a line starting with "access-class" under the vty 0 4 section. This would stop you from getting into the router but still able to ping it.

Hope this helps,

Michael.

New Member

Re: Telnet a router

This router is new one and nothing has ben entered except what i have stated

now i am confusing why it is not get to user mode also

i want to go in user mode only

regards

mahesh

New Member

Re: Telnet a router

dear michael,

Is there any possibility that from my router telnet is blocked

tell me the part of configuration which i am able to send as per your request

regards

Mahesh

Re: Telnet a router

Hi Mahesh,

1) Check if you have any outbound acccess list in your end serial interface.

2) Check if you have any inbound access list specified in the serial interface on the other end router. Any possible to get console access to the other end router to check this ?

do you get any error message when you telnet to the other end ip address from your router ?

-VJ

New Member

Re: Telnet a router

interface Serial3/3:0

bandwidth 2048

ip address 59.145.165.89 255.255.255.252

ip load-sharing per-packet

rate-limit input 4912000 921562 1843124 conform-action transmit exceed-action drop

rate-limit output 4912000 921562 1843124 conform-action transmit exceed-action drop

no clns route-cache

!

line vty 0 4

session-timeout 15

access-class 12 in

exec-timeout 5 0

access-list 12 remark VTY Access ACLcommon

access-list 12 permit 202.56.250.10

access-list 12 permit 203.132.154.210

access-list 12 permit 202.56.240.11

access-list 12 permit 59.144.244.86

access-list 12 permit 202.56.252.5

access-list 12 permit 61.95.140.226

access-list 12 permit 202.56.240.15

access-list 12 permit 202.56.240.12

access-list 12 permit 202.56.250.24

access-list 12 permit 61.95.140.254

access-list 12 permit 202.56.250.25

access-list 12 permit 202.56.200.24

access-list 12 permit 202.56.222.15

access-list 12 permit 202.56.200.22

access-list 12 permit 202.56.215.9

access-list 12 permit 59.145.1.154

access-list 12 permit 202.56.204.13

access-list 12 permit 202.56.222.25

access-list 12 permit 202.56.222.18

access-list 12 permit 202.56.239.67

access-list 12 permit 202.123.47.40

access-list 12 permit 202.123.47.39

access-list 12 permit 203.101.87.0 0.0.0.255

access-list 12 permit 59.145.12.0 0.0.0.255

access-list 12 permit 61.95.250.160 0.0.0.31

access-list 12 permit 61.95.240.0 0.0.0.31

access-list 12 permit 202.56.199.72 0.0.0.7

access-list 12 permit 202.56.204.0 0.0.0.31

access-list 12 permit 61.246.165.240 0.0.0.7

access-list 12 permit 61.95.210.96 0.0.0.7

access-list 12 permit 202.56.239.72 0.0.0.7

access-list 12 permit 203.145.138.16 0.0.0.7

access-list 12 permit 203.101.73.32 0.0.0.7

access-list 12 permit 61.246.167.80 0.0.0.15

access-list 12 permit 202.92.238.224 0.0.0.31

access-list 12 permit 202.56.223.0 0.0.0.255

access-list 12 permit 203.101.95.0 0.0.0.255

access-list 12 permit 203.101.100.0 0.0.0.255

access-list 12 permit 59.145.6.0 0.0.0.255

access-list 12 permit 59.145.7.0 0.0.0.255

access-list 12 permit 59.145.8.0 0.0.0.255

access-list 12 permit 59.145.11.0 0.0.0.255

access-list 12 deny any log

Above are my end configuration

and at far end we have only

line vty 0 4

password cisco

login

nothing else

Hope this helps

Regards

Mahesh

Bronze

Re: Telnet a router

Hi Mahesh,

I noticed your IP addressing is different in your configuration as to what you originally posted. Is this intended?

Your IP in the config is 59.145.165.89 and .90

But in your original post it's:

59.145.165.125 and .126

Your config looks OK otherwise.

Thanks,

Michael.

New Member

Re: Telnet a router

that was by mistake ip is configured as per my previous post which is 59.145.165.125/30

but is there any other issue n configuration

Pl. revert

regards

mahesh

Bronze

Re: Telnet a router

Hi,

There are no issues with the configuration from my observation.

Firstly, where are you telnetting from? I.e. is it from the other router, or from somewhere else on the network?

Also, what exactly happens when you try to telnet to the router? Does it just time out, or do you get a "connection refused"?

The only other possibility is that all the vty lines are used up and the router won't allow anyone else in. You will get a "connection refused" error if this is the case.

Hope this helps,

Michael.

New Member

Re: Telnet a router

its ok now

I don't know what was the issue

now i am able to telnet

regards

Thanks All

Mahesh

New Member

Re: Telnet a router

test

New Member

Re: Telnet a router

test

147
Views
0
Helpful
11
Replies
CreatePlease login to create content