Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

telnet question !!!

hi !

there are several question !

topology

PC - [cat 6509] - [server]

pc to server telnet connected

1. The speed is so slow by minute to about 2 minutes 1 to communicate by Telnet 23 Port

and Traffic or CPU is stable state.

2. Do not Telnet operate if set port more than 1024 but If restart 6509 Routers, become again

3. Do not operate when connect allocating specification application and port

Config is no problem, do not know reason

What problem is it? Ask kind reply.

3 REPLIES
Cisco Employee

Re: telnet question !!!

1. Can you successfully ping from PC to Server? If so, is the 1-2min delay only for initial telnet connection? For example, once connected to the server is telnet session fine? If that is the case make sure your pc ip address is in the server host table or that dns is configured properly. A sniffer capture will help you with this issue. The cat6k has no where to store your packets so it's not a latency issue. You are either having an application issue or are dropping packets. As I mentioned before, a sniffer capture will help you determine which.

2. Do you mean set the destination telnet port to 1024? If so, is there an application expecting tcp connection on port 1024 at the server? If this question isn't referring to TCP port 1024 then please clarify. Are you saying that if you reset the 6509 that you can telnet to port 1024 on the server?

3. Again, If this refers to the TCP port make sure the application is expecting a connection on this port. A sniffer capture may show you a port unreachable message if this is the case.

New Member

Re: telnet question !!!

1) The reason you are experiencing latency is because maybe your network is congested.

Green

Re: telnet question !!!

Are you using AAA to authenticate the telnet user?

If so, is it possible that the AAA server is timing out and you are being granted access through the local user list?

Have you tried other telnet client applications (r/o bad/corrupt client application)?

Have you tried SSH (different protocol, and more secure - no unusual port numbers)?

Have you tried telnetting to another switch/router, then telnetting the switch that seems slow (different path)?

Are you connecting through a WAN? If yes, does the WAN link have Weighted-Fair-Queuing enabled ? If the link is congested, WFQ may give the frequent, small telnet packets a better chance of getting through.

Most telnet clients send one packet per character typed (acutally two - the return character for echo gets one too)- lots of very small / minimum-sized packets.

Good Luck

Scott

127
Views
4
Helpful
3
Replies
CreatePlease login to create content