Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Terrible Transfer Rate

Hello All:

Looking for some help. Network segmented into 1x and 2x ...with a 3620 router doing the routing in the middle. 1x and 2x both on their own switches...all is fine.

Just added a 3x segment and firewall and the transfer rate to and from this 3x from anywhere is horrific. 50 minutes for a 100mb file to or from 1x or 2x using a windows machine. Only 29 seconds for the same file using a linux machine (not great but a huge difference)

I have posted my config below but in a nutshell, I have FA0/0 on router 10.0.3.2 going into 3x switch along with the LAN port of the firewall 10.0.3.1.

Clients using 10.0.3.1 as gateway and this routes out to internet over a 3660.

No dropped packets on the router or switch....only 11 packets a sec rate on the router. No matter how I set port settings on any device...mix and match these settings, it is still the same. Can anyone tell me what the heck is going on??

Thanks

----------------------CONFIG-------------

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 3620-INTERNAL

!

!

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description LINK TO 3X - SWITCH

ip address 10.0.3.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

!

interface FastEthernet0/1

description Production link

ip address 10.0.4.2 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

clockrate 2000000

!

interface FastEthernet1/0

description Corporate link

ip address 10.0.1.42 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

router rip

version 2

network 10.0.0.0

!

ip classless

ip route 10.0.2.0 255.255.255.0 10.0.4.1

ip route 172.16.1.0 255.255.255.0 10.0.3.1

ip route 172.16.2.0 255.255.255.128 10.0.1.2

no ip http server

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

3620-INTERNAL#

I just

9 REPLIES
VIP Purple

Re: Terrible Transfer Rate

Hello,

check for any errors on the FastEthernet0/0 interface, and set the speed and duplex to a fixed value (100/full duplex), rather than leaving it at autonegotiation.

You could also check if your CPU is maxed out during the file transfer ('show proc cpu'), in that case, an option would be to turn on CEF globally ('ip cef')...

Regards,

GP

New Member

Re: Terrible Transfer Rate

Could you have a duplex mismatch between you switch and router. I noticed the interface is set to auto negotiate.....just a thought...

New Member

Re: Terrible Transfer Rate

I've tried every combo under the sun of port settings. What's odd is this....no matter what the setting.....it is ALWAYS 54 minute transfer time.

Also....the LINUX box handles the transfer in 29 seconds. So one has to ask...what is the difference in how Linux is communicating over the network vs the windows box.

Going to and from the internet is fine....just the internal transfer rate and this is really killing me. I see no errors on the interface.....nothing

Re: Terrible Transfer Rate

I think your problem lies not in the link between the router and the 3x switch, but between the client PC and the switch. Check the PC and switch are both auto, or both forced. Otherwise, try changing the NIC in the PC.

Is the Linux box on the same segment? Try an FTP between the Linux box and the PC.

Kevin Dorrell

Luxembourg

New Member

Re: Terrible Transfer Rate

Kevin - have done all of that already, changed NICS, cabling and yes LINUX is on the same segment. Now that you mentioned this, the only difference in my testing is the fact that I ftp's from linux over to my 1x segment and the windows pc transfer was drag and drop....maybe somehow this will lead somehwere?

I'm stumped on this one.

New Member

Re: Terrible Transfer Rate

All - Thanks to Kevin's post, I have stumbled onto something....what I don't exactly know.

In my testing, I was FTPing from my linux box on 3x to my server on 1x...transfer rate was ok, 19 seconds for 100 mb. With my windows box on 3x, I was mapping a drive and copy/paste from 1x to 3x. That was the difference.....but WHY? I need to resolve this piece of the puzzle since I need the ability naturally, to drag and drop between 3x and 1x.

Why the difference between FTP and transferring with copy paste??

Any help would be appreciated. Thanks

VIP Purple

Re: Terrible Transfer Rate

Hello,

I think the difference is that FTP uses TCP, while copy/paste uses UDP.

Can you check the event viewer of your Windows machines for any 'MRxSMB' related events ? Which Windows clients do you have anyway (XP, 2000, Me) ?

Regards,

GP

Re: Terrible Transfer Rate

As an experiment, you could try a direct FTP from your windows machine. Open a command line, and do ftp server, then binary, then get filename.

Hope it helps.

Kevin Dorrell

Luxembourg

New Member

Re: Terrible Transfer Rate

If you havn't got this fixed yet let the router do the routing....Point your default gateways at the router and point the router at the FW. I don't see a default route on the router? Why is RIP turned on? Are the other switches routing also? Can you what tell us what you are doing with the statics?

cnowlin

128
Views
0
Helpful
9
Replies