Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Test VLAN not working properly?

I have a cat 6509 with 2 routing modules router80-81 (module15) and router89-253 (module16) each supporting vlans 80, 81, 89, 253.

192.231.232.190 is the inside of the pix .

I created a test vlan named vlan7 and assigned port 7/31 to it. here is a part of the config on the switch:

set vlan 7 name Test type ethernet mtu 1500 said 100007 state active

#vlan 7

set spantree disable 7

set port channel 7/29-32 41

set trunk 7/31 desirable negotiate 1-1005,1025-4094

#module 15 : 1-port Multilayer Switch Feature Card

#module 16 : 1-port Multilayer Switch Feature Card

then i created a virtual interface vlan7 on the router89-253. hers is the relevant part.

interface Vlan7

ip address 204.1.2.4 255.255.255.0

no ip redirects

no ip mroute-cache

standby 7 timers 5 15

standby 7 priority 110 preempt

standby 7 ip 204.1.2.5

ip classless

ip route 0.0.0.0 0.0.0.0 192.231.232.190

ip route 204.1.2.0 255.255.255.0 192.231.232.190

INow, I put in a computer with ip 204.1.2.3/24 into port 7/31. I can do the following:

1.ping the computer (204.1.2.3) from subnet 253

2.telnet router89-253 from the computer (204.1.2.3)

But, I can not do the following from 204.1.2.3:

1.connect to the internet

2.ping either the switch or the pix at 192.231.232.190

I dont know what's wrong??

2 REPLIES
Bronze

Re: Test VLAN not working properly?

Basic routing issues

When you

1.ping the computer (204.1.2.3) from subnet 253

It is working because both the source and destination of the ping point to the same 6509 as their default gateway. So it can reach both of the networks.

When you

2.telnet router89-253 from the computer (204.1.2.3)

It it working because the destination address is also the same host that is the default gateway of the pc. So it can find the pc's network.

When you fail trying to:

1.connect to the internet

2.ping either the switch or the pix at 192.231.232.190

It is because those devices, the pix and the switch, dont know where the new network is. The PIX has a default gateway pointing to the internet and needs a static route pointing in to the 6509 for the new network. The switch, I'm not sure where it is but its default probably does not point to the 6509.

New Member

Re: Test VLAN not working properly?

*******************

1.ping the computer (204.1.2.3) from subnet 253

It is working because both the source and destination of the ping point to the same 6509 as their default gateway. So it can reach both of the networks.

The default gatweay for 204.1.2.3 is 204.1.2.4 (interface vlan7)and the default ateway for the subnet 253 is 204.142.253.254(interface vlan253). Both the default gateways are configured on the router module in the switch.

*********************

2.telnet router89-253 from the computer (204.1.2.3)

It it working because the destination address is also the same host that is the default gateway of the pc. So it can find the pc's network.

Point well taken.

************************

Since the default gateway for the router is the inside interface of the pix, i am assuming any vlan on the router should be sent the inside of the pix.

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.231.232.190

ip route 192.168.1.0 255.255.255.0 192.231.232.190

ip route 192.231.232.0 255.255.255.128 204.100.100.253

ip route 192.231.232.192 255.255.255.224 192.231.232.190

ip route 198.138.22.0 255.255.255.0 204.100.100.253

ip route 204.1.2.0 255.255.255.0 192.231.232.190

ip route 204.142.254.0 255.255.255.0 204.100.100.253

no ip http server

!

As far as the switch is concerned, how do I inform it about the new network. I just configured the vlan 7 and assigned ports to the vlan 7.

84
Views
0
Helpful
2
Replies