Cisco Support Community
Community Member

TFTP Read/Write Error

I have never downloaded a IOS from the CISCO website before and I am having problems. I downloaded the IOS I needed to the TFTP root directory. I keep getting message "file or directory not found" when I tri to load it on my router. I can load the the flash image that is on my 2610 to and from the TFTP server. I tried the same process on a 7505, and I received "TFTP write error". It looks like some sort of file permission problem. I have checked the permissions on the TFTP folder and IOS files. Can someone tell me how to download an IOS from the cisco website and how to get it loaded on my 2610?


Re: TFTP Read/Write Error

If you get a file not found error, then probably you are not entering the correct image name while trying to copy it into flash. (copy tftp flash command).

Most IOS images are binary images. So they have .bin extension. You should specify the .bin extension while executing the command.

Community Member

Re: TFTP Read/Write Error

Thanks for the reply. I am copying and pasting the IOS image name, so they are identical. I am also including the .bin extention. It is very wierd. It seems the router can not open the IOS image that I downloaded from Cisco. I have checked the name, I have used other computers, I have used other TFTP servers, and I have tried to down load images on a 7513, 2610, and 7206. Everything I try does not work. I can copy flash images from all these routers to and from a TFTP Server, but I cannot get the IOS images from the Cisco website to load on any of these routers. I get the same tftp error. The routers cannot open these IOS images for some reason.

VIP Purple

Re: TFTP Read/Write Error


this might be a trivial hint, but what happens if you do not cut & paste the IOS filename but rather type it ? I am thinking that you might inadvertently paste an empty space at the end or at the beginning of the file.



Community Member

Re: TFTP Read/Write Error

I received an email from a great guy named Tim who said I needed to put the IOS images in the top level directory, i.e. C:\ instead of some subdirectory. I moved the images, and also changed the TFTP root directory to C:\. This IOS images transferred beautifully after I made these changes. Weird.

CreatePlease to create content