Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

The 2621 route can't recognize the NAT IP address

-- *Cisco Moderator edited this post. All public IP addresses have been changed to nnn.yyy.zzz to mask the actual public network and configuration in this public forum. Please refrain from posting actual IP addresses to reduce security risks involved. --

I got a cisco 2621 router from our ISP last week, but I'm a beginner to Cisco system :-P .

I'm planning to use the NAT to connect our Intranet(172.16.5.X subnet) to Internet(we got 64 IP from my ISP, *nnn.yyy.zzz.64`127). My ISP setup a fiber cable from their router to another fiber switch(Catalyst 2900 XL) in our office, so this router should use a LAN port to link to fiber switch, and use the static route only(send all the package to *nnn.yyy.zzz.65) ,I created both static NAT and Dynamic NAT), but a problem came up when I tested the connection, the following are the config on our 2621 router:

-----------------------copy the config here-----------------------------

interface FastEthernet0/0 ----------linked to fiber switch will go to Internet

ip address *nnn.yyy.zzz.100 255.255.255.192

ip nat outside

no ip mroute-cache

speed auto

full-duplex

!

interface FastEthernet0/1 ------------------linked to the switch in our Intranet

ip address 172.16.5.1 255.255.255.0

ip nat inside

no ip mroute-cache

speed auto

full-duplex

!

ip default-gateway *nnn.yyy.zzz.65

ip nat pool global *nnn.yyy.zzz.111 *nnn.yyy.zzz.116 netmask 55.255.255.192 ip nat inside source list 1 pool global overload

ip nat inside source static 172.16.5.22 *nnn.yyy.zzz.101

ip nat inside source static 172.16.5.100 *nnn.yyy.zzz.124

ip classless

ip route 0.0.0.0 0.0.0.0 *nnn.yyy.zzz.65 permanent

ip http server

no ip pim bidir-enable

!

access-list 1 deny 172.16.5.22

access-list 1 deny 172.16.5.100

access-list 1 permit 172.16.5.0 0.0.0.255

----------------------------------end the copy config ----------------------------------------

None of the NAT work when I finish the setup, I also can't ping to any of the IP address for NAT except *nnn.yyy.zzz.100. but when I change the IP of F0/0 to *nnn.yyy.zzz.101 then change back to *nnn.yyy.zzz.100, the 172.16.5.22 can access the internet via *nnn.yyy.zzz.101, the same thing happened to other address-------it seems the router didn't regard the other IP address(*nnn.yyy.zzz.101,124,111......) as its own IP.

Any help is appreciated, thanks!

  • Other Network Infrastructure Subjects
1 REPLY
New Member

Re: The 2621 route can't recognize the NAT IP address

Thank you, I did try but failed... :-P,It also can't resolve the problem about static NAT,anyway ,thank you for your suggestion.

BTW, about half a year ago, the same issue happened on our Windows2000 RRAS system(it acted as a software router)--only the NAT with primary IP which is combinded on NIC work .

This issue have been updated to my ISP, It seems there is something wrong with their fiber switch......

99
Views
0
Helpful
1
Replies
This widget could not be displayed.