Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

The isdn Number thas'nt appear in the show isdn active

Hi i have a probleme that same sites acces to a central routeur (7206 with the ios c7200-ik9s-mz.122-1.bin) with ISDN like backup and i want to make same change on the configuration but i need all isdn number and the customer does not have theme all so the betteer solution is the pic up theses number on the show isdn active but i can't view it in the 7206 so please if you know the correct ios image reply to me!

Tx

5 REPLIES
Cisco Employee

Re: The isdn Number thas'nt appear in the show isdn active

On 7206, you want to know the calling number of the renote site's BRI lines..right?

show isdn active will give you calling number and called number for the active connection only. You need to use "show isdn history" command to have those details for the last 15 mins (configurable).

BUT for all of the above commands to show you calling number, you need to have caller ID enabled on the lines receiving the calls on 7206 router. If the callerid is not presented by telco when the call comes in to 7206, it will not be logged umder any show isdn history/active commands.

New Member

Re: The isdn Number thas'nt appear in the show isdn active

Hi Patel

If the number id of the BRI's line isn't active from the teleco company i can't use it in the dialer caller command line!!! but it works and whene i debug isdn event i have messages like is connected to SITENAME and in the sh isdn active i have like this

--------------------------------------------------------------------------------

ISDN ACTIVE CALLS

--------------------------------------------------------------------------------

Call Calling Called Remote Seconds Seconds Seconds Charges

Type Number Number Name Used Left Idle Units/Currency

--------------------------------------------------------------------------------

In ---N/A--- ---N/A--- +ADIDACL036 143 18 101

In ---N/A--- ---N/A--- +ZNIKACL143 121 0 119

In ---N/A--- ---N/A--- SALECL086 88 33 86

So i'm sure that the id number is active by the teleco company but it these not apear in the sh isdn active

Tx

Cisco Employee

Re: The isdn Number thas'nt appear in the show isdn active

You need to have "debug isdn q931" turned on to see that the caller id and the called number is included in the SETUP message when the call is received on bri line or not. so turn on that debug and post it here with running config.

New Member

Re: The isdn Number thas'nt appear in the show isdn active

Hi i send you here the debug isdn q931 and the essential of the configuration because its to long

isdn debug

3w4d: %LINK-3-UPDOWN: Interface Serial2/0:6, changed state to up

3w4d: ISDN Se2/0:15: TX -> CALL_PROC pd = 8 callref = 0xB485

3w4d: Channel ID i = 0xA98387

3w4d: ISDN Se2/0:15: TX -> CONNECT pd = 8 callref = 0xB485

3w4d: Channel ID i = 0xA98387

3w4d: ISDN Se2/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x3485

3w4d: ISDN Se2/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0xDAF, bchan 6, dsl 0

3w4d: %DIALER-6-BIND: Interface Se2/0:6 bound to profile Di86

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0:9, changed state to down

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0:6, changed state to up

3w4d: %ISDN-6-CONNECT: Interface Serial2/0:6 is now connected to SALECL086

3w4d: ISDN Se2/0:15: RX <- DISCONNECT pd = 8 callref = 0x3479

3w4d: Cause i = 0x8090 - Normal call clearing

3w4d: %ISDN-6-DISCONNECT: Interface Serial2/0:7 disconnected from OUEZZANECL049, call lasted 159 seconds

3w4d: %LINK-3-UPDOWN: Interface Serial2/0:7, changed state to down

3w4d: %DIALER-6-UNBIND: Interface Se2/0:7 unbound from profile Di49

3w4d: ISDN Se2/0:15: TX -> RELEASE pd = 8 callref = 0xB479

3w4d: ISDN Se2/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x3479

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0:7, changed state to down

configuration

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname DSI_7206

!

card type e1 3

logging rate-limit console 10 except errors

no logging console

aaa new-model

aaa authentication login default local

aaa authorization exec default local

enable secret xxxxx

!

username CNCA password xxxxx

!

controller E1 2/0

pri-group timeslots 1-31

!

!

interface Serial2/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

cdapi buffers regular 0

cdapi buffers raw 0

cdapi buffers large 0

priority-group 1

no cdp enable

ppp authentication chap

!

!

interface Dialer7

description BACKUP TO KENITRAELISACR007

ip address 172.16.7.5 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name KENITRAELISACR007

dialer caller 037320015

dialer-group 1

pulse-time 0

ppp authentication chap

!

access-list 199 deny eigrp any any

access-list 199 permit ip any any

dialer-list 1 protocol ip list 199

thanks

Cisco Employee

Re: The isdn Number thas'nt appear in the show isdn active

SETUP message, when the call comes in to NAS, is missed in the debug. You may not have copied it from the debug. Pl. visit the following url

http://www.cisco.com/warp/customer/471/isdn_q931_ts.html#initiate

which explains the isdn signalling at layer 3 in detail. Also it has debug examples to see the calling and called number in SETUP messages.

Anyway post the SETUP message from the debug on a router/NAS reives the call.

240
Views
0
Helpful
5
Replies
CreatePlease login to create content