Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

too many LINK-3 error on Cat3750

Hey everybody,

we have around 25 Cat3750 switches on one site and ALL of them have logs full of LINK-3 updown error in 5-30 second intervalls:

Dec 9 12:58:24.084 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 12:58:25.082 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 12:58:30.551 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 12:58:31.558 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 14:39:26.214 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 14:39:27.212 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 14:39:29.871 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 14:39:30.878 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 14:42:03.947 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 14:42:04.946 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 14:42:07.563 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 14:42:08.569 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 14:43:35.133 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 14:43:36.131 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 14:43:38.245 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 14:43:39.252 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 14:44:08.143 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 14:44:09.141 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 14:44:11.800 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 14:44:12.807 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 16:23:28.361 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 16:23:29.359 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 16:23:32.018 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 16:23:33.025 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 16:28:20.172 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 16:28:21.170 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 16:28:23.787 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 16:28:24.794 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 9 16:30:00.694 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to down

Dec 9 16:30:01.692 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to down

Dec 9 16:30:03.798 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/23, changed state to up

Dec 9 16:30:04.804 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/23, changed state to up

Dec 13 09:51:28.562 CET: %LINK-3-UPDOWN: Interface FastEthernet1/0/27, changed state to down

Strange thing is that ALL those 25 switches have the the same problem.

From what I found in documentation LINK-3 error is either a configuration change on interface or just a message that the computer on the other side went down or up. Funny thing is that there are very robust servers behind these switches, so I seriously doubt server issue.

Anybody has an idea about this?

Thanks a lot.

4 REPLIES
New Member

Re: too many LINK-3 error on Cat3750

Is auto mdix disabled?

Don't rule out the servers. Are the servers using multiple NICs with loadbalancing or failover? I have seen that stuff cause more than one strange problem.

Did you do a "switchport host" command on all of the server ports?

Did you check cabling?

-Mark

New Member

Re: too many LINK-3 error on Cat3750

Thanks for reply,

basically the configuration of each interface is similar to this:

show run int Fast1/0/21

Building configuration...

Current configuration : 161 bytes

!

interface FastEthernet1/0/21

switchport access vlan 67

switchport mode access

speed 100

duplex full

spanning-tree portfast

end

To answer your questions:

No auto mdix is not disabled.....you think it be caused by this?

Yes, all the servers have teaming cards in failover modes. Each NIC in the team goes into different switch. (at least I hope so, did you experience problems also with failover mode teaming? I know that loadbalancing teaming could be really nasty stuff...)

No I did not check the cabling - I thought this could not be the connected with cabling, as the this affects whole site...but it is good point I will try to make a spot check

Yes all ports are "switchport host"

New Member

Re: too many LINK-3 error on Cat3750

You said auto mdix is not disabled. Are these 3750s stacked with the stacking cables in the back? If so I have seen automdix cause problems throughout the entire stack when one port does its auto thing. Cabling might attribute to this if one cable is internittent.

Failover on the server NICs should be ok but you may want to make sure the drivers are the latest.

-Mark

Purple

Re: too many LINK-3 error on Cat3750

check for errors on the interfaces . Also check the server nics , you have the switch hardcoded to 100/full so the server nics "MUST" be hardcoded to 100/full if they were left as "auto" this could cause this problem.

194
Views
5
Helpful
4
Replies
CreatePlease to create content