Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Too many VLANs in the switch

Hello friends. I have a Switch WS-C2950-24. It has 3 trunks links. I works with others switches and all have configured vtp mode transparent so I have to create one vlan in each of them every time i want to install. I don´t have a core switch that handle all vlans. yestreday I was configuring a new vlan and the switch showed me the following advertisment:

###################################

Proposed configuration has too many VLANs for this device's core memory

resources. Either reduce the number of VLANs proposed or use another VTP

device to configure database. (The latter will cause this device to enter

TRANSPARENT mode automatically if propagated to it.)

APPLY VLAN changes failed.

###################################

What can i do for create more vlans? Do I have to change the structure of the switches? Any suggestions?

Regards,

Charlie K.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Too many VLANs in the switch

Hello Charlie,

your switch has the Standard Image, which only supports 64 VLANs. Unfortunately, the switch is not upgradable to the Enhanced Image, which supports, I believe, 256 VLANs.

One solution would be to create Multiple Spanning Tree (MST) instances, which basically means grouping VLANs together and thereby decreasing the number of spanning tree instances. Let´s say you want to group VLAN 5 through 10 together in one instance, you would configure the following:

Switch(config)# spanning-tree mst configuration

Switch(config-mst)# instance 1 vlan 5-10

Switch(config-mst)# name Instance1

Switch(config-mst)# revision 1

Switch(config-mst)# exit

Switch(config)#end

With regard to your setup, I wonder if there might be a way to configure VTP anyway. Do you really need all VLANs on all switches ? Try and configure the trunks to allow only the VLANs needed, e.g.:

switchport trunk allowed vlan 1,2,3

Or configure VTP Pruning (which you would enable on the VTP server and which would only send VLAN information across the trunk to the switches where those VLANs are actually configured...

HTH,

GP

6 REPLIES
VIP Purple

Re: Too many VLANs in the switch

Hello Charlie,

your switch has the Standard Image, which only supports 64 VLANs. Unfortunately, the switch is not upgradable to the Enhanced Image, which supports, I believe, 256 VLANs.

One solution would be to create Multiple Spanning Tree (MST) instances, which basically means grouping VLANs together and thereby decreasing the number of spanning tree instances. Let´s say you want to group VLAN 5 through 10 together in one instance, you would configure the following:

Switch(config)# spanning-tree mst configuration

Switch(config-mst)# instance 1 vlan 5-10

Switch(config-mst)# name Instance1

Switch(config-mst)# revision 1

Switch(config-mst)# exit

Switch(config)#end

With regard to your setup, I wonder if there might be a way to configure VTP anyway. Do you really need all VLANs on all switches ? Try and configure the trunks to allow only the VLANs needed, e.g.:

switchport trunk allowed vlan 1,2,3

Or configure VTP Pruning (which you would enable on the VTP server and which would only send VLAN information across the trunk to the switches where those VLANs are actually configured...

HTH,

GP

New Member

Re: Too many VLANs in the switch

Hi GP, how are you? Thank you very much for your reply. I will try to apply the configurationt that you described me but i wanto yo to know more details of my configuration:

In that switch there are 4 trunk ports:

interface FastEthernet0/5

switchport trunk allowed vlan 1,52-68,100,103-107,1002-1005

interface FastEthernet0/9

switchport mode trunk (this have 7 vlans)

interface FastEthernet0/15

switchport trunk allowed vlan 1,4,5,103-107,110-130,1002-1005

switchport mode trunk

interface FastEthernet0/23

switchport trunk allowed vlan 1,70-80,100,110-130,1002-1005

I give you a picture of the structure (attachments),

Red Links: Fiber

Blue Links: Ethernet

Black Links: Ethernet

Red Circle: Switch with problems.

If you have more details, just tell me. Than you very much for your help.

Charlie K.

Purple

Re: Too many VLANs in the switch

You might want to take a look at your whole setup , can't imagine a configuration where you would need 64 vlans in a 2950 . Thats a lot . You would need a 4500,3750 or 6500 to propagate that many .

New Member

Re: Too many VLANs in the switch

Hi Glen, how are you? Thank you very much for your reply. I will try to apply the configurationt that you described me but i wanto yo to know more details of my configuration:

In that switch there are 4 trunk ports:

interface FastEthernet0/5

switchport trunk allowed vlan 1,52-68,100,103-107,1002-1005

interface FastEthernet0/9

switchport mode trunk (this have 7 vlans)

interface FastEthernet0/15

switchport trunk allowed vlan 1,4,5,103-107,110-130,1002-1005

switchport mode trunk

interface FastEthernet0/23

switchport trunk allowed vlan 1,70-80,100,110-130,1002-1005

I give you a picture of the structure (attachments),

Red Links: Fiber

Blue Links: Ethernet

Black Links: Ethernet

Red Circle: Switch with problems.

If you have more details, just tell me. Thank you very much for your help.

Charlie K.

New Member

Re: Too many VLANs in the switch

Charlie,

How many vlans do you have in total?

Your network seems to be complicated because all your switches are in transparent mode.Can't you configure one or two switches as VTP server , all other switches as VTP client and ofcourse all of them in the same domain? Then Implement VTP pruning and mst?

This will also make management of the lan easier.Any addition/change will be simplified.

Purple

Re: Too many VLANs in the switch

I guess I am a little confused , you say you are running transparent ???? How or why would you need 64 vlans on a switch that small ??? Are you sure you are not running client/server sounds like a switch above this is propagating many vlans down to it . Try "manually pruning off all vlans not needed down the trunk links with the switchport allowed vlan XXX command.

1998
Views
9
Helpful
6
Replies