Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Traffic-shape vs Rate-limit

Good morning. I have a router 2610 with one 1 Ethernet and 1 Serial interface. I have 10 clients, each of them are connecting with Internet through the router ethernet and have 4 ip's, one in the server of the client, and the other in the ethernet as a secondary ip.

The questions are:

How can I do to control de output traffic of the clients transmitting to my ethernet?

What is better, a traffic shape in the ethernet or serial? a rate-limit?

That is the difference between Traffic-shape and Rate-limit?

Sometimes the cpu proccess increases, but i could controll it through memory re-assignment. I want that you help me please with some helpful information to controll de traffic. Than you very much for your attention,

Regards,

Charlie

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Traffic-shape vs Rate-limit

Hello Charlie,

I will try and answer your questions:

1. In general, you want to put the ACL as close to the source as possible, otherwise all traffic will traverse the router first, and indeed unnecessarily increase CPU and memory utilizzation

2. I think you can only set the excess-burst-size to 0

3. As I undertstand it, the difference is similar to applying access lists inbound and outbound. Inbound is preferred because it is closer to the source...

HTH,

GP

3 REPLIES
VIP Purple

Re: Traffic-shape vs Rate-limit

Hello Charlie,

here is a brief explanation of the differences between both:

(Generic)Traffic Shaping allows you to control how fast packets are sent out an interface, any interface. You might want to do this to avoid congestion either locally or elsewhere in your network, for example if you have a network with different access rates or if you are restricting some traffic to a fraction of the available bandwidth. For example, if one end of the link in a Frame Relay network is 256 Kbps and the other end of the link is only 128 Kbps, sending packets at 256 Kbps at the very least causes congestion.

Committed Access Rate (CAR) has two functions:

Packet Classification, using IP Precedence and QoS group setting

Access Bandwidth Management, through rate limiting

So CAR is basically the input side of Traffic Shaping (which we've talked about somewhat in a prior Frame Relay article).

Traffic is sequentially classified using pattern matching specifications, just like access lists, on a first-match basis. The pattern matched specifies what action policy rule to use, based on whether the traffic conforms . That is, if traffic is within the specified rate, it conforms, and is treated one way. Non-conforming (excess) traffic can be treated differently, usually either by giving it lower priority or by dropping it. If no rule is matched, the default is to transmit the packet. This allows you to use rules to rate limit some traffic, and allow the rest to be transmitted without any rate controls.

In your situation, it would not make much of a difference wether you would use CAR or GTS. You also could configure Class-Based Weighted Fair Queuing.

Here is a configuration example for each option.

Generic Traffic Shaping

access-list 101 permit ip host 192.168.1.1 any

interface Ethernet0

traffic-shape group 101 1000000 125000 125000

This would limit the bandwidth for IP address 192.168.1.1 to 1000000 bits, with a burst size of 12500 bits, and an excess-burst of 125000 bits.

Committed Access Rate (CAR)

interface Ethernet0

rate-limit input access-group 101 1000000 1200 1200 conform-action transmit exceed-action drop

!

access-list 101 permit ip host 192.168.1.1 any

Class-Based Weighted Fair Queuing (CBWFQ)

class-map match-all Host_A

match access-group 101

!

policy-map LIMIT

class Host_A

bandwidth percent 10

!

access-list 101 permit ip host 192.168.1.1 any

!

interface Ethernet0

service-policy input LIMIT

You could configure a class for each host and limit bandwidth accordingly. The keywords available depend on your platform and IOS...

Let me know if you have trouble configuring this.

Regards,

GP

New Member

Re: Traffic-shape vs Rate-limit

Thank you very much for your comments GP, they are very helpful for me. I have more questions, i hope that you can help me please:

1.- In the GTS configuration, what is the difference to apply the ACL on the ethernet or serial? Maybe cpu increasing?

2.- In the GTS configuration, if i would like a fixed bandwidth, withou burst size and an excess-burst, how can i configure?

3.- In CAR configuration, what is the difference between rate-limit input and output, what is the difference to apply the command on the ethernet or serial?

Thank you very much again.

Regards,

Charlie K.

VIP Purple

Re: Traffic-shape vs Rate-limit

Hello Charlie,

I will try and answer your questions:

1. In general, you want to put the ACL as close to the source as possible, otherwise all traffic will traverse the router first, and indeed unnecessarily increase CPU and memory utilizzation

2. I think you can only set the excess-burst-size to 0

3. As I undertstand it, the difference is similar to applying access lists inbound and outbound. Inbound is preferred because it is closer to the source...

HTH,

GP

2928
Views
0
Helpful
3
Replies
CreatePlease to create content