Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

jcb
New Member

Traffic shaping/limiting 3560

How can i shape/limit the interface of an cisco 3560 not to allow more than

8mbit of outgoing and ingoing traffic?

Will something like this work:

class-map match-all any

match ip dscp default

!

!

policy-map 8mbps

class any

police 8388500 8000 exceed-action drop

interface FastEthernet0/13

switchport access vlan 940

switchport mode access

service-policy input 8mbps

srr-queue bandwidth shape 12 12 12 12

Jo Christian Buvarp

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Traffic shaping/limiting 3560

Hi andrea,

as there was no information on additional configuration of the switch - and there IS additional configuration - I just could not rule out, that there is traffic sorted into all 4 queues. This is why I wrote "up to 24 Mbps".

Regards, Martin

10 REPLIES
Blue

Re: Traffic shaping/limiting 3560

your config looks like it's well on its way although it seems you may need a little more.

to verify your configuration and any other items you may have missed, please see the following link for 3560 bandwidth shaping:

http://www.cisco.com/en/US/products/hw/switches/ps5528/products_configuration_guide_chapter09186a00801e85dd.html#1200681

Silver

Re: Traffic shaping/limiting 3560

Jo Christian,

You are matching traffic on DSCP with a zero value, which is valid configuration. However, you can classify ALL trafic with the class-default command within a policy-map.

policy-map police

class class-default

police 8000000 8000 exceed-action drop

interface FastEthernet0/13

service-policy input police

service-policy output police

Verify your work with the "show policy-map interface FastEthernet0/13" command.

HTH

--Leon

* Please rate ALL posts.

jcb
New Member

Re: Traffic shaping/limiting 3560

service-policy output police isn't supported on the 3560..

That's why I wonder if my config will work on "output" to..Pretty sure it will be ok for input :)

Silver

Re: Traffic shaping/limiting 3560

If you not sure about this policy, use rate-limit to limit the traffic in and out direction.

bye

FCS

Please rate me if I helped.

jcb
New Member

Re: Traffic shaping/limiting 3560

Do you have en example on how I can do this with rate-limit on an 3560 ?

Silver

Re: Traffic shaping/limiting 3560

Here you can read about rate-limit:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_command_reference_chapter09186a0080087f26.html

interface configs:

rate-limit input 8388608 1572864 3145728 conform-action transmit exceed-action drop

rate-limit outpu 8388608 1572864 3145728 conform-action transmit exceed-action drop

//

normal burst = configured rate * (1 byte)/(8 bits) * 1.5 seconds

extended burst = 2 * normal burst //

bye

FCS

Please rate me if I helped.

Re: Traffic shaping/limiting 3560

Hi,

your input config is ok and will limit traffic to 8 Mbps. on the output side, traffic is sorted into 4 queues. With shaped output, which you configured, each of the queues will be limited to 1/12 = approx. 8 Mbps. This will give you a total of up to 24 Mbps on output depending on how you sort traffic into the 4 queues.

If you can make sure all traffic is marked as "default", this should give you the desired result. You can also assign traffic to queues following

http://www.cisco.com/en/US/products/hw/switches/ps5528/products_configuration_guide_chapter09186a00801e85dd.html#1163863

with the command

mls qos srr-queue output dscp-map queue queue-id threshold threshold-id dscp1...dscp8

Hope this helps! Please rate all posts.

Regards, Martin

jcb
New Member

Re: Traffic shaping/limiting 3560

Thank you :)

Btw, will a "mls qos cos override" make sure that all the traffic goes into the same queue?

Silver

Re: Traffic shaping/limiting 3560

I'm sorry Martin, for this stupid question,

but why 24Mbps? Normally with that conf the priority queue is unused?

thanks

Andrea

Re: Traffic shaping/limiting 3560

Hi andrea,

as there was no information on additional configuration of the switch - and there IS additional configuration - I just could not rule out, that there is traffic sorted into all 4 queues. This is why I wrote "up to 24 Mbps".

Regards, Martin

3695
Views
18
Helpful
10
Replies