Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Trouble again with router

I have had troubles getting this to work now from console i can now ping anything on the net, before i couldnt, but now my pc from CMD cannot ping anything past the router here is the conf , let me know if i did something wrong,no worried about security yet till i get it working,thanks

---------------------------------------------------

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

memory-size iomem 15

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

!

ip dhcp pool test1

network 192.168.2.0 255.255.255.0

domain-name porter

dns-server 192.168.0.80 (= netgear firewall to internet)

default-router 192.168.1.20 (=inside int)

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

interface Ethernet0

ip address dhcp (= 192.168.0.2 )

ip nat outside

full-duplex

!

interface FastEthernet0

ip address 192.168.1.20 255.255.255.0

ip nat inside

speed auto

!

router rip

network 192.168.0.0

network 0.0.0.0

!

ip nat pool test 192.168.3.20 192.168.3.25 netmask 255.255.255.0

ip classless

no ip http server

ip pim bidir-enable

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router#

  • Other Network Infrastructure Subjects
2 REPLIES
VIP Purple

Re: Trouble again with router

Hello,

a couple of things:

Your DHCP server dishes out addresses from the range 192.168.2.0/24, yet your default gateway is 192.168.1.20, which is not from the same range, so it will not work, meaning that effectively your hosts will not have a working default gateway.

So either change your address range to:

ip dhcp pool test1

network 192.168.1.0 255.255.255.0

or change the IP address of your interface FastEthernet0 to an address from the range 192.168.2.0

Also, you need your inside source statement for NAT to work:

ip nat inside source list 1 pool test

!

access-list 1 permit 192.168.2.0

HTH,

Georg

New Member

Re: Trouble again with router

Ok...i added them in and still didnt work, hwtas funny from with in the console i can ping anything, but from pc i cant get passed the outside interface,but can ping the outside interface.

here is how it is setup,

cable modem>firewall> router> pc w/crossover

firewall ip = 192.168.0.80 LAN, wan = dhcp from cable

router outside interface = 192.168.0.2

inside interface = 192.168.1.1

pc = 192.168.1.2

now the firewall is just a netgear firewall router,

and my connection is cable via dhcp. is there anything im doing wrong or could try. Is it cause of two routers, this is giving me a headache, i have configured ospf,igrp ,rip ,router to router with switches in place and never had any problem, of course it was 2500 series and 1900 catalyst. this is the 1721 router, which it should be this hard to get working, im not even trying any secuity yet. thanks for any info.

92
Views
0
Helpful
2
Replies
This widget could not be displayed.