Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Trouble with Dynamic NAT

I have a unique problem. I have recently installed a cable router uBR 905 at a customer location. It has IOS 12.2(4)T release fc1. I configured dynamic NAT for a Class C local IP pool onto a global pool with 2 IP addresses from a subnet of 8 IP's. It is observed that the router NAT process stops every morning though the router is online. 'sh ip nat translation' command does not show any active translations. The router though is accessible from the network side and has to be rebooted for the NAT to work. It then works fine for the day but again the next morning the same problem arises. The CPU Utilisation is also not very high...of the order of 5%. The electrical voltages when checked are also according to specifications.

I have installed 2 other routers with the same hardware and IOS versions but they have never given such a problem. Could anybody give me a clue as to why this could happen?? What could be the probable reasons??

2 REPLIES
Bronze

Re: Trouble with Dynamic NAT

hope using route-maps with NAT may solve your problem.

ip nat inside source route-map test pool global overload

ip nat pool global 10.1.1.1 10.1.1.1 netmask 255.255.255.240

route-map test permit 10

match ip adress 100

access-list 100 permit ip 10.2.2.0 0.0.0.255 any

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

And also you can try to upgrade your IOS and test it.

New Member

Re: Trouble with Dynamic NAT

Dear Friend,

Thanx for your help! But I dont think route maps could help out, as I do have matches on the access-list when I execute the 'sh ip access-lists' command. Only the NATing does not happen.

Although changing the IOS could be tried out. I shall definitely check that option and let you know.

Thanx for your help anyways!!

121
Views
0
Helpful
2
Replies
CreatePlease to create content