Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

trouble with isdn ddr

I am trying to get a 1720 to use a isdn bri link for traffic to one ip address. However I can't get it to lift the line. If I manually lift the line it routes the packet ok. I used debug for isdn events and ppp authentication and dialer and got no output. the only response was from DEBUG IP PACKET 101 the result of which is below with the config.

All help appreciated

sh run

Building configuration...

Current configuration : 2636 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname bort

!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 49.49.49.49 255.255.255.255

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface FastEthernet0

ip address 56.35.31.1 255.255.128.0

speed auto

half-duplex

no cdp enable

!

interface Serial0

no ip address

ip helper-address 56.200.127.255

ip directed-broadcast

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0.16 point-to-point

description Backup PVC to HQ

bandwidth 256

ip address 56.5.49.129 255.255.255.128

ip directed-broadcast

ip ospf authentication-key cisco

ip ospf cost 4000

no cdp enable

frame-relay class data

frame-relay interface-dlci 16

frame-relay payload-compression packet-by-packet

!

interface Serial0.17 point-to-point

description Primary link to longman

bandwidth 256

ip address 56.5.49.1 255.255.255.128

ip directed-broadcast

ip ospf authentication-key cisco

no cdp enable

frame-relay class data

frame-relay interface-dlci 17

frame-relay payload-compression packet-by-packet

!

interface Dialer1

ip address 56.3.10.2 255.255.255.128

encapsulation ppp

dialer pool 1

dialer remote-name INVER

dialer string .........

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname I_BORT

ppp chap password 7 121016131C535B162524

!

router ospf 100

log-adjacency-changes

area 0.0.0.49 authentication

area 0.0.0.49 stub

area 0.0.0.100 authentication

area 0.0.0.100 nssa

redistribute connected metric 2000 metric-type 1 subnets

network 56.5.49.1 0.0.0.0 area 0.0.0.49

network 56.5.49.129 0.0.0.0 area 0.0.0.100

network 56.35.31.1 0.0.0.0 area 0.0.0.49

!

--More-- ip classless

ip route 0.0.0.0 0.0.0.0 56.3.10.1

ip route 56.200.4.18 255.255.255.255 56.3.10.1

no ip http server

!

!

!

map-class frame-relay data

no frame-relay adaptive-shaping

frame-relay cir 192000

frame-relay bc 192000

frame-relay be 64000

frame-relay mincir 192000

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx deny

no cdp run

snmp-server community public RO

snmp-server community private RW

snmp-server host 56.200.91.65 private

banner motd ^Cbort_router^C

!

line con 0

line aux 0

line vty 0 4

login

!

end

bort#debug isdn events

ISDN events debugging is on

bort#debug ppp authentication

PPP authentication debugging is on

bort#term mon

bort#ping 56.200.4.8 18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 56.200.4.18, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

bort#debug ip packet 101

IP packet debugging is on for access list 101

bort#

bort#debug ip packet 101

IP packet debugging is on for access list 101

bort#ping 56.200.4.18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 56.200.4.18, timeout is 2 seconds:

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, sending

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, encapsulation failed

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, sending

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, encapsulation failed

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, sending

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, encapsulation failed

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, sending

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, encapsulation failed

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, sending

9w1d: IP: s=56.3.10.2 (local), d=56.200.4.18 (Dialer1), len 100, encapsulation failed

Success rate is 0 percent (0/5)

bort#

5 REPLIES
Silver

Re: trouble with isdn ddr

What is the ip of the host on the remote side ? is it 56.200.4.18 ? If it is you are not on the same subnet .

Also check the route back

New Member

Re: trouble with isdn ddr

If you show your ISDN status does your Layer 2 report back that your

SPIDs are valid? does it show the carrier has got a valid TEI?

If you show your dialer 1 does he show up and spoofing?

Also, you are going to have some OSPF problems, you've created an ABR that isn't connected via area 0.

~rlc

CCNP, CCDA, CNE

New Member

Re: trouble with isdn ddr

Thanks for your prompt response. I am in the UK so the isdn flavour is basic-net3 (no spid's) I've included the output SH ISDN STATUS and SH DIALER1 They look fine and as I say it all works fine if I manually lift the line.

As to the OSPF area 0.0.0.0 is attached to the core router but not on the sub-interfaces attached to this router.

bort#sh isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 116, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Number of L2 Discards = 0, L2 Session ID = 64

Total Allocated ISDN CCBs = 0

bort#

bort#sh int dialer1

Dialer1 is up (spoofing), line protocol is up (spoofing)

Hardware is Unknown

Internet address is 56.3.10.2/25

MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

DTR is pulsed for 1 seconds on reset

Last input never, output never, output hang never

Last clearing of "show interface" counters 9w1d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 42 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

22322 packets input, 2459897 bytes

5293 packets output, 691983 bytes

Bronze

Re: trouble with isdn ddr

It looks like the route to the dialer is working. The encap failed is normal on a ddr line until it comes up. Turn on all isdn debugs and debug dialer and see if it is trying to call and what is happening.

New Member

Re: trouble with isdn ddr

Here is the result of the debugging you suggested.

bort#debug isdn events

ISDN events debugging is on

bort#debug isdn l2-Sock-Proc

ISDN L2 Socket Process packets debugging is on

bort#debug isdn q921

ISDN Q921 packets debugging is on

bort#debug isdn q931

ISDN Q931 packets debugging is on

bort#debug dialer events

Dial on demand events debugging is on

bort#debug dialer forwarding

Dialer forwarding events debugging is on

bort#debug dialer map

Dial on demand dynamic dialer maps debugging is on

bort#debug dialer packets

Dial on demand packets debugging is on

bort#debug dialer map

Dial on demand dynamic dialer maps debugging is on

bort#term mon

bort#ping 56.200.4.18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 56.200.4.18, timeout is 2 seconds:

9w2d: Di1 DDR: ip (s=56.3.10.2, d=56.200.4.18), 100 bytes, outgoing interesting

(ip PERMIT).

9w2d: Di1 DDR: ip (s=56.3.10.2, d=56.200.4.18), 100 bytes, outgoing interesting

(ip PERMIT).

9w2d: Di1 DDR: ip (s=56.3.10.2, d=56.200.4.18), 100 bytes, outgoing interesting

(ip PERMIT).

9w2d: Di1 DDR: ip (s=56.3.10.2, d=56.200.4.18), 100 bytes, outgoing interesting

(ip PERMIT).

9w2d: Di1 DDR: ip (s=56.3.10.2, d=56.200.4.18), 100 bytes, outgoing interesting

(ip PERMIT).

Success rate is 0 percent (0/5)

92
Views
0
Helpful
5
Replies
CreatePlease login to create content