Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trouble with ISDN

Hello:

I hope somebody out there can help ... I'm baffled. We try to ISDN dial a remote party, but although the router dials, the connection fails due to "unassigned / unallocated" number. When the other party attempts to dial us, a connection is made, but then shuts down due to "invalid call reference value". Below is the config of the router on my end, following which are exerpts from the debugs showing the failures.

Thanks in Advance.

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname toronto2

!

boot system flash c800-sy6-mw.122-4.T.bin

enable password 7 xxxxxxxxxxxxxxxxxxxxxxxx

!

username dyedur password 7 xxxxxxxxxxxxxxxxxxxxxxxxxx

ip subnet-zero

!

ip accounting-threshold 1028

isdn switch-type basic-ni

!

!

!

interface Loopback0

ip address 172.17.1.1 255.255.255.0

interface Ethernet0

no ip address

ip accounting output-packets

no ip mroute-cache

!

interface BRI0

ip address 142.106.225.179 255.255.255.240

ip accounting output-packets

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 2000000

dialer fast-idle 2000000

dialer enable-timeout 2

dialer wait-for-carrier-time 300

dialer map ip 142.106.225.178 name MCCR broadcast 4165553142

dialer map ip 142.106.225.178 name MCCR broadcast 4165552036

dialer load-threshold 1 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 416555845900

isdn spid2 416555897800

no fair-queue

ppp multilink

!

no ip http server

ip classless

ip route 142.106.87.29 255.255.255.255 BRI0

ip route 142.106.87.29 255.255.255.255 142.106.225.178

ip pim bidir-enable

!

access-list 101 remark defining interesting traffic

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

!

line con 0

stopbits 1

line vty 0 4

password 7 xxxxxxxxxxxxxxxxxxxxxxxx

login

!

!

end

===================

ERROR IN DEBUG WHEN WE CALL OUTBOUND TO OTHER SIDE

01:46:34: ISDN BR0: process_bri_call(): call id 0x8001, called_number 4165553142, speed 64, call type DATA

01:46:146028888064: CCBRI_Go Fr Host InPkgInfo (Len=25) :

01:46:146028929024: 1 0 1 80 1 0 4 2 88 90 18 1 83 2C A 34 31 36 39 37 37 33 31 34 32

01:46:146028929024:

01:46:146038529972: CC_CHAN_GetIdleChanbri: dsl 0

01:46:146028929024: Found idle channel B1

01:46:34: ISDN BR0: TX -> INFOc sapi=0 tei=79 ns=41 nr=41 i=0x08010105040288901801832C0A34313639373733313432

01:46:34: SETUP pd = 8 callref = 0x01

01:46:34: Bearer Capability i = 0x8890

01:46:34: Channel ID i = 0x83

01:46:34: Keypad Facility i = '4169773142'

01:46:34: ISDN BR0: RX <- RRr sapi=0 tei=79 nr=42

01:46:34: ISDN BR0: RX <- INFOc sapi=0 tei=79 ns=41 nr=42 i=0x08018102180189952A1980880A3431363937373331343280010A800114800114800114

01:46:34: CALL_PROC pd = 8 callref = 0x81

01:46:34: Channel ID i = 0x89

01:46:34: Locking Shift to Codeset 5

01:46:34: Codeset 5 IE 0x2A i = 0x80880A, '4169773142', 0x80010A800114800114800114

01:46:34: ISDN BR0: TX -> RRr sapi=0 tei=79 nr=42

01:46:34: ISDN BR0: RX <- INFOc sapi=0 tei=79 ns=42 nr=42 i=0x0801814508028281

01:46:34: DISCONNECT pd = 8 callref = 0x81

01:46:34: Cause i = 0x8281 - Unallocated/unassigned number

==================

ERROR IN DEBUG WHEN OTHER SIDE TRIES TO CALL US.

4d03h: ISDN BR0: Incoming call id = 0x2DEA, dsl 0

4d03h: ISDN BR0: LIF_EVENT: ces/callid 1/0x2DEA HOST_INCOMING_CALL

4d03h: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

4d03h: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

4d03h: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call type is DATA

4d03h: ISDN BR0: Event: Received a DATA call from 94169773142 on B1 at 64 Kb/s

4d03h: ISDN BR0: Event: Accepting the call id 0x2DEA

4d03h: ISDN BR0: RM returned call_type 0 resource type 0 response 2

4d03h: CCBRI_Go Fr Host InPkgInfo (Len=9) :

4d03h: 7 0 1 2D EA 3 18 1 89

4d03h:

4d03h: ISDN BR0: isdn_send_connect(): msg 4, call id 0x2DEA, ces 1 bchan 0, call type DATA

4d03h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

4d03h: ISDN: get_isdn_service_state(): idb 0x28D71E4 bchan 2 is_isdn 1 Not a Pri

4d03h: CCBRI_Go Fr Host InPkgInfo (Len=9) :

4d03h: 4 0 1 2D EA 0 18 1 89

4d03h:

4d03h: ISDN BR0: L1 ERR IF_ACTIVE

4d03h: ISDN BR0: TX -> INFOc sapi=0 tei=89 ns=70 nr=72 i=0x0801C102180189

4d03h: CALL_PROC pd = 8 callref = 0xC1

4d03h: Channel ID i = 0x89

4d03h: ISDN BR0: RX <- RRr sapi=0 tei=89 nr=71

4d03h: ISDN BR0: TX -> INFOc sapi=0 tei=89 ns=71 nr=72 i=0x0801C107180189

4d03h: CONNECT pd = 8 callref = 0xC1

4d03h: Channel ID i = 0x89

4d03h: ISDN BR0: RX <- INFOc sapi=0 tei=89 ns=72 nr=71 i=0x0801415A080282D1

4d03h: RELEASE_COMP pd = 8 callref = 0x41

4d03h: Cause i = 0x82D1 - Invalid call reference value

4d03h: ISDN BR0: TX -> RRr sapi=0 tei=89 nr=73

4d03h: ISDN BR0: RX <- RRr sapi=0 tei=89 nr=72

4d03h: ISDN BR0: RX <- INFOc sapi=0 tei=89 ns=73 nr=72 i=0x0801415A080282D1

4d03h: RELEASE_COMP pd = 8 callref = 0x41

4d03h: Cause i = 0x82D1 - Invalid call reference value

4d03h: ISDN BR0: TX -> RRr sapi=0 tei=89 nr=74

4d03h: CCBRI_Go Fr L3 pkt (Len=8) :

4d03h: 5A 1 C1 99 8 2 82 D1

4d03h:

4d03h: L3: L3_GetUser_NLCB returned NULL, message ignored cid 0x0 cr 0xC1 ev 0x5A ces 1 dsl 0

4d03h: ISDN BR0: LIF_EVENT: ces/callid 1/0x2DEA HOST_DISCONNECT_ACK

4d03h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

3 REPLIES

Re: Trouble with ISDN

dialer map ip 142.106.225.178 name MCCR broadcast 4165553142

dialer map ip 142.106.225.178 name MCCR broadcast 4165552036

I note that for the same next hop and remote name, two numbers are being used. Can you check the same dial out debug outputs, and see if its workign fine, once you remove one dialer map.

ALso can you check if the numbers you are trying to call are valid ?? You might want to double check this with the SP.

New Member

Re: Trouble with ISDN

Hi -- and thank you for the prompt response.

Okay, the dialer map was changed so that it just included the first of the two numbers above. Again it fails, but the message(s) in the debug is different. (BTW, when the second of the two numbers was used, the router on my end didn't seem to do anything .. but I will try that again). Here is an exerpt from the debug:

1w1d: Keypad Facility i = '4169773142'.

1w1d: ISDN BR0: RX <- RRr sapi=0 tei=88 nr=12

1w1d: ISDN BR0: RX <- INFOc sapi=0 tei=88 ns=13 nr=12 i=0x0801E35A080282B2

1w1d: RELEASE_COMP pd = 8 callref = 0xE3

1w1d: Cause i = 0x82B2 - Requested facility not subscribed

1w1d: ISDN BR0: TX -> RRr sapi=0 tei=88 nr=14

1w1d: CCBRI_Go Fr L3 pkt (Len=8) :

1w1d: 5A 1 63 99 8 2 82 B2

1w1d:

1w1d: ISDN BR0: Setup was rejected, cause = 32

1w1d: ISDN BR0: LIF_EVENT: ces/callid 1/0x8063 HOST_DISCONNECT_ACK

1w1d: ISDN BR0: Error: Unfound B-channel on Disconnect_Ack - callid 0x8063

Thanks

Re: Trouble with ISDN

Hi,

Now your error code is 82B2.

B2 error codes are returned by the switch due to following reasons.

1. The spids are incorrect, or the telco has not activated the spids. This is the reason that i doubt. First check whether the spids you have entered in your router are correct. If they are correct, go to privileged mode and give a show isdn status. A sample out put would look like,

R2#sh isdn stat

Global ISDN Switchtype = basic-ni

ISDN BRI0/0 interface

dsl 0, interface ISDN Switchtype = basic-ni

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI = 65, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Spid Status:

TEI 64, ces = 1, state = 8(established)

spid1 configured, spid1 sent, spid1 valid

Endpoint ID Info: epsf = 0, usid = 70, tid = 1

TEI 65, ces = 2, state = 5(init)

spid2 configured, spid2 sent, spid2 valid

Endpoint ID Info: epsf = 0, usid = 70, tid = 2

Please not that under both the TEI, spid1 and spid2 are configured, they were sent to the switch, and they are valid too.

Check what you see on your router. If the spids are shown as not sent, you can sent them to switch, by shutting down bri interface once and bringing it back up or you can issue a "clear interface bri 0"

If none of these works - you might want to check with your telco about the spid issue.

2. A second but last reason could be due to telco switch misconfigured to receive callas at 56k. to see if the switch is accepting calls at 56k, do the following.

The following config helps in placing a call at 56 k.

In the privilege exec mode.

R2# isdn call interface bri 0/0 speed 56

get back to us with the results.

330
Views
0
Helpful
3
Replies