Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Trunk failing to come up on 2851 (over etherchannel)

Hi,

I've the config listed below and although when I check the port channel is showing up, the trunk is not.

The far end is showing the trunk as being active.

If anyone has any ideas why this is not working, please let me know,

thanks,

Mark

interface Port-channel1

no ip address

interface Port-channel1.224

description Call Manager Express VLAN

encapsulation dot1Q 224

ip address 10.14.182.70 255.255.255.192

no snmp trap link-status

interface Port-channel1.254

description Management_VLAN

encapsulation dot1Q 254

ip address 10.14.182.140 255.255.255.128

no snmp trap link-status

interface Port-channel1.666

description Native VLAN

encapsulation dot1Q 666 native

no snmp trap link-status

interface gigabitEthernet 0/0

speed 100

duplex full

channel-group 1

interface gigabitEthernet 0/1

speed 100

duplex full

channel-group 1

6 REPLIES

Re: Trunk failing to come up on 2851 (over etherchannel)

Hi Mark,

Can you update which switch you are using and if possible can you paste the output from "sh run"

Regards,

Ankur

New Member

Re: Trunk failing to come up on 2851 (over etherchannel)

Hi Ankur,

Sure thing - its a 3560, and I pasted on the following config on the switch:

interface Port-channel1

no switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 666

interface range fastethernet 0/23 – 24

speed 100

duplex full

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

Many thanks,

Mark

Silver

Re: Trunk failing to come up on 2851 (over etherchannel)

Hi Mark,

Within your Cat3560 switch configuration:

1) I would consider to add the "switchport trunk native vlan 666" command also under the "interface range fastethernet ..." heading,

2) I am bit confused why you have configured the port-channel interface as L3 ("no switchport"). As you are doing inter-vlan routing at the router I would believe that interface port-channel (Cat3560) should be set rather as L2 (switchport).

3) You may also consider to add "switchport nonegotiate" command under both int port-cahnnel and interface range headings to disable DTP frames as the router does not understand theese.

Best regards,

Antonin

New Member

Re: Trunk failing to come up on 2851 (over etherchannel)

Hi Antonin,

Thanks for the response.

1. Have done this

2. I think (as I recall) I had to do this to get it to accept the trunk commands.

3. Have done this too.

It hasn't made any differnence though. I pasted the updated switch config below:

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport mode trunk

switchport nonegotiate

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport mode trunk

switchport nonegotiate

duplex full

speed 100

channel-group 1 mode on

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport mode trunk

switchport nonegotiate

duplex full

speed 100

channel-group 1 mode on

VIP Purple

Re: Trunk failing to come up on 2851 (over etherchannel)

Hello,

AFAIK, you cannot mix FastEthernet and GigabitEthernet interfaces in a single channel. Can you try and establish the channel with FastEthernet or GigabitEthernet interfaces on BOTH sides ?

Regards,

GP

New Member

Re: Trunk failing to come up on 2851 (over etherchannel)

Hi GP,

It is using two FA on one end and two GE on the other. Possibly that's why its not working.

I've thrown in the towel now and am going to have a pair of routed links instead.

Many thanks for your help guys,

Mark

179
Views
0
Helpful
6
Replies