Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunk Issues Between a 3560G and a 1200 access point

Hi All,

I have a 1200 access point configured with 3 vlans connected to a 3560G configured with about 17 vlans.. as soon as i enable the trunk on the port on the switch where the AP is connected i lose connectivity to the AP.. attached is the config of the switch and AP .

Hope some one can help.

Kind regards

Okechi

7 REPLIES
Silver

Re: Trunk Issues Between a 3560G and a 1200 access point

Assuming you have connected the Wireless Access Point to FastEtheret0/1 your trunking configuration seems to be the culprit.

interface FastEthernet0/1

description # MRCISDAP1 #

switchport access vlan 280

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

*switchport mode access*

switchport nonegotiate

The switchport is configured to be a static access port. Port Fa0/1 which is a member of vlan 280 receives tagged fromes from the Wireless Access Point, because it is not in trunking mode these frames are discarded.

#show interface FastEthernet0/1 switchport

Configure the port to be in truning mode.

(config-if)#switchport mode trunk

HTH

--Leon

* Please rate posts.

New Member

Re: Trunk Issues Between a 3560G and a 1200 access point

The issue is this , as soon as I enable trunk using(config-if)#switchport mode trunk I lose conectivity to th AP

Purple

Re: Trunk Issues Between a 3560G and a 1200 access point

You must have matching native vlan commands on each side of the trunk link , on the switch side it would be switchport trunk native vlan XXX , on the wap side it would be under the ethernet subinterface that matches the native vlan with the "encapsulation dot1q XXX native" command , don't see either in your config

New Member

Re: Trunk Issues Between a 3560G and a 1200 access point

Sorry that was the old config ... The four interfaces below are connected to the AP... with trunks enable on the interfaces .. i lose connectivity to the AP.

interface FastEthernet0/1

description # MRCISDAP1 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/2

description # MRCISDAP2 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/3

description # MRCISDAP3 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/4

description # MRCISDAP4 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

New Member

Re: Trunk Issues Between a 3560G and a 1200 access point

Sorry that was the old config ... The four interfaces below are connected to the AP... with trunks enable on the interfaces .. i lose connectivity to the AP.

interface FastEthernet0/1

description # MRCISDAP1 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/2

description # MRCISDAP2 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/3

description # MRCISDAP3 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/4

description # MRCISDAP4 #

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,280,500,501

switchport mode trunk

switchport nonegotiate

New Member

Re: Trunk Issues Between a 3560G and a 1200 access point

You may need to configure "switchport trunk native vlan xxxx" command.

New Member

Re: Trunk Issues Between a 3560G and a 1200 access point

Thanks ssen010 it worked ... The native vlan is vlan 1 but the mgt vlan is 280.. when is made the trunk native vlan 280 it worked.. many thanks.

447
Views
9
Helpful
7
Replies
CreatePlease login to create content