Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

trunk routing

i have in a sw (3550-12T) defined 2 trunks on ports 0/2 and 0/3, with 2 routers (3725). I have also a PC on the sw in 0/5. all the 3 interfaces (pc + routers) are into the same network 192.168.200.0/24 and all in the same vlan 4. i can ping from the pc to the 2 routers, and from the routers to the pc, but i can't ping from one router to the other.

The problem, i think, is at the sw, he don't switch between the two trunk ports. It's a config problem, or it's not possible.

if not possible, how can i do what i want?

C

  • Other Network Infrastructure Subjects
6 REPLIES

Re: trunk routing

What you want to do is possible. Most likely there is a mistake in the config somewhere. I could ask you a lot of questions and not still find the answer. The easiest would it be when you upload the config of the switch and the relevant part of the routerconfigs.

Regards,

Leo

New Member

Re: trunk routing

i tryed and it work in the config with one sw and 2 routers, but

actualy my config is one sw and one router, conected like this

R 0/0 -- SW 0/2

R 0/1 -- SW 0/3

PC -- SW 0/5

pc is 192.168.200.5

sw:

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3,4,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/5

switchport access vlan 4

no ip address

!

interface Vlan4

ip address 192.168.200.10 255.255.255.0

!

R:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 4

ip address 192.168.200.5 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 4

ip vrf forwarding vr1

ip address 192.168.200.1 255.255.255.0

!

new_p_pe#ping 192.168.200.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

new_p_pe#ping 192.168.200.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.10, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

new_p_pe#ping 192.168.200.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

new_p_pe#ping 192.168.200.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

new_p_pe#

new_p_pe#ping vrf vr1 192.168.200.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

new_p_pe#ping vrf vr1 192.168.200.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

new_p_pe#ping vrf vr1 192.168.200.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

new_p_pe#ping vrf vr1 192.168.200.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.200.5, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

from the sw it works ping to all (.1,.2,.5)

from the pc works ping to all (.1,.5,.10)

from the router work ping to all except betwen interfaces

c

Re: trunk routing

The fact that you use one router instead of two changes the matter a bit.

When pinging from the router you need to know what is used as the source-adress for the ping. Suppose the PC =2, not 5.

For the rest the config is not extensive, but it should work. There is just one thing that remains a puzzle: the ip vrf command on int fa0/1:2. You did not list the related lines. Why did you put it in? As the rest seems more or less ok, this is likely to be the cause of your troubles. Try to remove it and see if it works.

Leo

New Member

Re: trunk routing

ip vrf vr1

rd 100:1

!

if i remove it i can't pun 2 interfaces into the same network, the 192.168.200.0/24

but i did not get your point about the source address

C

Re: trunk routing

About the source address: When you have two equal paths to a destination, which path does the router use? In your case, both fast eth. are the equal paths. So when pinging from the router to any network host, what is the IP-source in the ping request?

To verify a path, you normally use an extended ping and then specify the source adress.

New Member

Re: trunk routing

aha, i got your point but not i my case, i have 2 router, one real and one virtual (vr1) so when i do "ping 192.168.200.1" i have the source 192.168.200.5, and when i do "ping vrf vr1 192.168.200.5" i have source 192.168.200.1

and how do i specify the source address in the "ping" from the router???

so anyone other ideea???

C

222
Views
3
Helpful
6
Replies