Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Trunking Cisco with Nortel

I am looking for help trunking a couple of GBIC ports on a 2970 with a Nortel Passport core switch. My ports are all up, my PortChannel is up, but I cannot get any data through the trunk. Any help would be appreciated. Thanks.

9 REPLIES
VIP Purple

Re: Trunking Cisco with Nortel

Hello,

have you check Spanning-Tree? IEEE standard dictates that only a single instance of STP can exist on a device, while Cisco, as far as I know, implements PVST (Per-VLAN Spanning-Tree) as a default. You may need to modify the STP mode in the Catalyst to ensure that traffic isn't being blocked through the trunk port to the Nortel.

Can you post the VTP configuration from each switch ?

Regards,

Georg

New Member

Re: Trunking Cisco with Nortel

Are you talking about port aggregation / Ether channel from CISCO to Nortel Passport (MLT) ?

New Member

Re: Trunking Cisco with Nortel

Yes, I am. 2 ports on the Cisco with 2 ports on the Passport for 2GB trunking.

Re: Trunking Cisco with Nortel

Hi,

there might be problems with either trunking or Etherchannel (or both).

So I'd try to start Etherchannel first on an acees port (one VLAN only).

Check thet you are not using Cisco proprietary PAgP

( see http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2970/12119ea1/2970scg/swethchl.pdf for details)

and that you are able to send data.

Finally, try to establish a trunk.

Again, check that you are not using Cisco proprietary ISL.

There might be a problem with native VLAN.

See http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2970/12119ea1/2970scg/swvlan.pdf for instructions how to configure 802.1q trunks.

HTH,

Milan

New Member

Re: Trunking Cisco with Nortel

I have tried like heck to get rid of spanning tree with "no spanning-tree mode" in the global config mode. I have a very elememtary config as follows:

hostname cisco2970

!

enable secret xxxxx

!

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet0/25

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/26

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

ip address 10.1.13.250 255.255.255.0

no ip route-cache

!

ip default-gateway 10.1.13.1

ip http server

!

line con 0

line vty 0 4

password

login

line vty 5 15

password

login

!

end

Any help would be appreciated. As I said earlier, the two GBIC ports are UP and the Portchannel is UP; but I cannot ping any other address on the 10.1.13.X subnet. Thanks again.

New Member

Re: Trunking Cisco with Nortel

to successfully create a multilink trunk between a c2970 and a nortel passport, the nortel passport would have to support ieee802.3ad link aggregation. does it?

looking at your configuration, you would have to use "channel-group 1 mode active" to use the ieee802.3ad link aggregation.

i assume that the trunk between the passport and 2970 works fine with no etherchannel.

New Member

Re: Trunking Cisco with Nortel

Try removing the trunking configs from the member ports and only apply it to the port channel interface.

Re: Trunking Cisco with Nortel

Hi,

you ARE using Cisco PAgP which Nortel probably doesn't support.

Portchannel is UP because it's forced to by the "channel-group 1 mode on" command.

Try to separate portchannel and trunk configuration problem, configure portchannel without trunk or trunk without portchannel first.

Regards,

Milan

New Member

Re: Trunking Cisco with Nortel

Thanks to all that replied. Our problem was that the Nortel and Cisco were on different VLAN's. Once that was fixed we are running very nicely.

Again, thanks to all that posted replies.

Lee

399
Views
0
Helpful
9
Replies