Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunking

I have 2 catalyst 4507's each with a 6 port fiber blade. I wish to trunk the two switches to share 3 vlans.

I understand that i will go ahead and setup switch trunk encapsulation dot1q on each fiber port (i am going to run 2 trunks) and i will add switchport mode trunk.

Is there anything that needs to be done since i will use 2 sets of fiber to make 2 trunks?

Also please confirm if this is correct:

I will create vlan 1, vlan 2 and vlan 3 on both switches and individually assign them the switchports i wish for them to use. Or do i need to do something with VTP?

any help is greatly appreciated.

12 REPLIES

Re: Trunking

Thats correct.

STP will put one trunk to blocking (since you have 2), so that there is no loop. When one link goes down, other link will come up.

You can additionally add command such as,

switchport trunk allowed vlan 1,2,3

VTP is a good idea if you have lots of switches and vlans. You really dont need VTP if you have only 2 switches and 3 vlans.

Another option is to bundle the two fiber ports to get twice the bandwidth using port channeling.

New Member

Re: Trunking

Why would you not etherchannel the turnk ports together. That way you would use all the ports and none would be in a STP blocking state?

Sample config would be like:

interface Port-channel1

description Connection to c4507-2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/1

description Connection to c4507-1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

interface GigabitEthernet1/2

description Connection to c4507-1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

interface GigabitEthernet2/1

description Connection to c4507-1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

interface GigabitEthernet 2/2

description Connection to c4507-1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

You will need to changet the interface port number but I hope you get the idea.

Andy

New Member

Re: Trunking

if i etherchannel the trunks what happens, if one link goes down does it fail over to the one remaining link?

Re: Trunking

When one link in ether channel fails, traffic is automatically forwarded through the remaining links in the bundle.

New Member

Re: Trunking

i will have 4 - 5 additional 3000 series switches all on vlan 1 that are trunked back to 1 of the 4507s through fiber as well. Can i get away without using VTP?

Re: Trunking

You should be fine. IF you have a lot of vlans (say 50), you would have to recreate all those vlans in the databases of all switches manually and then assign those vlans to individual switch ports.

With VTP, all you gain is the creation of vlans in the database of each switch automatically. VTP propagates vlan info from one centralized switch to all other switches in the same domain (VTP version and password should also match if configured).

Once the database is sync'ed, you will still have to manually assign each vlan to appropriate ports.

You should be just fine with or without VTP.

HTH

New Member

Re: Trunking

thanks for all of your help. i have 2 more quick questions. On my 5th 3000 series switch i will have run out of fiber ports. is it better to use a fiber port in one of the supervisor cards, to use a crossover cable and put printers on the switch, or to put it into the fiber port of one of the other 3000s. (i would personally think option one is best).

Also, on my PIX 515 i have a vlan for DMZ that currently goes to a switch thats being removed. in that switch is a VPN concentrator. is it bad practice to put the vpn concentrator right into a dmz vlan i create on the 4507?

New Member

Re: Trunking

Hey I thought that I would just mention that it's a bad idea to have data traffic and managment traffic on the same VLAN. Typically VLAN 1 is the managment VLAN and I would make another VLAN for data.

I try to keep just managment traffic on VLAN1. Also like to use VTP - it keeps management of VLAN simple. Additionally I like to use pruning in my VTP setup but some people do not like that.

Andy

New Member

Re: Trunking

what do you mean by management traffic, telnet traffic to the switch? Also, what benefit do you see in pruning?

Re: Trunking

Management traffic is like your telnet, SNMP traffic that is used to manage the switch.

Prunning will save the bandwidth on the trunk links by prunning the unwanted broadcast on the trunks for a particular vlan if not host is active on that vlan on a switch. I.e If you dont have any active host on a vlan on a particular switch and if there is a broadcast on that vlan which will come over the trunk so if no host is active that broadcast is prunned on the trunk where no host is active on the switch.

regards,

-amit singh

New Member

Re: Trunking

thanks for all of your help. i have 2 more quick questions. On my 5th standalone 3000 series switch i will have run out of fiber ports on the 6 port fiber blade. is it better to use a fiber port in one of the supervisor cards, to use a crossover cable and put printers on the switch, or to put it into the fiber port of one of the other standalone 3000s. (i would personally think option one is best).

Also, on my PIX 515 i have a vlan for DMZ that currently goes to a switch thats being removed. in that switch is a VPN concentrator. is it bad practice to put the vpn concentrator right into a dmz vlan i create on the 4507?

New Member

Re: Trunking

Andy,

This idea seems very beneficial. Forgive my ignorance but i am trying to make sense of the config. interface GigabitEthernet2/1 and interface GigabitEthernet2/2 are these the interfaces on the 2nd 4507?

130
Views
0
Helpful
12
Replies
CreatePlease login to create content