Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Try to configure NM-8AM module to act as RAS in 2620 router

Replacing and old RAS box with a 2620 router and NM-8AM module solution. I have followed the sample configuration at http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a00800e0dcd.shtml, but when trying to test with one phone line into any of the 8 ports, it just rings; the modem never picks up. I know the line is active, I can connect to an external modem on the AUX port just fine. Beginning to think the module is bad?

Specs:

2620 with 12.2(2)T with IP/IPX/AT/DEC

NM-8AM with Modem Firmware Version 1.2.8

Any help is appreciated.

TIA

Robb

17 REPLIES
Bronze

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Could you post the portions of config from group-async interface and the tty/modem lines ?

~Zulfi

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

I'll just post the whole thing omitting passwords, etc.

Current configuration : 1621 bytes

!

! NVRAM config last updated at 21:38:48 UTC Mon Mar 31 2003

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug datetime localtime

service timestamps log datetime localtime

no service password-encryption

!

hostname TippCityRAS

!

logging rate-limit console 10 except errors

enable secret 5 ***

!

username rhollen nopassword

ip subnet-zero

!

!

ip domain-list ***.com

no ip domain-lookup

ip domain-name ***.com

!

no ip dhcp-client network-discovery

async-bootp dns-server ***

!

!

!

interface FastEthernet0/0

ip address ***

speed 100

full-duplex

no cdp enable

!

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer-group 1

async mode interactive

peer default ip address pool dialin

ppp authentication chap

group-range 33 40

!

router eigrp 1

network ***

auto-summary

no eigrp log-neighbor-changes

!

ip local pool dialin ***

ip classless

ip route 0.0.0.0 0.0.0.0 ***

ip http server

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

exec-timeout 0 0

password ***

login

line 33 40

modem InOut

transport input all

autoselect ppp

flowcontrol hardware

line aux 0

password ***

login

modem InOut

modem autoconfigure type usr_courier

transport input all

speed 115200

line vty 0 4

exec-timeout 5 0

password ***

login

line vty 5 15

exec-timeout 5 0

password ***

login

!

no scheduler allocate

ntp clock-period 17179870

ntp server ***

!

end

TippCityRAS#

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Config looks good...can you please try the reverse telnet test.

With reverse telnetted into the modem, try & make a call into the same modem, do we see a incomming RING?

Thanks, Mak.

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Can we reverse telnet into the modems? Can we make a successful call OUT by reverse telnetting into any internal modem using ATDT?

telnet <2000+line#>

eg: telnet 1.1.1.1 2033

then, ATDTxxxxxxxxx

Thanks, Mak.

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Had to add loopback0 to configuration I posted. Phone line is on port 0 of nm-8am module:

TippCityRAS#telnet 1.1.1.1 2033

Trying 1.1.1.1, 2033 ... Open

at

OK

at&f

OK

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#

I don't know other AT commands to try.

Robb

Bronze

Re: Try to configure NM-8AM module to act as RAS in 2620 router

you dont have an IP addr on the group async. I believe it must be failing in IPCP portion , making you think modem is not picking up. Try that please.

~Zulfi

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Just try calling a phone number located near you (or your cell phone#) & see if it rings,

AT

OK

ATDT1408xxxyyyy

If that works, then remain in the reverse telnet session & call into the same modem to see incomming RING.

just adding further to Zulfi's note, add "ip unnumbered loopback0" under interface group-asy 1.

Thanks, Mak.

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Yes, I added the following to the config after I posted it when mak asked me to reverse telnet to the modems:

...

interface Loopback0

ip address 1.1.1.1 255.255.255.0

...

int group-async1

ip unnumbered Loopback0

...

So with the phone line plugged into modem port 0 on the nm-8am, I did a reverse telnet to all eight modems and tried to call my cell phone:

TippCityRAS#telnet 1.1.1.1 2033

Trying 1.1.1.1, 2033 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2034

Trying 1.1.1.1, 2034 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2035

Trying 1.1.1.1, 2035 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2036

Trying 1.1.1.1, 2036 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2037

Trying 1.1.1.1, 2037 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2038

Trying 1.1.1.1, 2038 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2039

Trying 1.1.1.1, 2039 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#telnet 1.1.1.1 2040

Trying 1.1.1.1, 2040 ... Open

at

OK

atdt19378770912

NO DIALTONE

TippCityRAS#disconnect

Closing connection to 1.1.1.1 [confirm]

TippCityRAS#

When I plug the line into a phone, I get a dialtone and can send and receive calls on it. I'm stumped.

Robb

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Looks to me a faulty NM-8AM card here....also since this is a 2620 there is no way we can try this in another slot of the chassis (maybe we can try it in another chassis)

Thanks, Mak.

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

I'll try another chassis before I look into replacing the module.

Thanks for your help thus far.

Robb

Bronze

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Hi, as what Mak has mentioned, it looks like you do have a faulty module. You might also want to check for proper grounding if you haven't done so, but this should not be directly related to the problem. Although the grounding issue is usually related to poor or unsuccessful connections, it is worth a try. Just a wild guess. Thanks.

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

OK, I have replaced the module. I can reverse telnet to modem0 (2033) and call my cell phone and it rings. But when I try to call in to the number it still just rings and rings. I think I'm missing something obvious here. I'm posting my configuration again, just to make sure I'm not missing anything.

TippCityRAS#sh run

Building configuration...

Current configuration : 1431 bytes

!

! No configuration change since last restart

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname TippCityRAS

!

logging rate-limit console 10 except errors

enable secret 5 ***

!

username *** nopassword

ip subnet-zero

!

!

no ip domain-lookup

ip domain-name ***

!

no ip dhcp-client network-discovery

async-bootp dns-server ***

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address ***

speed 100

full-duplex

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer-group 1

async mode interactive

peer default ip address pool dialin

ppp authentication chap

group-range 33 40

!

router eigrp 1

network ***

auto-summary

no eigrp log-neighbor-changes

!

ip local pool dialin ***

ip classless

ip route 0.0.0.0 0.0.0.0 ***

ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

password ***

login

line 33 40

modem InOut

transport input all

autoselect ppp

flowcontrol hardware

line aux 0

line vty 0 4

password ***

login

line vty 5 15

login

!

no scheduler allocate

ntp clock-period 17179925

ntp server ***

!

end

TippCityRAS#

Any ideas?

Robb

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

The config looks good, can you please try adding the following after reverse telnetting into the modem: AT&Fs0=1

It will be interseting to see if any of these two cards work fine in another chassis, could be a chassis problem too. Also as Ariel mentioned, ensure that the 2600 chassis is properly grounded.

Thanks, Mak.

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

OK, I've determined modem0 and modem4 are not working inbound, only outbound. The rest are working both ways. So I need to get another replacement module (that's what I get for buying used, at least they're under warranty). I have a few more questions:

1. I cannot seem to use the nopassword command. How do you setup not to use a password? If I do the 'username xxx password 0 xxx' command I connect fine, but 'username xxx nopassword' does not connect.

2. I need IPX capabilities as well. Do I just need to add a 'dialer-list 1 protocol ipx permit' command?

Thanks for all your help Mak.

Robb

New Member

Re: Try to configure NM-8AM module to act as RAS in 2620 router

Mak, do you have any recommendations on the following issues.

1. In need IPX capabilities on the dialin connections. I've added the following to the configuration:

#conf t

#ipx routing

#ipx dialer-list 1 protocol ipx permit

#int f0/0

#ipx network *** encap sap

#int gourp-async1

#ipx network *** (different from f0/0, no encap. because encap. is already ppp)

When I try to dial, TCP/IP connects successfully, but IPX does not. Get some message that "your computer and remote computer could not agree on PPP control protocols." I'm running Windows2000.

2. The nopassword command does not seems to work. If I specify a username and password I connect fine, but if I specify a username with the nopassword command, I get a message that the username and/or password could not be verified. This is not as pressing an issue as IPX, I can always issue passwords.

Thanks for all your help Mak!

Robb

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

ipx routing

!

loopback0

no ip address

ipx network 544

!

interface ethernet0

ip address x.x.x.x x.x.x.x

ipx network AC150E00

ipx encapsulation SAP

!

interface group-async1

ip unnumbered ethernet0

encapsulation ppp

async mode interactive

ipx ppp-client loopback0

ipx sap-interval 0

group-range 1 24

http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/asqcg/qcpppara.htm#xtocid1661220

http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/asqcg/qcisdn.htm#xtocid1192617

Thanks, Mak.

Silver

Re: Try to configure NM-8AM module to act as RAS in 2620 router

The username xxx nopassword command worked fine for me...not sure how are you trying out the same.

Thanks, Mak.

201
Views
5
Helpful
17
Replies