Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Trying to connect 1720 to ISP

I am trying to connect a Cisco 1720 running IOS 12.1 to our isp. This is just a test to see if I can get internet connectivity before I move onto the more difficult tasks.

It has two interfaces

FastEthernet0 (LAN)

Ethernet0 (WIC 0)

The configuration originally had NAT enabled, but I took that out to try to isolate the problem.

The configuration I'm using is:

no ip name-server


ip subnet-zero

ip routing


interface FastEthernet 0

ip address


interface Ethernet 0

ip address


! Access Control List 1


router rip



ip classless


! IP Static Routes

ip route Ethernet 0


The problem is I can't ping anything on the outside network (interface Ethernet0).

The problem is seen with

show ip traffic

where it reports many encasulation failed packets.

This is happening because when I try to ping an ip address outside the network of and ARP request is sent out for the destination ip. No response ever comes back so the packet encapsulation failes.

I don't know how to fix this and can't seem to find any information on this.

The WAN connection from the router is ethernet to a radio then to an ISP. I'm assuming that since it is an ethernet connection there needs to be some way of resolving an IP to a MAC address.

I would imagine the way it should work is that I need to point ethernet 0 to a gateway for which I must know the mac address or it can get it. The gateway I believe is

Many thanx for any help.

Matthew Jackson

Wyoming Solutions, LLC

Community Member

Re: Trying to connect 1720 to ISP

Are you sure you have the right mask on your external interface? Are you sure that they are up and working? Test your cabling also. Finally do a show int e0 and see if line and protocol is up.

Community Member

Re: Trying to connect 1720 to ISP

Your ISP should have given you a gateway IP address that sits off your E0 interface.

Change your default route statement from

ip route ethernet0


ip route


Community Member

Re: Trying to connect 1720 to ISP

Thanx for the advice. I made the change you suggested but it still didn't fix my problem. This morning first thing I called the ISP and found out the problem. The radio that the router plugs into caches only one MAC address for a device that connects to it. That MAC address won't change unless you reset the radio by powering off and on again.

Once I did that everything worked like a charm. The problem was that it had the IP addressed cached witht he MAC address of the previouse device that was plugged into it. So when I'd plug that device back in the connection worked fine. When I plugged in the new Cisco router everything stopped and arp requests were not being returned because they were being returned to the wrong MAC address.

It was not a problem resolving the MAC address on the outgoing direction, it was a problem resolving the MAC address returning to my IP.

Is there a protocol command for discovering a device's ARP cache?

Thanx again.

Matt J.

Community Member

Re: Trying to connect 1720 to ISP

On the device if it's a cisco router, type show ip arp

if it's NT/2000 it's arp -g

CreatePlease to create content