Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

unable to access to net thru ISDN dial up behind the PPP connection

My serial Interface is doing a PPP connection to another remote site and I have no problem on accessing remote site but I was unable to access to internet thru my ISDN dialer.I had paste my config of my router show run.Any one cud provide me some advise and method solving.

Current configuration : 1451 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type basic-net3

!

!

!

!

interface FastEthernet0/0

ip address 192.168.253.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface BRI0/0

no ip address

ip nat outside

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Serial0/0

ip address 192.168.4.1 255.255.255.0

encapsulation ppp

clockrate 64000

no fair-queue

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

no ip route-cache

no ip split-horizon

no ip mroute-cache

dialer in-band

dialer string xxxxx

dialer hold-queue 10

dialer load-threshold 255 either

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxxx

ppp chap password 0 xxxxx

ppp pap sent-username xxxx password 0 xxxxx

!

router rip

version 2

passive-interface Dialer1

version 2

passive-interface Dialer1

network 192.168.4.0

network 192.168.253.0

no auto-summary

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

access-list 1 permit 192.168.4.0 0.0.0.255

access-list 1 permit 192.168.253.0 0.0.0.255

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

Anything cmd line missing from my config?

3 REPLIES
Silver

Re: unable to access to net thru ISDN dial up behind the PPP con

Need to define the interesting traffic that will trigger the DDR call. For eg:

"dialer-list 1 protocol ip permit"

If you still run into issues connecting over the ISDN link, please run the following debugs:

deb dialer / deb isdn q931 / deb ppp nego.....also ensure isdn status is ok.

Thanks, Mak.

New Member

Re: unable to access to net thru ISDN dial up behind the PPP con

I don't see a NAT address pool:

RTA(config)#ip nat pool [name] [start add] [end add] netmask [snm]

The add would be the public add from ISP.

Hope this helps!

New Member

Re: unable to access to net thru ISDN dial up behind the PPP con

Sorry about last post, I see your using easy ip /NAT getting public add from ISP and applying to BRI/dialer1 interface. One thing you might try is using debug dialer and make sure you are authenticating correctly...I notice you are using #ppp chap [hostname]/ppp chap password commands in your dialer profile, for ppp auth using dialer profiles you should use:

RTA(config-if)# dialer remote-name [hostname]

I also see you used dialer rotary-group1 on BRI, if using dial profile, need to use #dialer pool-member 1 to assign dialer pool1 to interface.

Hope this helps!

74
Views
0
Helpful
3
Replies
CreatePlease to create content