Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

unable to browse

I have recently installed routers in our main office and a new remote office. All seems fine, except we can browse the network of the local office but not that of the other one. Also, we are unable to run an app in the remote office that accesses data on a server at the main office. The app uses the server name to find the data.

Below are the configs for the two routers.

Main office:

main_router#sh config

Using 1105 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname iworx_scarboro

!

enable secret xxxxxx

enable password *****

!

ip subnet-zero

!

!

ip name-server 192.168.128.3

!

!

!

!

interface FastEthernet0/0

description connected to Scarborough LAN

ip address 192.168.129.201 255.255.240.0

ip local-proxy-arp

ip route-cache same-interface

no ip mroute-cache

speed auto

half-duplex

!

interface Serial0/0

description connected to Bristol 2620 router via T1

ip address 192.168.146.2 255.255.255.0

encapsulation ppp

no ip mroute-cache

fair-queue

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

ip classless

ip forward-protocol udp echo

ip forward-protocol udp netbios-ss

ip route 0.0.0.0 0.0.0.0 192.168.128.1

ip route 192.168.147.0 255.255.255.0 192.168.146.1

ip http server

ip pim bidir-enable

!

!

snmp-server community public RO

!

line con 0

exec-timeout 0 0

password *****

line aux 0

line vty 0

exec-timeout 0 0

password *****

login

line vty 1 4

password *****

login

!

!

end

Remote office:

remote_router#sh config

Using 1260 out of 29688 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname iworx_bristol

!

enable secret xxxxx

enable password *****

!

!

!

!

!

ip subnet-zero

ip name-server 192.168.128.3

!

!

!

!

interface FastEthernet0/0

description connected to Bristol LAN

ip address 192.168.147.1 255.255.255.0

ip helper-address 192.168.128.22

no ip directed-broadcast

no ip mroute-cache

speed auto

half-duplex

!

interface Serial0/0

description connected to Scarborough 2620XM router via T1

ip address 192.168.146.1 255.255.255.0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

!

ip classless

ip forward-protocol udp echo

ip forward-protocol udp netbios-ss

ip route 0.0.0.0 0.0.0.0 192.168.146.2

ip http server

!

snmp-server engineID local xxxxx

snmp-server community public RO

snmp-server location Bristol, CT

snmp-server contact Michael J. Doyle,207-883-8090,mdoyle@iworxinc.com

!

line con 0

exec-timeout 0 0

password *****

login

transport input none

line aux 0

line vty 0

exec-timeout 0 0

password *****

login

line vty 1 4

password *****

login

!

no scheduler allocate

end

Can this be fixed? If so, how?

Thanks in advance for your help,

Emjay

  • Other Network Infrastructure Subjects
4 REPLIES
Cisco Employee

Re: unable to browse

This can certainly be fixed. Here's a good document to start with:

http://www.cisco.com/en/US/partner/tech/tk870/tk877/tk880/technologies_tech_note09186a00801aa01f.shtml

Gold

Re: unable to browse

Sounds like you need Microsoft Windows name resolution of some sort. You can use LMHOSTS files, Windows Internet Name Service (WINS), or DNS; or any combination of the three. Which you ultimately decide on depends on how many stations you have, how many servers you have, where they're located, what operating systems they're running, etc., but in principle all will work.

LMHOSTS is the easiest to implement, but the most difficult to maintain. It's kind of like HOSTS files in Unix and generic TCP/IP applications, but specific to Windows. (The "LM" in LMHOSTS is for LAN Manager, an older Microsoft product that followed MS-DOS and preceded Windows NT.)

You create the file in either the C:\WINDOWS, C:\WINNT\SYSTEM32\DRIVERS\ETC, or C:\WINDOWS\SYSTEM32\DRIVERS\ETC directory, depending on your operating system. Search your hard drive for a sample file, LMHOSTS.SAM for some more information on syntax and special tags.

Try it on one workstation and one server, see how it works. You can create the text file and then put it into effect immediately by running the NBTSTAT -R command from a command prompt. Note: the -R parameter is case sensitive, the "R" MUST BE CAPITALIZED for it to work. Type in NBTSTAT without any parameters to see the other options.

Setting up WINS and/or DNS is a better long-term solution, but may take a while to get it set up and working on all stations. But you will be visiting all the stations anyway if you decide for LMHOSTS only. Somethine else to keep in mind: like HOSTS files with DNS, LMHOSTS file entries will take precedence over WINS or DNS in Microsoft Networking.

Also, here's another hyperlink to the excellent document in the previous post, in case you don't have a Cisco Partner login:

http://www.cisco.com/en/US/tech/tk870/tk877/tk880/technologies_tech_note09186a00801aa01f.shtml

UPDATED: Just looked at your configs, make sure the router at 192.168.128.1 that "iworx_scarboro" uses as its default gateway also has a static route back to the LAN subnet at Bristol via the LAN interface of the Scarborough router. If you have stations and servers on the Scarborough LAN that point to this other router as their default gateway, and it does not know how to find the users on the Bristol LAN, then their traffic won't go in the correct direction. (It will probably go to that router's own default gateway, maybe heading for the Internet, where it will get squashed by the ISP.)

Have you been able to test basic IP connectivity using pings, from the routers? Servers? Workstations?

Gold

Re: unable to browse

Didn't get a chance to finish this in my last post, got timed out.

If you have ping working but no Windows name resolution, then it's most likely a name resolution problem.

If basic IP connectivity and routing isn't working from all parties (routers, servers, workstations) as tested with pings and traceroutes, then you have to take care of that first. Then work on the Windows name resolution.

Hope this helps.

New Member

Re: unable to browse

I can ping and trace route from both locations. I can browse the entire network (both subnets) now. I have set up DNS and WINS. I created a BDC at the main office, and could synchronize with the PDC. I set up WINS on the BDC, and push/pull replication worked. I then moved it to the remote office. Now WINS won't replicate and I can't synch with or even find the PDC in Server Manager.

What's wrong? Router config? WINS and/or DNS setup?

???

Please help, I need to get this working today!

Thanks in advance,

Emjay

106
Views
0
Helpful
4
Replies
This widget could not be displayed.