Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to configure Etherchannel

As part of my studies for the bcmsn exam, I have been trying to configure etherchannel on a 3550 EMI switch and keep recieving the following message:

command rejected (port channel1 gi/01 ): either port is L2 and port channel is L3 or vice-versa. I have followed the config examples from the Cisco self study book and have tried switchport, no switchport commands and still keep recieving the same message. Has anyone out there experianced the same problem? Any ideas?

Thanks for reading this!

  • Other Network Infrastructure Subjects
8 REPLIES

Re: Unable to configure Etherchannel

hi try this

Switch# configure terminal

Switch(config)# interface gigabitethernet0/4

Switch(config-if-range)# switchport mode access

Switch(config-if-range)# switchport access vlan 10

Switch(config-if-range)# channel-group 5 mode desirable

Switch(config-if-range)# end

here you need to make the perticular interface member of the perticular channel group...

try this will work...

rate this post if it helps

regards

Devang

Re: Unable to configure Etherchannel

for layer 3 ether channel use this

creat logical channel interface

Switch# configure terminal

Switch(config)# interface port-channel 3

Switch(config-if)# no switchport

Switch(config-if)# ip address 172.10.20.10 255.255.255.0

Switch(config-if)# end

now for physical interface use:

Switch# configure terminal

Switch(config)# interface range gigabitethernet0/4 -5

Switch(config-if-range)# no ip address

Switch(config-if-range)# channel-group 3 mode desirable

Switch(config-if-range)# end

Hope this will help you

rate this post if it helps

regards

Devang

New Member

Re: Unable to configure Etherchannel

Dear Devang

Many thanks for your reply.I will try your suggestion tomorrow since England are playing in the world cup tonight! The problem I was having was in regard to the creation of a Etherchannel trunk. Perhaps there is a typo in the BCMSN 3rd edtion book?

Re: Unable to configure Etherchannel

Hey there Martin,

To make an etherchanne trunk you need to ensure that all of the interfaces are singing from the same hymn sheet:-

int f0/1

sw trunk enc dot

sw mo trunk

channel-group 1 mode on

int f0/2

sw trunk enc dot

sw mo trunk

channel-group 1 mode on

int po 1

sw trunk enc dot

sw mo trunk

And that's it! Try not to mix up:-

i) channel-group modes

ii) trunk encapsulations

iii) do not put an ip address on switchports

iv) put an ip address on the port-channel interface if you want it to be a routed port, if you want it as a switched port or a trunk, then configure it as you normally would a trunk/switched port.

Good luck with the exam,

COME ON ENGLAND!!

Regards,

LH

Please rate all posts

New Member

Re: Unable to configure Etherchannel

Thanks LH

I have tried what you suggested without any luck. I am using a 3550 in a remote lab which is the only switch in the lab. Is it poss that I am recieving error messages because the interface is not connected?

Purple

Re: Unable to configure Etherchannel

You certainly have to have a connection to see if it is working ok .

Re: Unable to configure Etherchannel

Hi there,

No, it does not have to be connected for the config to be entered and there should not be any error messages. You will get "down, down" on the port-channel, as the interfaces that you have nominated to be in the group will be down and therefore the switch will not put them in the channel-group. As and when they come up if you do a "sh int po 1" you should see the bandwidth increase to the total size of the links in the group.

With you haveing an error saying somthing about a layer 2 and layer 3 mismatch, it would conclude that there is a typo in the config.

The physical ports can either be layer 2 "switchport mode...." or layer 3 "no switchport, ip address...." These have to be the same on all ports involved - if the switchports are layer 3 (no switchport, etc) then the port-channel can't be a trunk.

Try configuring the ports using "channel-group 30 mode on" without doing and config on the port channel and see what happens. Failing that - post the config and we'll sort it ;)

Was Joe Cole's goal one of the best ever!?

Regards,

LH

Please rate all posts

New Member

Re: Unable to configure Etherchannel

Thanks for that Leigh

I will give it a whirl tonight and let you know how it went. It was a great goal by Cole! Just a pity about Owen. Lets hope Ferdinand recovers in time!

Cheers

Martin

1536
Views
0
Helpful
8
Replies