Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to delete IOS for Cisco2621XM

Hi,

Recently I tried to upgrade IOS on my 2621XM router but due to timeout it ended that there are three files with similiar filename but with a invalid CheckSum append at the end of the filename.

I have only one partition of flash on the router and I am not able to delete the courrpted file.

router#sh flash

System flash directory:

File Length Name/status

1 7717788 c2600-is-mz.121-17.bin

2 667648 c2600-is-mz.121-20.bin [invalid Checksum]

..

I tried command like "delete flash:c2600-is-mz.121-20.bin", "delete flash:/C2600-is-mz.121-20.bin" but it failed.

Thanks in advance for any help render!

2 REPLIES
Bronze

Re: Unable to delete IOS for Cisco2621XM

What error message did you get when the delete failed?

You could always try the erase flash: command and start over and load your new image from a directly connected laptop running a tftp server.

Good luck

New Member

Re: Unable to delete IOS for Cisco2621XM

Try giving the command Squeeze flash.

Else, copy the working image to ur tftp server and then erase the flash by giving erase flash. This will erase the flash files. Dont reboot the router. Now the flash doesnt contain any files. Try uploading the image just copied to the router again from the tftp server.

Hope this helps.

-Deepu

110
Views
0
Helpful
2
Replies