Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

unable to get an ip via DHCP

adelphia, my cable provider issues IP addresses via DHCP. i've set my 2611 to get it's address from the DHCP server with the command "ip address dhcp"

as you can guess, it's not working. i can't nab an address from the server.

i removed all ACL's to see what was going on. the following is my debug output:

------

*Feb 28 18:15:32.239 PST: DHCP: Try 11 to acquire address for Ethernet0/0

*Feb 28 18:15:32.239 PST: Ethernet0/0: Setting Duplex to HALF

*Feb 28 18:15:32.243 PST: Ethernet0/0: Interface is alive

*Feb 28 18:15:32.243 PST: IP-EIGRP: Callback: address_command Ethernet0/0 0.0.0.0/0 sense 0

*Feb 28 18:15:32.243 PST: PIM(0): Flush DF for Ethernet0/0, RP 0.0.0.0

*Feb 28 18:15:32.247 PST: Ethernet0/0: Setting Duplex to HALF

*Feb 28 18:15:32.251 PST: Ethernet0/0: Interface is alive

*Feb 28 18:15:32.251 PST: IP-EIGRP: Callback: address_command Ethernet0/0 0.0.0.0/32 sense 1

*Feb 28 18:15:32.251 PST: IP: pruning prefix cache entries for Ethernet0/0

*Feb 28 18:15:32.251 PST: IP: Invalidating prefix cache entries for 1 interfaces

*Feb 28 18:15:32.255 PST: DHCP: allocate request

*Feb 28 18:15:32.255 PST: DHCP: new entry. add to queue

*Feb 28 18:15:32.255 PST: DHCP: SDiscover attempt # 1 for entry:

*Feb 28 18:15:32.255 PST: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0/0

*Feb 28 18:15:32.255 PST: Temp sub net mask: 0.0.0.0

*Feb 28 18:15:32.259 PST: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Feb 28 18:15:32.259 PST: DHCP transaction id: 7515FE

*Feb 28 18:15:32.259 PST: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Feb 28 18:15:32.259 PST: Next timer fires after: 00:00:02

*Feb 28 18:15:32.259 PST: Retry count: 1 Client-ID: cisco-0010.7b1d.4c60-Et0/0

*Feb 28 18:15:32.263 PST: Hostname: pluto

*Feb 28 18:15:32.263 PST: DHCP: SDiscover: sending 297 byte length DHCP packet

*Feb 28 18:15:32.263 PST: DHCP: SDiscover 297 bytes

*Feb 28 18:15:32.263 PST: IP: s=0.0.0.0 (local), d=255.255.255.255 (Ethernet0/0), len 604, sending broad/multicast

*Feb 28 18:15:32.267 PST: B'cast on Ethernet0/0 interface from 0.0.0.0

*Feb 28 18:15:34.550 PST:

*Feb 28 18:15:34.550 PST: Rudpv1 Sent: Pkts 0, Data Bytes 0, Data Pkts 0

*Feb 28 18:15:34.550 PST: Rudpv1 Rcvd: Pkts 0, Data Bytes 0, Data Pkts 0

*Feb 28 18:15:34.550 PST: Rudpv1 Discarded: 0, Retransmitted 0

*Feb 28 18:15:34.550 PST:

*Feb 28 18:15:35.249 PST: DHCP: SDiscover attempt # 2 for entry:

*Feb 28 18:15:35.249 PST: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0/0

*Feb 28 18:15:35.249 PST: Temp sub net mask: 0.0.0.0

*Feb 28 18:15:35.249 PST: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Feb 28 18:15:35.249 PST: DHCP transaction id: 7515FE

*Feb 28 18:15:35.253 PST: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Feb 28 18:15:35.253 PST: Next timer fires after: 00:00:02

*Feb 28 18:15:35.253 PST: Retry count: 2 Client-ID: cisco-0010.7b1d.4c60-Et0/0

---------

i don't want to burden you with the config if you can spot the error here, but if needed, i'll be more than happy to post the contents of the file.

any and all help will be greatly appreciated.

  • Other Network Infrastructure Subjects
6 REPLIES
VIP Purple

Re: unable to get an ip via DHCP

Hello,

it looks like your client does not find a DHCP server. What happens if you use the statement:

ip address dhcp client-id Ethernet0/0

?

If that doesn't help. can you post your configuration ?

Regards,

GP

New Member

Re: unable to get an ip via DHCP

Hi ssheikh,

Have you verified connectivity to the DCHP server on that cable? If not plug in a PC and make sure it can pull an address.

Once that works you know the DHCP server exists. You may need to identify an interface on the router for the MAC and create a hostname. The complete command is listed below.

ip address dhcp [client-id interface-name] [hostname host-name]

R/S

Dave

joe
New Member

Re: unable to get an ip via DHCP

Some ISP require you to fix MAC address. Personally i have used just ip address dhcp and it works fine. On a 1605R.

Regards.

New Member

Re: unable to get an ip via DHCP

hmmm... for some reason, my response didn't get posted. i hope this one does.

alright, this problem isn't fully resolved, but a little progress was made.

apparently the cable modem makes a record of the MAC address of the connecting device. in this case it made a record of my linksys 4-port device.

when i power-cycled the connection on the cable modem (a motorola SB4100) things worked... BUT... only for a few minutes.

after a little while, things stopped working again.

and here's the weird thing. while i was looking at my debug output, i was flooded by these messages:

-------

*Mar 2 01:20:15.342: Local MobileIP: Ethernet0/0 add 68.169.156.1 rejected

*Mar 2 01:20:15.342: IP ARP: rcvd req src 68.169.156.1 0050.5700.6943, dst 68.169.156.206 Ethernet0/0

*Mar 2 01:20:15.342: Local MobileIP: Ethernet0/0 add 68.169.156.1 rejected

*Mar 2 01:20:15.378: Local MobileIP: Ethernet0/0 add 68.66.243.1 rejected

*Mar 2 01:20:15.378: IP ARP: rcvd req src 68.66.243.1 0050.5700.6943, dst 68.66.243.158 Ethernet0/0

*Mar 2 01:20:15.378: Local MobileIP: Ethernet0/0 add 68.66.243.1 rejected

*Mar 2 01:20:15.382: Local MobileIP: Ethernet0/0 add 68.66.243.1 rejected

*Mar 2 01:20:15.382: IP ARP: rcvd req src 68.66.243.1 0050.5700.6943, dst 68.66.243.159 Ethernet0/0

-------------

when this "Local MobileIP" was being generated, the connection was fine, after a while it stopped and so did the fucntioning of the connection.

my config is pretty threadbare.

i'll be more than happy to post it.

-----------

Current configuration : 1451 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname pluto

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxx.

enable password 7 xxx

!

username xxx password 7 xxx

aaa new-model

!

!

aaa session-id common

ip subnet-zero

ip cef

!

!

no ip domain lookup

ip domain name sol.home

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 60

ip ssh authentication-retries 2

ip dhcp-client network-discovery informs 2 discovers 0

!

!

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Ethernet0/0

ip address dhcp client-id Ethernet0/0 hostname pluto

ip nat outside

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface BRI0/0

no ip address

shutdown

!

interface Ethernet0/1

ip address 10.10.xxx.xxx 255.255.255.248

ip nat inside

full-duplex

!

ip nat inside source list 25 interface Ethernet0/0 overload

ip http server

no ip http secure-server

ip classless

!

!

!

ip access-list extended SSH_ACCESS

permit tcp host 10.10.xxx.xxx any eq 22 log

deny tcp any any eq 22 log

access-list 25 permit 10.10.xxx.xxx 0.0.0.7

!

!

!

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

access-class SSH_ACCESS in

password 7 xxx

transport input ssh

!

!

!

end

-------------

if anyone can help out.... i'd be eternally grateful.

New Member

Re: unable to get an ip via DHCP

Hey ,

You mentioned that you are using a Linksys 4 port Router. Well I would suggest that you use the MAC Cloning feauture in the router and see if it helps.

You can set that by going into the set up page of the router and there you will find the MAC Cloning Option.

Regards

Khalid.

joe
New Member

Re: unable to get an ip via DHCP

Use the WAN MAC address of the Linksys and input into your Cisco E0/0.

Have you tried commands like sh dhcp server or sh dhcp lease ?

Regards.

154
Views
0
Helpful
6
Replies