Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to ping other side of 802.1q trunk links on 3500XL

Hopefully you can point out my mistakes here.

I can ping the Extreme, but can't ping the 3500XL nor either server. All connections are 802.1q trunk links. The native VLANs for Server23 and Server24 are 23 and 24, respectfully. Sorry for all the x's...the posting system here is messing with my diagram..

xoxoxoxoxoxoxoxoxoxoExtreme Switch

xoxoxoxoxoxoxoxoxoxo10.6.200.2

xoxoxoxoxoxoxoxoxoxo|

xoxoxoxoxoxoxoxoxoxo|

Router A--------- 3500XL------ Server23

xoxoxoxoxoxoxoxoxo 10.6.200.3 10.6.23.2

xoxoxoxoxoxoxoxoxox|

xoxoxoxoxoxoxoxoxox|

xoxoxoxoxoxoxoxo Server24

xoxoxoxoxoxoxoxox 10.6.24.2

*Server gateways point to their respect subif on the router (i.e. 10.6.24.2 is using 10.6.24.1 on Router A)

** Both the Extreme and the 3500XL are using 10.6.200.1 as their default gw.

Subifs on router A:

subif .1 10.6.200.1

subif .23 10.6.23.1

subif .24 10.6.24.1

!Relevant 3500XL config

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 1

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 24

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

interface VLAN1

ip address 10.6.200.3 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.6.200.1

2 REPLIES
New Member

Re: Unable to ping other side of 802.1q trunk links on 3500XL

few questions

1) why are you trunking to the servers ? if it is just a single vlan (23 or 24), why not make it access port.

2) can you provide us with the config on the router ?

I am assuming you are trying to ping from the router to the servers, do you see arp entries getting populated ?

New Member

Re: Unable to ping other side of 802.1q trunk links on 3500XL

1.) We develop a special network measurement device that can use a 802.1q trunk connection. As part of the testing, we needed the link to be a trunk, not a access link. 2) I just found the problem - a subif (.23) was shutdown for some reason. After issueing a no shut, everything was fine and well. D'OH!

432
Views
0
Helpful
2
Replies
CreatePlease to create content