Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

unable to reverse telnet modem in 2511

HI ALL

I configured 2511 for accepting dialin users.I am unable to communicate with the modem using reverse telnet.The modem is Zyxel .I have tried all options given in cisco documentation.I also need a sample configuration for the following scenario.

Scenario:

I am having a linux server running web,mail and ftp services.There are some 100 users who will be dialing in to the 2511 and connect to the linux server for web,mail and ftp services.I have given a different range of IP to the dial in clients.The linux server to which the dial-in users will connect to is on different range of IP.Will it work?If so how to enable routing?

Thanks,

Arasu

7 REPLIES
Cisco Employee

Re: unable to reverse telnet modem in 2511

YES..you can configure the 2500 router for dialin access using the external analog modems. Here is the url for config.

http://www.cisco.com/warp/public/793/access_dial/pppdialup.html

For each dialin, a static route will be added for each dialin users. Now you need to make sure that you can reach that linux server from the 2500 router.

New Member

Re: unable to reverse telnet modem in 2511

I am in progress of configuring the 2511 router for dial in.Now i am unable to reverse telnet into the modem to configure it.I have selected modem autoconfigure discovery,but the router is not communicationg with the modem.And also i am unable to reverse telnet into the modem.Help me.

Regards,

Arasu.

Cisco Employee

Re: unable to reverse telnet modem in 2511

That may be mostly a physical layer issue. Need to know the cable you use on 2511 along with the label on DB25 adaptor which need to connect modem. Mostly you have OCTAL cable with 8 RJ45 ports. That is the RJ45 Rolled cable.

so you need DB25 adaptor marked as "MODEM" (part number CAB-25AS-MMOD) to plug in to modem.

Here is the detailed modem to router connection guide which covers the required cables and config etc

http://www.cisco.com/warp/public/76/9.html

New Member

Re: unable to reverse telnet modem in 2511

I am using a RJ-45 to DB9 connecter to connect the asnyc line to the modem.The modem supports only DB9 connector.The line speed is not getting locked.When ever i give sh run command the line speed differs from time to time.When i reverse telnet into the modem the modem doesn't respond to the AT command.Kindly give me a solution.The following is the configuration i have done.

sh run

Building configuration...

Current configuration:

!

version 11.2

service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname bsnlpgt

!

enable password 7 00111F12165A

!

ip domain-name XXXXX

ip name-server XX.YY.ZZ.OO

ip address-pool local

!

interface Ethernet0

ip address 172.16.2.19 255.255.255.224

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

interface Group-Async1

ip unnumbered Ethernet0

ip tcp header-compression passive

encapsulation ppp

async mode interactive

peer default ip address pool default

group-range 1 16

!

router rip

network 172.16.0.0

!

ip local pool default 172.16.2.13 172.16.2.16

no ip classless

!

line con 0

exec-timeout 0 0

line 1 16

autoselect ppp

modem InOut

modem autoconfigure discovery

transport input all

stopbits 1

rxspeed 300

txspeed 300

flowcontrol hardware

line aux 0

line vty 0 4

login

!

end

Bronze

Re: unable to reverse telnet modem in 2511

Are the modems set with an explicit speed? Try explicitely setting the speed on the 2500 to 9600 (and then increase it if you can't connect via a reverse telnet).

New Member

Re: unable to reverse telnet modem in 2511

I have set the speed to 9600 and tried still i am unable to connect.The line speed is not getting locked.If i type "sh run" the line speed varies form time to time.What may be the problem?

Cisco Employee

Re: unable to reverse telnet modem in 2511

Try to plug that modem to PC on one of the com port and see you can talk to iy via hyperterminal. If the modem dosen't respond to AT commands via hyperterminal from PC, i would say modem may be bad.

If modem does respond, pl issue following commands. You should get OK after every commands

AT&F

ATS0=1

AT&W

After that plug the modem back to router and let us know how many led's (signals) on the modem you see are active (just after plugging to router).

317
Views
0
Helpful
7
Replies
CreatePlease login to create content