Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Unable to use web console to C2950 after the upgrade

Hi all,

I have a C2950 which had c2950-i6q4l2-mz.121-11.EA1.bin , I was able use web console. I have upgraded the IOS due to a bug in the old one, everything seems to work fine but I am unable to Web console to the switch, IP http server service is enabled on the switch. Here is the show flash output. Any idea, how can I recover from this situation. MAny Thanks in advance

Regards

Shaheen

Directory of flash:/

2 -rwx 2664051 Mar 01 1993 00:03:22 c2950-i6q4l2-mz.121-11.EA1.bin

4 -rwx 916 Mar 01 1993 00:17:31 vlan.dat

5 -rwx 4536 Mar 01 1993 00:05:22 config.text

6 -rwx 360 Mar 01 1993 00:04:46 env_vars

7 drwx 0 Mar 04 2003 12:55:48 html

19 -rwx 110 Mar 04 2003 12:57:01 info

20 -rwx 109 Mar 01 1993 00:04:07 info.ver

8 -rwx 2888611 Mar 02 1993 23:08:50 c2950-i6q412-mz.121-13.EA1c.bin

9 -rwx 47 Mar 01 1993 00:05:22 private-config.text

8 REPLIES
New Member

Re: Unable to use web console to C2950 after the upgrade

Hi,

Are you getting a login screen? Clear the Browser cache and do a reload on the router. If it still doesn't work, you could do the reverse, put back the old software and see if it works. If it does, open a TAC Case to verify the bug.

Good luck,

Corey

Re: Unable to use web console to C2950 after the upgrade

Have done this already, now the web console does not work even it I reload the switch using the old IOS. Could it be something to do with upgrading using the .bin files. How do I use the .tar file to upgrade. If I want to do upgrade it again, what steps shall I take do using the the console ?

New Member

Re: Unable to use web console to C2950 after the upgrade

Hi,

Never heard of the .bin files giving any problem in this way. I would be interested in your config. You can send offline. If you not getting a login screen, before and after the up/down grade then I would say the service isn't working, but I find it hard it is corrupt. What error do you get in the browser?

Regards,

Corey

Silver

Re: Unable to use web console to C2950 after the upgrade

If you can access the box and use CLI add the command ip http server . When you switched versions it probably changed from deafult to non default.

Re: Unable to use web console to C2950 after the upgrade

ip http server is not missing and is there. The first sign on process works fine and I get this :

++++++++++++++++++++++++++++++++++++++++++++++++++++

Accessing Cisco WS-C2950T-24 "Switch4"

Web Console - Manage the Switch through the web interface.

Telnet - to the router.

Show interfaces - display the status of the interfaces.

Show diagnostic log - display the diagnostic log.

Monitor the router - HTML access to the command line interface at level 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15

Connectivity test - unavailable, no valid nameserverdefined.

Extended Ping - Send extended ping commands.

Show tech-support - display information commonly needed by tech support.

--------------------------------------------------------------------------------

Help resources

CCO at www.cisco.com - Cisco Connection Online, including the Technical Assistance Center (TAC).

tac@cisco.com - e-mail the TAC.

1-800-553-2447 or +1-408-526-7209 - phone the TAC.

cs-html@cisco.com - e-mail the HTML interface development group.

+++++++++++++++++++++++++++++++++++++++++++++++++++++

Then I click on Web Console to start the Web interface using Jave and it stops there. All other switches are working fine, hence My PC and Jave applet is fine. Http server on the switch is also working as I get the initial sign on process working. It must be something to do with http files on the switch but I don't know what and how to recover from this. Possibly they also need to be upgraded with IOS as I have just foung they are part of the newIOS.tar upgrade file, I have used newIOS.bin

Here is the Show ver and config

+++++++++++++++++++++++++++++++++++++++++++++++++++

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(13)EA1c, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Tue 24-Jun-03 17:31 by yenanh

Image text-base: 0x80010000, data-base: 0x805A8000

ROM: Bootstrap program is CALHOUN boot loader

ITSC2950TLut8 uptime is 20 hours, 48 minutes

System returned to ROM by power-on

System image file is "flash:c2950-i6q412-mz.121-13.EA1c.bin"

cisco WS-C2950T-24 (RC32300) processor (revision G0) with 20839K bytes of memory.

Processor board ID FOC0651Z1D1

Last reset from system-reset

Running Enhanced Image

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

+++++++++++++++++++++++++++++++++++++++++++++++++++

Building configuration...

Current configuration : 4572 bytes

!

version 12.1

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname Switch4

!

logging monitor informational

enable secret 5

enable password 7

!

clock timezone GMT 1 59

clock summer-time BST recurring 4 Sun Mar 0:00 4 Sun Oct 0:00

ip subnet-zero

no ip domain-lookup

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree uplinkfast

!

interface FastEthernet0/1

switchport access vlan 20

switchport mode access

no ip address

spanning-tree portfast

!

!

!

!

interface GigabitEthernet0/2

switchport mode trunk

no ip address

!

interface Vlan1

ip address xxx.xxx.xxx.xxx 255.255.255.0

no ip route-cache

!

ip default-gateway xxx.xxx.xxx.xxx

ip http server

!

!

line con 0

password 7

login

line vty 0 4

password 7

login

line vty 5 15

password 7

login

!

end

+++++++++++++++++++++++++++++++++++++++++++++++++++++

I have also tried to use the previus IOS by editing the boot attribute, IOS works but now html part does not work there so I cannot go back.

If now I want to load newIOS.tar file, how do I do this so that switch's web console/http java part can start working ?

Currently functionality wise there is no problem with the switch, telnet and normal console works fine.

New Member

Re: Unable to use web console to C2950 after the upgrade

Hi,

Now it is a bit easier to understand. I thought you could not get a login through the browser. Here is a link that has another link and info on using the .tar and .bin files. Hope it helps you out.

http://www.cisco.com/warp/public/473/corrupt_or_missing_image.html

Regards,

Corey

Re: Unable to use web console to C2950 after the upgrade

First of all many thanks for this very helpful link it has a lot of information.

I have read this document. I have an empty html directory on this C2950, Off course webcosole does not work, stupid me, I should have checked it first.

The document suggest to use following command

switch#tar /x tftp://10.1.1.1/c2900xl-c3h2s-tar.120-5.WC8.tar flash:

My switch does not support the "tar" command, probably this command is for XL switches only.

I can upload the .tar image using tftp, but how will I use that uploaded image, I mean unzip it to put files into correct locations.

Your help will be much appriciated

Regards

Shaheen

New Member

Re: Unable to use web console to C2950 after the upgrade

You need to use the archive command prior to the tar command. See example below:

archive tar /x tftp://server_ip_address/path/filename.tar flash:

Hope this helps.

Josh

735
Views
0
Helpful
8
Replies
CreatePlease to create content