Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unbindable Call error

I have an 801 Router configured to dial an ISP and therefore has a Dialer interface with IP Negotiated. This works fine. We now have a requirement to dial into the router as well - we have therefore created a second dialer profile with a static address within the same subnet as the remote end. Upon receiving a call the debugs state that the call in is "Unbindable". If I remove the first dialer (IP Negotiated) from the pool the call will connect fine.... I have tried creating two dialer pool members with varying priority etc, with no success..

Any one got this working ?

5 REPLIES
Silver

Re: Unbindable Call error

1. If only 1 Dialer interface (profile) is configured, incoming calls on BRI will be forwarded to that single Dialer based on Dialer pool (dialer pool-member & dialer pool) binding.

2. When multiple Dialer interfaces (profiles) are configured, incoming ISDN calls can be forwarded based on CLID (dialer caller), DNIS (dialer called) or PPP name authentication ( using dialer remote-name & ppp authentication chap/pap).

We have 3 ways to bind the in comming call onto the second dialer interface:

dialer caller xxxx / dialer called xxxxx (provided this info is sent in the q931 setup message) & dialer remote-name xxxxx.

Thanks, Mak.

Cisco Employee

Re: Unbindable Call error

Just to add as Mak mentioned, its a dialer profile config issue so we do need to see the running config with following debug when the call comes in and reports "call unbindable"

debug dialer

debug ppp nego

debug ppp auth

debug isdn q931

Post the debug with running config.

New Member

Re: Unbindable Call error

Many Thanks for the replies,

Here is the config etc.....

Regarding the Callerid etc - I guess that would mean we would need to always dial in from a certain Number ? I haven't tried this yet ....... I will let you know.

Building configuration...

Current configuration : 1341 bytes

!

version 12.2

no service pad

service timestamps debug datetime

service timestamps log datetime

no service password-encryption

!

hostname Test_801

!

boot system flash

logging buffered 200000 debugging

enable password xxxxx

!

username over1 password 0 over1

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 10.227.253.254 255.255.255.0

ip nat inside

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp multilink

!

interface Dialer1

description ISP

ip address negotiated

no ip proxy-arp

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 10

dialer string 08089916001

dialer-group 1

no cdp enable

ppp chap hostname Test.fsnet.co.uk

ppp chap password 0 test

!

interface Dialer2

ip address 10.199.1.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer-group 1

dialer remote-name over1

ppp authentication chap

!

ip nat inside source list 100 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 10.199.1.0 255.255.255.0 Dialer2

ip route 10.252.253.0 255.255.255.0 Dialer2

ip http server

!

!

access-list 100 permit ip any any

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

password test

login

!

no rcapi server

!

!

end

Test_801#

Test_801#

*Mar 1 00:06:33: ISDN BR0: RX <- SETUP pd = 8 callref = 0x01

*Mar 1 00:06:33: Sending Complete

*Mar 1 00:06:33: Bearer Capability i = 0x8890

*Mar 1 00:06:33: Channel ID i = 0x89

*Mar 1 00:06:33: Called Party Number i = 0x81, '290333', Plan:ISDN, Type:Unknown

*Mar 1 00:06:33: Low Layer Compat i = 0x8890

*Mar 1 00:06:33: CCBRI_Go Fr L3 pkt (Len=25) :

*Mar 1 00:06:33: 5 1 81 90 A1 4 2 88 90 18 1 89 70 7 81 32 39 30 33 33 33 7C 2 88 90

*Mar 1 00:06:33:

*Mar 1 00:06:33: ISDN BR0: Incoming call id = 0x0002, dsl 0

*Mar 1 00:06:33: ISDN BR0: LIF_EVENT: ces/callid 1/0x2 HOST_INCOMING_CALL

*Mar 1 00:06:33: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Mar 1 00:06:33: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Mar 1 00:06:33: ISDN BR0: llc valid, speed 64, call type is DATA

speed:0 async:N

*Mar 1 00:06:33: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call type is DATA

*Mar 1 00:06:33: ISDN BR0: Event: Received a DATA call from on B1 at 64 Kb/s

*Mar 1 00:06:33: ISDN BR0: Event: Accepting the call id 0x2

*Mar 1 00:06:33: ISDN BR0:1: Incoming call rejected, unbindable

*Mar 1 00:06:33: ISDN BR0: process_disconnect(): call id 0x2, call type is DATA, b_idb 0x284F318, ces 1, cause Call rejected(0x15)

*Mar 1 00:06:33: ISDN: get_isdn_service_state(): idb 0x284F318 bchan 2 is_isdn 1 Not a Pri

*Mar 1 00:06:33: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id 2

*Mar 1 00:06:33: CCBRI_Go Fr Host InPkgInfo (Len=13) :

*Mar 1 00:06:33: 5 0 1 0 2 3 8 1 95 8 2 80 95

*Mar 1 00:06:33:

*Mar 1 00:06:33: ISDN BR0: LIF_EVENT: ces/callid 1/0x2 HOST_DISCONNECT_ACK

*Mar 1 00:06:33: ISDN: get_isdn_service_state(): idb 0x284F318 bchan 2 is_isdn 1 Not a Pri

*Mar 1 00:06:33: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

*Mar 1 00:06:33: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x81

*Mar 1 00:06:33: Cause i = 0x8095 - Call rejected

*Mar 1 00:06:39: ISDN BR0: RX <- SETUP pd = 8 callref = 0x02

*Mar 1 00:06:39: Sending Complete

*Mar 1 00:06:39: Bearer Capability i = 0x8890

*Mar 1 00:06:39: Channel ID i = 0x89

*Mar 1 00:06:39: Called Party Number i = 0x81, '290333', Plan:ISDN, Type:Unknown

*Mar 1 00:06:39: Low Layer Compat i = 0x8890

*Mar 1 00:06:39: CCBRI_Go Fr L3 pkt (Len=25) :

*Mar 1 00:06:39: 5 1 82 90 A1 4 2 88 90 18 1 89 70 7 81 32 39 30 33 33 33 7C 2 88 90

*Mar 1 00:06:39:

*Mar 1 00:06:39: ISDN BR0: Incoming call id = 0x0003, dsl 0

*Mar 1 00:06:39: ISDN BR0: LIF_EVENT: ces/callid 1/0x3 HOST_INCOMING_CALL

*Mar 1 00:06:39: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Mar 1 00:06:39: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Mar 1 00:06:39: ISDN BR0: llc valid, speed 64, call type is DATA

speed:0 async:N

*Mar 1 00:06:39: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call type is DATA

*Mar 1 00:06:39: ISDN BR0: Event: Received a DATA call from on B1 at 64 Kb/s

*Mar 1 00:06:39: ISDN BR0: Event: Accepting the call id 0x3

*Mar 1 00:06:39: ISDN BR0:1: Incoming call rejected, unbindable

*Mar 1 00:06:39: ISDN BR0: process_disconnect(): call id 0x3, call type is DATA, b_idb 0x284F318, ces 1, cause Call rejected(0x15)

*Mar 1 00:06:39: ISDN: get_isdn_service_state(): idb 0x284F318 bchan 2 is_isdn 1 Not a Pri

*Mar 1 00:06:39: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id 3

*Mar 1 00:06:39: CCBRI_Go Fr Host InPkgInfo (Len=13) :

*Mar 1 00:06:39: 5 0 1 0 3 3 8 1 95 8 2 80 95

*Mar 1 00:06:39:

*Mar 1 00:06:39: ISDN BR0: LIF_EVENT: ces/callid 1/0x3 HOST_DISCONNECT_ACK

*Mar 1 00:06:39: ISDN: get_isdn_service_state(): idb 0x284F318 bchan 2 is_isdn 1 Not a Pri

*Mar 1 00:06:39: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

*Mar 1 00:06:39: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x82

*Mar 1 00:06:39: Cause i = 0x8095 - Call rejected

Cisco Employee

Re: Unbindable Call error

You need to turn on authentication under the "interface bri0" to bind the call to the dialer profile interface based on the remote-name. I can see that "ppp authentication chap" command is missing under the "interface bri0" so when call comes in router will try to bind based on caller id or dnis. So if you enter "ppp authentication chap" command under bri0 interface, dialin call will work fine.

New Member

Re: Unbindable Call error

DOH !!!!!!!

How on earth did I miss that ? ?

Many Thanks for the replies - I am suitably embarrassed !!

I guess I was looking for problems !

399
Views
0
Helpful
5
Replies
CreatePlease login to create content