Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Unnumbered Interface on 803

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname DSSacdpsb

!

enable password XXXXX

username Derbycimp password XXXXXXXX

!

no ip name-server

!

isdn switch-type basic-net3

pots country US

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to Derbycimp

ip unnumbered Ethernet 0

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name Derbycimp broadcast 12345

dialer map ip 192.168.216.254 name Derbycimp speed 64 broadcast 12345

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 192.168.211.254 255.255.255.0

no keepalive

ip access-group 100 in

!

interface BRI 0

no shutdown

description connected to Derbycimp

no ip address

dialer rotary-group 1

ip access-group 100 in

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

ip classless

!

no access-list 100

access-list 100 permit icmp any any

access-list 100 permit tcp any any range ftp-data ftp

access-list 100 permit tcp any any eq telnet

! IP Static Routes

ip route 192.168.216.0 255.255.255.0 Dialer 1 1 permanent

no ip http server

!

line console 0

exec-timeout 0 0

password XXXXXX

login

!

line vty 0 4

password XXXXX

login

!

end

When trying to establish a ISDN DDR connection to 192.168.216.100 the connection is dialed sucessfully but when IP is assigned the connection is dropped.

Debug output

01:55:23: BR0 DDR: rotor dialout [priority]

01:55:23: BR0 DDR: place call

01:55:23: BR0 DDR: Dialing cause snapshot

01:55:23: BR0 DDR: Attempting to dial 01332690039

01:55:23: ISDN BR0: TX -> SETUP pd = 8 callref = 0x4E

01:55:23: Bearer Capability i = 0x8890

01:55:23: Channel ID i = 0x83

01:55:23: Called Party Number i = 0x80, '01332690039', Plan:Unknown, Typ

e:Unknown

01:55:23: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xCE

01:55:23: Channel ID i = 0x89

01:55:24: ISDN BR0: RX <- ALERTING pd = 8 callref = 0xCE

01:55:24: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xCE

01:55:103079215104: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

01:55:24: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x4E

01:55:24: BR0:1 PPP: Treating connection as a callout

01:55:24: BR0:1 PPP: Authorization NOT required

01:55:24: BR0:1 CHAP: O CHALLENGE id 78 len 30 from "DSSacdpsb"

01:55:24: BR0:1 CHAP: I CHALLENGE id 1 len 30 from "Derbycimp"

01:55:24: BR0:1 CHAP: I RESPONSE id 78 len 30 from "Derbycimp"

01:55:24: BR0:1 PPP: Sent CHAP LOGIN Request to AAA

01:55:24: BR0:1 CHAP: Using hostname from configured hostname

01:55:24: BR0:1 CHAP: Using password from AAA

01:55:24: BR0:1 CHAP: O RESPONSE id 1 len 30 from "DSSacdpsb"

01:55:24: BR0:1 PPP: Received LOGIN Response from AAA = PASS

01:55:24: BR0:1 DDR: Remote name for Derbycimp

01:55:24: BR0:1 CHAP: O SUCCESS id 78 len 4

01:55:24: BR0:1 CHAP: I SUCCESS id 1 len 4

01:55:24: BR0:1 set_ip_peer(8): new address 192.168.216.254

01:55:24: BR0:1 set_ip_peer(0): new address 0.0.0.0

01:55:24: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xCE

01:55:24: Cause i = 0x8090 - Normal call clearing

All seams OK until the set_ip_peer output.

is this beace i'm using the Unnumbered IP for Dialer1 ?

The remote router is a BinTec ISDN router.

12 REPLIES
Bronze

Re: Unnumbered Interface on 803

Probably. But there were no IPCP nego output from your debug.

Most implementations use the same network address between the two peers.

You can try using another ip address on the dialer interface belonging to the

same network as the remote peer.

Hope this helps.

Cisco Employee

Re: Unnumbered Interface on 803

Need to see the debug for following as IPCP debug is not displayed.

debug isdn q931

debug ppp authentication

debug ppp negotiation

debug dialer

Community Member

Re: Unnumbered Interface on 803

Debug output as requested

15:44:37: BR0:1 PPP: Treating connection as a callout

15:44:37: BR0:1 PPP: Phase is ESTABLISHING, Active Open

15:44:37: BR0:1 PPP: Authorization NOT required

15:44:37: BR0:1 LCP: O CONFREQ [Closed] id 29 len 15

15:44:37: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

15:44:37: BR0:1 LCP: MagicNumber 0x05783C7C (0x050605783C7C)

15:44:37: BR0:1 LCP: I CONFREQ [REQsent] id 1 len 23

15:44:37: BR0:1 LCP: MRU 1524 (0x010405F4)

15:44:37: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

15:44:37: BR0:1 LCP: MagicNumber 0x4012312B (0x05064012312B)

15:44:37: BR0:1 LCP: PFC (0x0702)

15:44:37: BR0:1 LCP: ACFC (0x0802)

15:44:37: BR0:1 LCP: O CONFACK [REQsent] id 1 len 23

15:44:37: BR0:1 LCP: MRU 1524 (0x010405F4)

15:44:37: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

15:44:37: BR0:1 LCP: MagicNumber 0x4012312B (0x05064012312B)

15:44:37: BR0:1 LCP: PFC (0x0702)

15:44:37: BR0:1 LCP: ACFC (0x0802)

15:44:37: BR0:1 LCP: I CONFACK [ACKsent] id 29 len 15

15:44:37: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

15:44:37: BR0:1 LCP: MagicNumber 0x05783C7C (0x050605783C7C)

15:44:37: BR0:1 LCP: State is Open

15:44:37: BR0:1 PPP: Phase is AUTHENTICATING, by both

15:44:38: BR0:1 CHAP: O CHALLENGE id 15 len 30 from "DSSacdpsb"

15:44:38: BR0:1 CHAP: I CHALLENGE id 1 len 30 from "Derbycimp"

15:44:38: BR0:1 CHAP: I RESPONSE id 15 len 30 from "Derbycimp"

15:44:38: BR0:1 PPP: Sent CHAP LOGIN Request to AAA

15:44:38: BR0:1 CHAP: Using hostname from configured hostname

15:44:38: BR0:1 CHAP: Using password from AAA

15:44:38: BR0:1 CHAP: O RESPONSE id 1 len 30 from "DSSacdpsb"

15:44:38: BR0:1 PPP: Received LOGIN Response from AAA = PASS

15:44:38: BR0:1 DDR: Remote name for Derbycimp

15:44:38: BR0:1 CHAP: O SUCCESS id 15 len 4

15:44:38: BR0:1 CHAP: I SUCCESS id 1 len 4

15:44:38: BR0:1 PPP: Phase is UP

15:44:38: BR0:1 IPCP: O CONFREQ [Closed] id 15 len 10

15:44:38: BR0:1 IPCP: Address 192.168.211.254 (0x0306C0A8D3FE)

15:44:38: BR0:1 IPCP: I CONFREQ [REQsent] id 1 len 16

15:44:38: BR0:1 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

15:44:38: BR0:1 IPCP: Address 192.168.216.254 (0x0306C0A8D8FE)

15:44:38: BR0:1 IPCP: O CONFREJ [REQsent] id 1 len 10

15:44:38: BR0:1 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

15:44:38: BR0:1 CCP: I CONFREQ [Not negotiated] id 1 len 10

15:44:38: BR0:1 CCP: MS-PPC supported bits 0x00000020 (0x120600000020)

15:44:38: BR0:1 LCP: O PROTREJ [Open] id 30 len 16 protocol CCP (0x80FD0101000A1

20600000020)

15:44:38: BR0:1 IPCP: I CONFACK [REQsent] id 15 len 10

15:44:38: BR0:1 IPCP: Address 192.168.211.254 (0x0306C0A8D3FE)

15:44:38: BR0:1 IPCP: I CONFREQ [ACKrcvd] id 2 len 10

15:44:38: BR0:1 IPCP: Address 192.168.216.254 (0x0306C0A8D8FE)

15:44:38: BR0:1 IPCP: O CONFACK [ACKrcvd] id 2 len 10

15:44:38: BR0:1 IPCP: Address 192.168.216.254 (0x0306C0A8D8FE)

15:44:38: BR0:1 IPCP: State is Open

15:44:38: Di1 IPCP: Install route to 192.168.216.254

15:44:38: BR0:1 IPCP: Add link info for cef entry 192.168.216.254

15:44:38: BR0:1 LCP: I TERMREQ [Open] id 2 len 4

15:44:38: BR0:1 LCP: O TERMACK [Open] id 2 len 4

15:44:38: BR0:1 IPCP: Remove link info for cef entry 192.168.216.254

15:44:38: BR0:1 IPCP: State is Closed

15:44:38: BR0:1 PPP: Phase is TERMINATING

15:44:38: BR0:1 DDR: dialer protocol up

15:44:38: BR0:1 PPP: Outbound ip packet dropped, line protocol not up

15:44:38: BR0:1 PPP: Outbound ip packet dropped, line protocol not up

15:44:38: BR0:1 DDR: Call connected, 2 packets unqueued, 0 transmitted, 2 discar

ded

15:44:38: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x8F

15:44:38: Cause i = 0x8090 - Normal call clearing

15:44:167512106340: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 013326

90039 Derbycimp

15:44:167512106172: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 0133

2690039 Derbycimp, call lasted 1 seconds

15:44:167503724544: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

15:44:39: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x0F

15:44:39: Cause i = 0x8090 - Normal call clearing

15:44:39: Di1 IPCP: Remove route to 192.168.216.254

15:44:39: BR0:1 LCP: State is Closed

15:44:39: BR0:1 PPP: Phase is DOWN

15:44:39: BR0:1 DDR: disconnecting call

15:44:39: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x8F

I also made a slight change to the Config

! IP Static Routes

ip route 192.168.216.254 255.255.255.255 Dialer1

ip route 192.168.216.0 255.255.255.0 192.168.216.254

Cisco Employee

Re: Unnumbered Interface on 803

There is ip address mismatch here. Derbycimp wants to negotiate 192.168.216.254 ip address while DSSacdpsb wants to negotiate 192.168.211.254. Both the ip address are in two different networks. That is the problem on point to point link. You need to have both the peers on the same network/subnet.

So to make that work, you need to allocate the ip address of the ethernet interface on DSSacdpsb from 192.168.216.0 network. or use the different addressing scheme.

That way we will have both the peers in the same ip network..Once that changed you will be able to ping ecah other fine.

Community Member

Re: Unnumbered Interface on 803

Thanks for your help so far!

When i change Dialer1 conf to

ip address 192.168.216.250 255.255.255.0

I get the following output why is the line being drop as soon as the IP's are declared by each router ?

00:16:52: BR0:1 PPP: Phase is UP

00:16:52: BR0:1 IPCP: O CONFREQ [Closed] id 10 len 10

00:16:52: BR0:1 IPCP: Address 192.168.216.250 (0x0306C0A8D8FA)

00:16:52: BR0:1 CCP: I CONFREQ [Not negotiated] id 1 len 10

00:16:52: BR0:1 CCP: MS-PPC supported bits 0x00000020 (0x120600000020)

00:16:52: BR0:1 LCP: O PROTREJ [Open] id 20 len 16 protocol CCP (0x80FD0101000A1

20600000020)

00:16:52: BR0:1 IPCP: I CONFREQ [REQsent] id 1 len 16

00:16:52: BR0:1 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

00:16:52: BR0:1 IPCP: Address 192.168.216.254 (0x0306C0A8D8FE)

00:16:52: BR0:1 IPCP: O CONFREJ [REQsent] id 1 len 10

00:16:52: BR0:1 IPCP: CompressType VJ 15 slots (0x0206002D0F00)

00:16:52: BR0:1 IPCP: I CONFACK [REQsent] id 10 len 10

00:16:52: BR0:1 IPCP: Address 192.168.216.250 (0x0306C0A8D8FA)

00:16:52: BR0:1 LCP: I TERMREQ [Open] id 2 len 4

00:16:52: BR0:1 LCP: O TERMACK [Open] id 2 len 4

00:16:52: BR0:1 IPCP: State is Closed

00:16:52: BR0:1 PPP: Phase is TERMINATING

00:16:52: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x8A

00:16:52: Cause i = 0x8090 - Normal call clearing

Cisco Employee

Re: Unnumbered Interface on 803

For wahtever reason this router got request to clear the connection..as we have received

00:16:52: BR0:1 LCP: I TERMREQ [Open] id 2 len 4

Now once this router rejects VJ compression, the other router should send CONFREG with just ip address as 192.168.216.254 but instead that router send TERMREQ..So i think you need to talk to other side router's admin about compressin issue..

You can configure "compress mppc" command under the bri0 interface and see if that makes any difference..Otherwise you need to talk to other side router's admin to sort that compression issue,

Community Member

Re: Unnumbered Interface on 803

I've got details from the remote router admin

Encapsulation PPP

Compress STAC

Encryption MPPE 40

I assume that I need

Interface BRI0

compress STAC

but what IOS do I need from the Encryption type Mppe ?

Thanks

Cisco Employee

Re: Unnumbered Interface on 803

I think you are trying to replace the windows PC dialout to some server by 803 router..Looking on the previous debug you just need to have following to successfully negotiate the ip address between two routers.

Interface BRI0

compress STAC

Now if the remote side router is looking for Microsoft Point-to-Point Encryption (MPPE) 40 for data, you need images with IPSEC featureset in it. But 800 routers dosen't supports MPPE as per following url.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/dt_pptp.htm

Community Member

Re: Unnumbered Interface on 803

Thanks for your help removing MPPE 40 from teh remote router lets this config work!

Next question how dow I had a second Dialer ?

Dialer2

New IP Range 192.168.217.0

I'm confussed about the Dialer-Groups

Cisco Employee

Re: Unnumbered Interface on 803

Need to know why exactly you need the second dialer for. You can't add a second dialer interface using "dialer rotary-group x" one one physical bri interface. For that you need to have dialer-profiles" configured with one bri interface has a pool of two dialer interface. Here is the sample config for that

http://www.cisco.com/warp/public/793/access_dial/ddr_dialer_profile.html

OR

you can use another dialer-map in the same config.

Community Member

Re: Unnumbered Interface on 803

I need to be able to Route to a different Remote Network.

by Dialer Map i assume you mean something like :-

dialer map snapshot 1 name Sealcimp broadcast 54321

dialer map ip 192.168.217.254 name Sealcimp speed 64 broadcast 54321

Can U point me in the direction of some "Dialer Map" info?

Community Member

Re: Unnumbered Interface on 803

I need to be able to Route to a different Remote Network.

by Dialer Map i assume you mean something like :-

dialer map snapshot 1 name Sealcimp broadcast 54321

dialer map ip 192.168.217.254 name Sealcimp speed 64 broadcast 54321

Can U point me in the direction of some "Dialer Map" info?

162
Views
0
Helpful
12
Replies
CreatePlease to create content