Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Unwanted DHCP or connection fails

Let me start by saying that I am very inexperienced with Cisco routers. I have two remote users (Howard and Gary - me) who dial into our central site which has an 801 ISDN router. Originally, one remote user had a 761 router and the other an 801. A couple of years ago we switched to using terminal adapters (Xircom) and are now using Eicon USB adapters. The dial up used to work OK with the TAs (and at one time there was a third user, GaryM).

For application reasons, both remote PCs need fixed IP addresses and the central network uses only static IP addresses. This used to work OK and the central 801 dials back.

Now what happens with both remote PCs (which are the same hardware/OS) is that with the IP address (of say) 10.0.1.6, the remote PC dials up, authenticates (as Gary-TA, e.g.) and hangs up waiting for the dial-back, which then occurs; however the connection is then dropped immediately with the connection being refused by the server.

If I set the remote PC to "Obtain IP address automatically", on dial-back, the IP address 172.16.0.2 is assigned, and is accepted. The connection holds, but unfortunately, none of my central machines know anything about 172.16.0.2.

I don't know what's caused this. Changes that I can think of between it working and now have been:

1) Service pack update on Win2K

2) Change to WinXP

3) Change from Xircom to Eicon TA

4) (Attempt to) enable SNMP on the 801

maybe other stuff.

Please, Please can someone help?

Thanks,

Gary Cooper

801 Configuration

-----------------

Script started on Fri Mar 7 15:40:11 2003

cmserver:/home/gcooper:291> script router.config2

telnet central-801

Trying...

Connected to Central-801.

Escape character is '^]'.

Local flow control off

User Access Verification

Password:

Central-801>en

Password:

Central-801#sho conf

Using 1865 out of 8064 bytes

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Central-801

!

logging buffered 200000 debugging

enable secret 5 <encrypted password>

enable password <password>

!

username Gary-801 password 0 <password>

username Howard-761 password 0 <password>

username Gary-TA callback-dialstring <dialback no> password 0 <password>

username Howard-TA callback-dialstring <dialback no> password 0 <password>

username GaryM-TA callback-dialstring <dialback no> password 0 <password>

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address <lan IP of router> 255.255.255.0

no ip directed-broadcast

!

interface BRI0

description ******* ISDN Link to Gary and Howard *******

ip address 172.16.0.1 255.255.255.248

no ip directed-broadcast

encapsulation ppp

dialer map ip 172.16.0.4 name Gary-TA class gadc

dialer map ip 172.16.0.5 name Howard-TA class gadc

dialer map ip 172.16.0.6 name GaryM-TA class gadc

dialer map ip 172.16.0.2 name Gary-801 class gadc broadcast <dialback no>

dialer map ip 172.16.0.3 name Howard-761 class gadc broadcast <dialback no>

dialer-group 1

isdn switch-type basic-net3

compress stac

ppp callback accept

ppp authentication chap

ppp chap hostname Central-801

ppp chap password 7 <encrypted password>

hold-queue 75 in

!

ip classless

ip route 10.0.1.0 255.255.255.0 172.16.0.2

ip route 10.0.2.0 255.255.255.0 172.16.0.3

ip route 11.0.0.0 255.0.0.0 192.37.248.199

!

!

map-class dialer gadc

dialer callback-server username

dialer-list 1 protocol ip permit

snmp-server community public RO

snmp-server chassis-id Cisco801

snmp-server enable traps snmp

snmp-server enable traps isdn call-information

snmp-server host 192.37.248.250 traps public snmp

!

line con 0

transport input none

stopbits 1

line vty 0 4

password <password>

login

!

end

Central-801#exit

Connection closed by foreign host.

cmserver:/home/gcooper:292> exit

script done on Fri Mar 7 15:40:37 2003

3 REPLIES
Bronze

Re: Unwanted DHCP or connection fails

Your router is still configured as though there is a router on your remote sites between the central router and the remote PCs. You have the network 10.0.1.0/24 at Gary's house and 10.0.2.0/24 at Howard's. The easiest way to change the central router to reflect the fact that Gary and Howard no longer have routers on their sites is to enter the following commands:

ip subnet-zero

interface Bri0

ip address 10.0.0.1 255.255.252.0

no dialer map ip 172.16.0.4 name Gary-TA class gadc

no dialer map ip 172.16.0.5 name Howard-TA class gadc

no dialer map ip 172.16.0.6 name GaryM-TA class gadc

no dialer map ip 172.16.0.2 name Gary-801 class gadc broadcast

no dialer map ip 172.16.0.3 name Howard-761 class gadc broadcast

dialer map ip 10.0.1.6 name Gary-TA class gadc

dialer map ip (Howard's IP address) name Howard-TA class gadc

These new dialer maps reflect the fixed IP addresses on Gary's and Howard's PCs. The ip subnet-zero command will allow the use of the address space 10.0.0.0/22

HTH

Mark

Community Member

Re: Unwanted DHCP or connection fails

Thanks for the reply Mark. I'll give your suggestion a go. I probably won't get the opportunity for a few days, but will get back to you when I've tried it.

Thanks again,

Gary

Community Member

Re: Unwanted DHCP or connection fails

Hi Mark,

I managed to try the connection out last night and it worked fine - many thanks.

One thing that was a bit puzzling though was that Howard also dialled in last night; he tried it with his new notebook and whilst he managed to get in with IP address 10.0.2.2 (which was the IP address used in the dialer map command), he had application problems and so went back to his old notebook. It has IP address 10.0.2.1 and so I expected it to be rejected - it wasn't! Any ideas why?

Thanks again,

Gary

148
Views
0
Helpful
3
Replies
CreatePlease to create content