Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Upgrading 2500 routers

I have 4 Cisco 2500 routers, and am trying to upgrade to 12.2 (21) from 12.2 (17), but I am not able to uprade. It won't delete the existing IOS from flash. When I run "Sh Ver", I see that the Flash is read-only. Does that mean that I can't upgrade the IOS.

Please advise.

8 REPLIES
New Member

Re: Upgrading 2500 routers

How exactly are you trying to upgrade? Flash in the 2500s, if there is only one partition is always read-only. But this should not effect you ability to upgrade them.

If you use the command "copy tftp flash" the flash loader should run and pretty much do everything for you once you put int he ip address of the tftp server, and the file name.

You can also use a 2500 as a tftp server. If for example you hae a 2500 that has only serial connections (such as a 2523 and no token ring available), you can connect the rotuers back-to-back and use copy tftp flash and give the tftp server as the attached router.

Please provide additional info if this doesn't help.

Joe

New Member

Re: Upgrading 2500 routers

I met the problem. but I think maybe our situation is diffirent. for me, my ios on the 8M flash can not be deleted. I try to use diffirent way to delete it, but I can not.

so I think maybe the IOS on the flash can be read only, like some "bios information on the computer mainboard" ,maybe. I am not sure.

New Member

Re: Upgrading 2500 routers

Here is a copy from one of my routers:

cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory.

Processor board ID 16904023, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

16 terminal line(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read ONLY)

This says flash "read-only" as well, but I have never had a single problem upgrading the IOS.

How are you trying to upgrade the IOS? I don't think the router will just let you erase the flash, you have to erase it and then upload a new IOS one after another. This is extremely easy using the command "copy tftp flash":

TermServ#copy tftp flash

**** NOTICE ****

Flash load helper v1.0

This process will accept the copy options and then terminatethe current system image to use the ROM based image for the copy. Routing functionality will not be available during that time. If you are logged in via telnet, this connection will terminate. Users with console access can see the results of the copy operation.

---- ******** ----

Proceed? [confirm]

Just hit retunr, enter the ip address of the tftp server, the source file and the destination file (the same), and the router does the rest.

How are you trying to upgrade the IOS?

HTH,

Joe

New Member

Re: Upgrading 2500 routers

Thanks Joe,

I tried to erase or delete flash by manually typing the command that I couldn't do it. Then I just did through the regular upgrade procedure the same way you mentioned, but the router couldn't connect to TFTP server. I made sure that I was able to ping the TFTP server first, and I was. I will try it again tonight, and then send you the outputs if not able to do it. But I have the same sh ver, showing flash (Read-only) so I guess I should be able to do it.

Thanks

New Member

Re: Upgrading 2500 routers

Steps to upgrade ios

1. connect router console to pc com port

2. access router through hyperterminal.

3. router ethernet and pc where tftp server is running are should be on same network.

4. router and tftp server pc are able to communicate with each other via ping

5. both are pinging save router configuration

6. give " sh ver " and check last line configuration registry is 0x2102

7. check the flash size and ios which is going to be upgraded size. ios size > flash size.

8.

================

router# copy tftp flash

do you want to proceed? Y/N

source file name? c2500-ios56i-11.3-T1.bin

// new ios file name//

remote hostname? 192.168.1.10

// tftp server ip address//

destination file name[c2500-ios56i-11.3-T1.bin] ? c2500-ios56i-11.3-T1.bin

do you want to erase flash [ confirm ] ?

do you want to erase flash ? [y/n] Y

===============

router starts reloading

erasing flash eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

hope it will help you

New Member

Re: Upgrading 2500 routers

These steps shold work perfectly.

Make sure that you have enough RAM and flash for the new images.

Joe

Silver

Re: Upgrading 2500 routers

Also verify that the link you are trying to do the download over is supported by the boot roms (you left the SW & FW version lines off the show version you posted. If you are not running the latest boot ROMs (circa 2000), you will have to have a TFTP server on the local LAN. Even with the latest boot ROMs, the path to the TFTP server must be statically defined, there are no routing protocols running when the time comes to download the IOS image. Note that this may require static routes to get from the TFTP server back to the router being loaded...

As others have mentioned, it is much easier to load up the new IOS on a notebook computer and go on site to do the job... I've been doing that since back in the days of OS/2.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

New Member

Re: Upgrading 2500 routers

I just upgraded 10 Cisco 2520 recently. You will need to access the router via console port so you can see the errors message why it failed. What I had to do was change the config register from 0x2102 to 0x2101. This place the router in boot mode but changes the flash to read/write so it can be erase. Here is a url for a reference.

www.cisco.com/en/US/customer/products/hw/routers/ps233/products_tech_note09186a00800941aa.shtml

121
Views
0
Helpful
8
Replies
CreatePlease to create content