Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

URGENT! Router 2621 can't ping its serial0/0??

Please if anyone could help me on the following strange problem that I encountered! Router 2621 fails to ping its serial0/0 but no problem to ping serial0/1. Did I miss any configuration here? Thanks.

(1) SETTINGS ON Router B (branch)

Router 2621 with WIC: (delicated link leased line for internal SAP connection)

serial 0/0 connect to Router A (HQ)

ip address: 192.168.254.2/24

serial 0/1 connect to Router C (branch)

ip address: 172.16.1.11/16

fastethernet 0/0 10.20.1.10/16

ip route 0.0.0.0 0.0.0.0 10.20.1.1 (firewall)

ip route 10.1.0.0 255.255.0.0 192.168.254.1 (Router A serial0 interface)

ip route 10.30.0.0 255.255.0.0 172.16.1.21 (Router C serial0 interface)

serial0/0 192.168.254.2 directly connected

serial0/1 172.16.1.11 directly connected

(2) SETTINGS ON Router C (branch)

serial0 Leased line to Router B

ip address: 172.161.21/16

fastethernet0 10.30.1.10/16

ip route 10.20.0.0 255.255.0.0 172.16.1.11

ip route 10.1.0.0 255.255.0.0 172.16.1.11

From Router B:

When I try to ping 192.168.254.2 (serial 0/0), it FAILED! I can ping serial 0/1 172.16.1.11, Router A serial0 192.168.254.1, Router C serial0 172.16.1.21 and their internal LAN interfaces.

From Router A:

Failed to ping 192.168.254.2, 172.16.1.21 and 10.30.0.0 network segment

From Router C:

Failed to ping 192.168.254.2, 192.168.254.1 and 10.1.0.0 network segment.

When I trace route to send packet from Router C 10.30.0.0 network to Router A 10.1.0.1 network, the packet from Router C LAN (10.30.0.0) sends to Router B serial0/1 (172.16.1.11) but can't proceed to re-route to Router A serial0 (192.168.254.1).

My question is: Why Router B fails to ping serial0/0 192.168.254.2 itself? I even tried to remove the firewall but to no avail. Funny thing is Router B 10.20.0.0 network has no problem to access SAP at Router A 10.1.0.0 network. Any suggestion, please?

10 REPLIES
Silver

Re: URGENT! Router 2621 can't ping its serial0/0??

Do you have any access-list preventing icmp on router B s0/0 interface?

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

No access lists are applied to this router B. WIC-2T is used on this router. I wonder if the WIC-2T is causing problem. I have tried many methods including restarting the router and re-configuring Router B serial0/0 to different IP addresses but to no avail. It just seems to me that serial0/1 and serial0/0 on Router B somehow are not connected/ do not recognized each other. Any ideas?

Silver

Re: URGENT! Router 2621 can't ping its serial0/0??

your problem may be on the remote end of s0/0 . When you ping yourself the packet goes out on the wire to the remote end then comes back .

What are the configs on the router b s0/0 and the remote end ?

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

ROUTER B (Cisco 2621):

!

interface FastEthernet0/0

ip address 10.20.1.10 255.255.0.0

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.254.2 255.255.255.0

no ip mroute-cache

!

interface FastEthernet0/1

no ip address

no ip mroute-cache

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 172.16.1.11 255.255.255.0

no ip mroute-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.20.1.7 -->(firewall)

ip route 10.1.0.0 255.255.0.0 192.168.254.1

ip route 10.30.0.0 255.255.0.0 172.16.1.21

!

ROUTER A (Cisco 2500:remote end):

!

interface Serial1

ip address 192.168.254.1 255.255.255.0

ip access-group 101 out

!

ip domain-name 10.1.1.1

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.250

ip route 10.2.0.0 255.255.0.0 20.20.20.1 --> (serial0)

ip route 10.20.0.0 255.255.0.0 192.168.254.2

ip route 10.30.0.0 255.255.0.0 192.168.254.2

access-list 101 permit ip host 10.1.1.30 10.20.0.0 0.0.255.255

access-list 101 permit ip host 10.1.1.31 10.20.0.0 0.0.255.255

access-list 101 permit ip host 10.1.1.32 10.20.0.0 0.0.255.255

access-list 101 permit ip host 10.1.1.30 10.30.0.0 0.0.255.255

access-list 101 permit ip host 10.1.1.31 10.30.0.0 0.0.255.255

access-list 101 permit ip host 10.1.1.32 10.30.0.0 0.0.255.255

!

ROUTER C (Cisco 1700:remote end):

!

interface FastEthernet0

ip address 10.30.1.10 255.255.0.0

speed auto

no cdp enable

!

interface Serial0

ip address 172.16.1.21 255.255.255.0

no fair-queue

no cdp enable

!

ip classless

ip route 10.1.0.0 255.255.0.0 172.16.1.11

ip route 10.20.0.0 255.255.0.0 172.16.1.11

That is the configurations on three routers. Router C can ping Router B's Serial0/1, but not Router B's Serial0/0, and the packet can't route to Router A! The traceroute shows that packets from Router C send to Router B's Serial0/1

and lost!! I still can't figure out why. Any suggestion is appreciated.

Silver

Re: URGENT! Router 2621 can't ping its serial0/0??

The fact that router B itself can't ping its own interface is very serious! Maybe you can try replacing the WIC card and check. However, how does the sh ip route look like in router A, B and C?

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

Try removing the access list on router a s1. And then try to ping router b from router a again.

Silver

Re: URGENT! Router 2621 can't ping its serial0/0??

Your problem is you have no routes to the 192.168.254.0/24 subnet from the C router. you need to either configure statics or a dynamic routing protocol.

If you ping the 192.168.254.2 on the B router sourcing it from the s0/1 interface your pings will also fail.

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

Another thing you can try is to put the interface in question in loopback (try a hard loopback as well) and test the interface. Try this site for info: http://www.cisco.com/warp/public/471/hard_loopback.html

Steve

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

Make sure that the interface is up/up

show interface s0/0

If it is not up, put a loopback on it.

If you can ping it with the loopback the problem is on the circuit or the device on the other end. If not then it's an interface problem.

New Member

Re: URGENT! Router 2621 can't ping its serial0/0??

Thanks for all your suggestions. Guess what? Router A and Router B are using Frame Relay. According to Cisco engineer, you can't ping Frame Relay interface. But I still don't quite understand why Router A can ping itself even though the serial interface is also connecting to Frame Relay.

227
Views
0
Helpful
10
Replies
CreatePlease to create content