Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Using a router as an Internet connection sharing device

Hi,

I would like to use a router 1605-R to share a dial-up connection to the internet. This router has an ethernet port which I can configure easily. It's also got a serial interface to which is connected an analog modem via a DTE RS-232 - DB60 cable.

This router is connected to a hub via its LAN interface. On the same hub, computers are also connected & have IP addresses on the same subnet as the IP address of the LAN interface of the router and are configured to use this same LAN interface as a gateway.

My question is: how do I configure the serial interface (step by step) so that any request from any computer to a web address causes the router to start the dial up connection to Internet via the analog modem.

I urgently need help on this!!!

Thank you.

16 REPLIES

Re: Using a router as an Internet connection sharing device

I have a fairly simple config which contains all configuration except for the modem control. Hope it helps a bit to understand about NAT and ip routes.

hostname Internet

!

enable password removed

!

ip subnet-zero

ip name-server x.x.x.x

!

!

!

interface Ethernet0

ip address 172.16.4.6 255.255.0.0

no ip directed-broadcast

ip nat inside

!

interface serial0

ip address x.x.x.x 255.255.255.252 (can also be ip negotiated)

no ip directed-broadcast

ip nat outside

no cdp enable

encapsulation ppp

!

ip nat inside source list 1 interface serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 serial0

!

access-list 1 permit 172.16.0.0 0.0.255.255

!

line con 0

transport input none

line vty 0 4

access-class 1 in

password removed

login

!

end

New Member

Re: Using a router as an Internet connection sharing device

Thanks for your help.

Yet, how come you don't supply any username nor password for your router to authenticate to the ISP? Also, the router should cause the modem to dial the ISP phone number. Where is that?

On which IOS version is NAT available? Can I update my IOS version somewhere from Cisco website in case it doesn't support NAT?

Riadh.

Bronze

Re: Using a router as an Internet connection sharing device

Below is a sample config that you can try:

!

interface ethernet0

ip address 10.10.10.254 255.255.255.0

ip nat inside

!

interface serial0

physical-layer async

no ip address

encapsulation ppp

async mode dedicated

dialer pool-member 1

!

interface dialer1

ip address negotiated

encapsulation ppp

dialer wait-for-carrier-time 30

dialer string

dialer pool 1

dialer-group 1

ppp pap sent-username password

ip nat outside

!

ip nat inside source list 100 interface dialer 1 overload

ip route 0.0.0.0 0.0.0.0 dialer1

access-list 100 permit ip 10.10.10.0 0.0.0.255 any

dialer-list 1 protocol ip list 100

!

Goodluck!

New Member

Re: Using a router as an Internet connection sharing device

Hi,

Thanks for your config.

Two commands were not accepted on my router:

- physical-layer async

- async mode dedicated

Still no luck. I guess because of the 2 above commands!!!

The router I have is a cisco 2620.

Any other advice.

Thanks again.

Bronze

Re: Using a router as an Internet connection sharing device

The "physical-layer async" command can be used for the serial interface

of a Cisco 1600 router. You mentioned in your first post that you wanted

to use a 1605-R router that's why I assumed you have a Serial WIC installed

on the 1605's WIC slot. It would be better if you could post the output

of the following:

- show version

- show diag

- show run

We have to check if the serial interface(s) of your router are

capable of running async. If you have typed the "physical-layer async"

command under the serial interface, that interface could probably

be SYNC capable only. The output of the commands above will help us

to verify this assumption. Thanks.

New Member

Re: Using a router as an Internet connection sharing device

Yeah, that's right, I mentioned that I had a 1605-R router but that one did not accept ip nat commands. That's why, I tried on a separate 2620.

The 1605 accepted the physical-layer async & not the ip nat, whereas the 2620 accepted the ip nat but not the physical-layer command.

I'll send the result for your above commands in separate posts.

Thanks a lot for your help.

New Member

Re: Using a router as an Internet connection sharing device

For the 2621

- Show ver gives:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IK9O3S-M), Version 12.2(6a), RELEASE SOFTWARE (fc

1)

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sat 01-Dec-01 20:52 by pwade

Image text-base: 0x80008088, data-base: 0x8120F8B8

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Router uptime is 8 minutes

System returned to ROM by power-on

System image file is "flash:c2600-ik9o3s-mz.122-6a.bin"

cisco 2621 (MPC860) processor (revision 0x600) with 60416K/5120K bytes of memory

.

Processor board ID JAD05450T6X (4029363579)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

- Show diag gives

Slot 0:

C2621 2FE Mainboard Port adapter, 3 ports

Port adapter is analyzed

Port adapter insertion time unknown

EEPROM contents at hardware discovery:

Hardware Revision : 6.0

PCB Serial Number : JAD05450T6X (4029363579)

Part Number : 73-3200-10

RMA History : 00

RMA Number : 0-0-0-0

Board Revision : B0

Deviation Number : 0-0

EEPROM format version 4

EEPROM contents (hex):

0x00: 04 FF 40 00 A2 41 06 00 C1 18 4A 41 44 30 35 34

0x10: 35 30 54 36 58 20 28 34 30 32 39 33 36 33 35 37

0x20: 39 29 82 49 0C 80 0A 04 00 81 00 00 00 00 42 42

0x30: 30 80 00 00 00 00 FF FF FF FF FF FF FF FF FF FF

0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

WIC Slot 0:

Serial 1T WAN daughter card

Hardware revision 1.1 Board revision E0

Serial number 7037567 Part number 73-1775-02

Test history 0x0 RMA number 00-00-00

Connector type Wan Module

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 02 01 01 00 6B 62 7F 49 06 EF 02 00 00 00 00

0x30: 70 00 00 00 98 01 21 01 FF FF FF FF FF FF FF FF

I only have one Serial WIC card. So you may find it's the same serial number on 1605-r & 2621.

Thanx

New Member

Re: Using a router as an Internet connection sharing device

For the 1605-r

- show version gives:

Cisco Internetwork Operating System Software

IOS (tm) 1600 Software (C1600-NY-M), Version 11.2(11)P, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1998 by cisco Systems, Inc.

Compiled Tue 06-Jan-98 06:34 by dschwart

Image text-base: 0x02005000, data-base: 0x023564C8

ROM: System Bootstrap, Version 11.1(12)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc

1)

ROM: 1600 Software (C1600-RBOOT-R), Version 11.1(12)XA, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

Router uptime is 14 minutes

System restarted by power-on

System image file is "flash:c1600-ny-mz.112-11.P", booted via flash

cisco 1605 (68360) processor (revision C) with 15872K/512K bytes of memory.

Processor board ID 07708118, with hardware revision 00000000

Bridging software.

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

2 Ethernet/IEEE 802.3 interface(s)

1 serial(sync/async) network interface(s)

System/IO memory with parity disabled

8192K bytes of DRAM onboard 8192K bytes of DRAM on SIMM

System running from RAM

8K bytes of non-volatile configuration memory

2048K bytes of processor board PCMCIA flash (Read/Write)

Configuration register is 0x2102

show diag gives:

Serial 1T WAN daughter card

Hardware revision 1.1 Board revision E0

Serial number 0007037567 Part number 73-1775-02

Test history 0x00 RMA number 00-00-00

Connector type WAN Module

EEPROM format version 1

EEPROM contents (hex):

0x00: 01 02 01 01 00 6B 62 7F 49 06 EF 02 00 00 00 00

0x10: 70 00 00 00 98 01 21 01 FF FF FF FF FF FF FF FF

2620 ver & diag follow soon!!!

Bronze

Re: Using a router as an Internet connection sharing device

From the show diag of your 2600, I believe the WIC-1T installed in slot 0

only supports synchronous communication when installed in the 2600 router.

That's why it does not support the 'physical-layer async' command.

Unless you're going to install a module or card that supports ASYNC,

you can probably use the AUX port of your router to dial-in to the ISP.

The following link could be used as a reference on how to configure

dialout using the AUX port:

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094579.shtml

Goodluck.

New Member

Re: Using a router as an Internet connection sharing device

Hi,

And thanks again for your help.

Why then does it say, under the 1605-r show ver:

- 1 serial(sync/async) network interface(s)?

I'll try with the aux port and I'll get back to you.

New Member

Re: Using a router as an Internet connection sharing device

Hi,

I tried to combine in some way the 1st config you sent me to the CISCO document you linked in your last message.

The result is this:

Building configuration...

Current configuration : 1375 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable secret 5 $1$gOGe$gBJ0TptVLcON9r9wzsTuj/

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

!

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 connect \c

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.10 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Async65

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 20

async default routing

!

interface Dialer10

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 20

dialer string 1616

dialer-group 1

ppp pap sent-username ataj password

!

ip nat inside source list 100 interface Dialer10 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer10

ip http server

ip pim bidir-enable

!

access-list 100 permit ip 192.168.0.0 0.0.0.255 any

dialer-list 1 protocol ip list 100

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

script dialer Dialout

modem InOut

modem autoconfigure type default

transport input all

stopbits 1

speed 57600

flowcontrol hardware

line vty 0 4

login

!

no scheduler allocate

end

When I ping any external IP address, the modem dials the number & the connection is established but nothing more than that. Success rate is 0 percent & ht elink goes down after a few seconds.

Is there anything missing in my configuration?

New Member

Re: Using a router as an Internet connection sharing device

I suspect my problem is related to these missing three lines:

aaa new-model

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

These lines are available on the link you sent me: Configuring Dialout using a modem on the AUX Port. They mean nothing to me. That's why I want to know what they're for before I add them. 'Cause on that document it says "--- This is the basic AAA configuration for PPP calls."

I'm getting there thanks to your HELP :)

New Member

Re: Using a router as an Internet connection sharing device

One last question: How can I make the modem only dial out? I don't want it to accept calls when the line receives an incoming call.

Bronze

Re: Using a router as an Internet connection sharing device

"When I ping any external IP address, the modem dials the number & the

connection is established but nothing more than that. Success rate is

0 percent & ht elink goes down after a few seconds."

Just to be sure that there are no problems with the user account

that you are using, please verify that you can connect to the

ISP using a PC and that account. Also check the ip address given

to the host PC and verify that you can browse the web.

You mentioned that the connection was established but goes down after

a few seconds. Were you able to check that you have acquired an IP address

from the ISP? It might be that the connection was not fully established.

It can be verified by the following debugs:

debug ppp negotiation

debug ppp authentication

I believe you don't need the AAA lines to perform a dial-out correctly.

Those lines are to be used to authenticate incoming calls and login.

"How can I make the modem only dial out?"

Typically, for this scenario, I use the command "modem inout" to perform

dialout. From the documentation, it mentioned that, by default, incoming

calls are not permitted (see the link below),

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122tcr/122tdr/drflcmo.htm#1112753

so could try removing the "modem inout" command and see if the router is

still able to perform dialout.

Basically, what we need are the debug output to check and verify where the

problem is. Thanks.

New Member

Re: Using a router as an Internet connection sharing device

Hi,

I am kinda fed up with this. Sometimes it works sometimes it doesn't & it makes me waste a lot of time: the modem doesn't wanna dial at all now, it does not respond either. I think I'll resort to using a PC for sharing an Internet connection. So much simpler.

I'm sorry for all this but I do thank you for all your time & patience.

Silver

Re: Using a router as an Internet connection sharing device

"modem dtr-active" will allow dialout only.

Thanks, Mak.

351
Views
0
Helpful
16
Replies