Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Using ISDN TA for dialling to AS5300

we have a NAS setup comprising of AS5300 and PRI links grouped into a hunting group. Currently all the dialin users are V.90 modem users using PSTN to log into the NAS after getting authenticated by the AAA server. Now we have requirement to add ISDN dialin users to the existing NAS network. I am not very sure how we can setup connectivity for these ISDN users using TA.

I have gone thru the site

http://www.cisco.com/warp/public/129/28.shtml#config_opts ...

but here it mentions to remove AAA auth which i cannot do as my existing modem users will be affected.

Can anyone provide a config which will allow the existance of both analog modem users and ISDN TA users. (AAA is a must).

3 REPLIES
New Member

Re: Using ISDN TA for dialling to AS5300

Hi,

You need to configure your controller to support ISDN PRI.You can use the following configs as templates for both analog & ISDN users.

However, I'm not sure how you want the user authentication to be. If you want to allow same user name/password to access ISDN service no problem, just go ahead; no nas port entries are required at you authentication server. Otherwise you should have NAS PORT entries at your authentication server to identify the Analog/ISDN users.

If you post your aaa configuration we could proceed further.

Regds,

Dinesh.K

!

isdn switch-type primary-net5

!

controller e1 1/0/11

pri-group time-slots 1-31

!

interface serial 1/0/11:15

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

peer default ip address pool DIALPOOL

ppp authentication pap chap

ppp multilink

!

dialer-list 1 protocol ip permit

New Member

Re: Using ISDN TA for dialling to AS5300

Hi

The config is pasted below. As mentioned earlier we use AAA server for authentication. Iam looking at the option of using the same username/password for both analog and isdn access. The call gets connected (authentication succeeds) at 64K with the current setup itself when I use the ISDN TA and an IP is assigned but howvever IP doesn't flow. (On the NAS it shows as a sync user connnected.

I think we may need to use the vty interfaces....

CONFIG below

aaa authentication login SECURE group radius enable

aaa authentication login CONSOLE local enable

aaa authentication login AUX local enable

aaa authentication login VTY local enable

aaa authentication ppp default if-needed group radius local

aaa authorization network default group radius

aaa authorization configuration default group radius

aaa accounting send stop-record authentication failure

aaa accounting update newinfo

aaa accounting exec default start-stop group radius

aaa accounting network default start-stop group radius

controller E1 0

framing NO-CRC4

clock source line primary

pri-group timeslots 1-31

interface Serial0:15

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem 64

no fair-queue

nterface Group-Async1

ip unnumbered Loopback0

ip access-group 100 in

encapsulation ppp

dialer in-band

dialer idle-timeout 3600

dialer-group 1

async dynamic routing

async mode interactive

peer default ip address pool pool0

no cdp enable

ppp authentication chap pap

group-range 1 200

interface Dialer1

ip unnumbered Loopback0

ip access-group 100 in

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 3600

dialer-group 1

peer default ip address pool pool0

no fair-queue

ppp authentication chap pap pool0

ppp multilink

kvrmurty

New Member

Re: Using ISDN TA for dialling to AS5300

Hi,

I guess you missed the "dialer-list" in your configuration, check out that. More often this is the root cause for the problem you said.

And can you clarify why do you need Dialer Interface, your requirements can be satisfied without dialer interface with the configuration that given earlier.

Can you post "debug ppp neg" output for a particular call.

If you need more assistance let me know.

87
Views
0
Helpful
3
Replies