Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Using NAT with Interface Virtual-Template

Hi!

I'm trying to use NAT to a Virtual-Template interface (see the example). It doesn't work (the virtual-template is also down-down). Where seems to be the problem?

##################

hostname Router

!

ip cef

!

multilink virtual-template 1

!

controller E1 0/0

channel-group 1 timeslots 1-31

!

controller E1 0/1

channel-group 1 timeslots 1-31

!

controller E1 1/0

channel-group 1 timeslots 1-31

!

controller E1 1/1

channel-group 1 timeslots 1-31

!

interface Serial0/0:1

ip unnumbered Virtual-Template1

ip nat outside

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

!

interface Serial0/1:1

ip unnumbered Virtual-Template1

ip nat outside

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

!

interface FastEthernet1/0

ip address 10.10.0.9 255.255.0.0

ip nat inside

!

interface Serial1/0:1

ip unnumbered Virtual-Template1

ip nat outside

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

!

interface Serial1/1:1

ip unnumbered Virtual-Template1

ip nat outside

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

!

interface Virtual-Template1

ip address 62.48.193.242 255.255.255.252

ip accounting output-packets

ip nat outside

ppp multilink

no ppp multilink fragmentation

!

ip nat inside source list 69 interface Virtual-Template1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 62.48.193.241

!

access-list 69 permit 10.10.0.0 0.0.255.255

######################################

  • Other Network Infrastructure Subjects
2 REPLIES
Bronze

Re: Using NAT with Interface Virtual-Template

NAT will not work if the interface you are overloading to is not in an up/up status. Under your serial interfaces, you have keepalives turned off... be sure that those serial lines are actually up and that traffic can traverse those links.

New Member

Re: Using NAT with Interface Virtual-Template

Hi!

I solved the problem using a loopback and configuring "ip unnumbered" in the Virtual-template interface. About your question: traffic does go trough the serial interfaces but the NAT traffic. The problem was that the Virtual-template interface is always down/down and, as you say, we can't do NAT with that kind of interface.

Thanks for your answer,

Olindo

1351
Views
0
Helpful
2
Replies
This widget could not be displayed.