cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
260
Views
0
Helpful
3
Replies

Using one BRI interface as a backup to two different locations

kvc
Level 1
Level 1

Hi,

I have a 3640 router with a ISDN BRI interface. And I also have two 1750 routers each with a BRI interface placed at two different locations.

|------------- Router 1750

|

Router3640|

|

|------------- Router 1750

The 3640 has two serial links to these two 1750 routers.

Now when both the serial links are down i want to use one B channel of 3640 to dial to one 1750 and the other to dial to other 1750.

Can you please give me a sample configuration about how to do this.

If you can give me a URL of cisco site where i can find this kind of configuration it will be very helpful

Thanks in advance

vijay

3 Replies 3

svermill
Level 4
Level 4

Here is a one-stop-shopping site for all things dial:

http://www.cisco.com/warp/customer/471/index.shtml

Scott

mazhar71
Level 1
Level 1

Hi,

You should create 2 different dialer interfaces. 1 is configured to dial to location 1 , the other is to location 2. Then you can configure on serial lines such : " backup interface dialer 1"

I wish it will help you

ericlinji
Level 1
Level 1

I have just completed some project with same situation as yours. This is the configuration, hope it may be helpful. I didn't use "backup interface" command, instead, I used dynamic routing protocol and floating static routes. And the IOS version is 12.2(6), ip only. there are some bugs on isdn with some versions of ios.

!

version 12.2

!

hostname BJ

!

enable password password

!

username SH password password

ip subnet-zero

!

!

!

isdn switch-type basic-net3

!

interface Ethernet0/0

ip address 172.35.16.254 255.255.255.0

half-duplex

!

interface BRI0/0

description Backup ISDN to SH

no ip address

encapsulation ppp

no keepalive

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Serial1/0

ip address 172.35.250.2 255.255.255.0

no ip mroute-cache

no fair-queue

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

interface Dialer1

description Backup ISDN to SH

ip address 172.35.244.6 255.255.255.0

encapsulation ppp

no keepalive

dialer in-band

dialer idle-timeout 180

dialer enable-timeout 2

dialer map ip 172.35.244.5 name SH 02144444444

dialer hold-queue 50

dialer-group 1

no cdp enable

ppp authentication chap

!

router eigrp 10

redistribute connected

redistribute static

network 172.35.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 172.35.10.0 255.255.255.0 172.35.244.5 120

ip route 172.35.14.0 255.255.255.0 172.35.244.5 120

no ip http server

ip pim bidir-enable

!

access-list 101 deny eigrp any any

access-list 101 permit ip any 172.35.10.0 0.0.0.255

access-list 101 permit ip any 172.35.14.0 0.0.0.255

dialer-list 1 protocol ip list 101

!

line con 0

line aux 0

line vty 0 4

!

end

version 12.2

!

hostname GZ

!

enable password password

!

username SH password password

ip subnet-zero

!

isdn switch-type basic-net3

!

interface Ethernet0/0

ip address 172.35.14.254 255.255.255.0

half-duplex

!

interface BRI0/0

description Backup ISDN to SH

no ip address

encapsulation ppp

no keepalive

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Serial1/0

ip address 172.35.252.2 255.255.255.0

no ip mroute-cache

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

interface Dialer1

description Backup ISDN to SH

ip address 172.35.244.4 255.255.255.0

encapsulation ppp

no keepalive

dialer in-band

dialer idle-timeout 180

dialer enable-timeout 2

dialer map ip 172.35.244.5 name SH 02144444444

dialer hold-queue 50

dialer-group 1

no cdp enable

ppp authentication chap

!

router eigrp 10

redistribute connected

redistribute static

network 172.35.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 172.35.10.0 255.255.255.0 172.35.244.5 120

ip route 172.35.16.0 255.255.255.0 172.35.244.5 120

!

access-list 101 deny eigrp any any

access-list 101 permit ip any 172.35.10.0 0.0.0.255

access-list 101 permit ip any 172.35.16.0 0.0.0.255

dialer-list 1 protocol ip list 101

!

line con 0

line aux 0

line vty 0 4

!

end

version 12.2

!

hostname SH

!

enable password password

!

username BJ password password

username GZ password password

ip subnet-zero

!

!

isdn switch-type basic-net3

!

!

interface Ethernet0/0

description SH LAN

ip address 172.35.10.254 255.255.255.0

half-duplex

!

interface BRI0/0

description Backup ISDN to BJ&GZ

no ip address

encapsulation ppp

no keepalive

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Serial1/0

description WAN to BJ

ip address 172.35.250.1 255.255.255.0

no ip mroute-cache

no fair-queue

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

description WAN to GZ

ip address 172.35.252.1 255.255.255.0

!

interface Serial1/3

no ip address

shutdown

!

interface Dialer1

description Backup ISDN to BJ&GZ

ip address 172.35.244.5 255.255.255.0

encapsulation ppp

no keepalive

dialer in-band

dialer idle-timeout 180

dialer enable-timeout 2

dialer map ip 172.35.244.4 name GZ 02044444444

dialer map ip 172.35.244.6 name BJ 01066666666

dialer hold-queue 50

dialer-group 1

no cdp enable

ppp authentication chap

!

router eigrp 10

redistribute connected

redistribute static

network 172.35.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 172.35.14.0 255.255.255.0 172.35.244.4 120

ip route 172.35.16.0 255.255.255.0 172.35.244.6 120

no ip http server

ip pim bidir-enable

!

access-list 101 deny eigrp any any

access-list 101 permit ip any 172.35.14.0 0.0.0.255

access-list 101 permit ip any 172.35.16.0 0.0.0.255

dialer-list 1 protocol ip list 101

!

line con 0

line aux 0

line vty 0 4

!

end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco