Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Using Single host in NAT Pool and Static NAT Configuration

Can the same host address (148.92.24.206) be used in NAT Pool and Static NAT configuration?

Router-configuration

!

interface FastEthernet0/0

description 100MB LAN

ip address 148.92.158.189 255.255.255.0

ip nat inside

!

interface Serial0/0.100 point-to-point

description PVC to Santa Clara, CA

ip address 10.25.16.66 255.255.255.252

ip nat outside

frame-relay interface-dlci 100

!

ip nat inside source static 148.92.24.206 148.92.165.129

!

ip nat pool hide_routes 148.92.164.145 148.92.164.145 netmask 255.255.255.0

ip nat inside source list 2 pool hide_routes overload

!

access-list 2 permit 148.92.24.0 0.0.0.255

3 REPLIES

Re: Using Single host in NAT Pool and Static NAT Configuration

This typically such a cinfiguration where people are making it difficult for themselves, and others.

The adress mentioned causes a match on access-list 2. This could cause unpredictable results. I don't know what takes precendence in this case. I would do the following:

Try to exclude this specific address from the acces-list.

no access-list 2

access-list 2 deny 148.92.24.206 255.255.255.255

access-list 2 permit 148.92.24.0 0.0.0.255

Now you can check your NAT process by observing the hits on the second line using the sh access-list command. In this manner you can test and tune your configuration.

Goodluck!

Re: Using Single host in NAT Pool and Static NAT Configuration

On the way home, I realized that the given mask was wrong.

It should be:

access-list 2 deny 148.92.24.206

access-list 2 permit 148.92.24.0 0.0.0.255

The other one would match anything to be denied.

Hope you still get the point !

New Member

Re: Using Single host in NAT Pool and Static NAT Configuration

Thanks for your assistance. I got the point and your approach works.

132
Views
0
Helpful
3
Replies