Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN and router internet browsing failure

I have a cisco 3548xl switch which is split into 48 vlans. the switch links to a cisco 2620 router which is used to do NAT, the VLAN port number is the Private IP address of whatever equipment is on the port, the router is used to assign a public internet IP address to the port. the router is then linked to another router which forwards onto the internet link.

A problem i had a few weeks ago meant i had to reboot the routers and switch.

A PC in port 7 of the switch could browse the internet, if i changed the IP address from 192.168.7.3 to 192.168.7.15 for instance browsing stopped working. If i installed a new PC into the same network 192.168.7.xx and gave it the address 192.168.7.3 this PC browsed the network fine. If i changed this to have an ip address of 192.168.7.50 it stopped working.

Any one have any ideas because this I would like to eradicate the problem. Currently it may come back and I dont know where the problem lies ????.

3 REPLIES

Re: VLAN and router internet browsing failure

Can you post the config of the router?

NAT is only used for connecting to the internet or also used in your LAN? What did the arp tables (router and PC) look like when this happened?

Also what did the cam table of the switch look like?

Was the router able to ping the PCs when their IP changed?

Steve

Community Member

Re: VLAN and router internet browsing failure

The PC's once the IP address changed couldn't ping the router.

dont know what a CAM table is ??, can you explain.

didn't check the arp tables at that time.

here is the config of the router..... its a biggy

sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname micrtr

!

no logging console

enable secret

enable password

!

memory-size iomem 15

ip subnet-zero

no ip finger

no ip domain-lookup

!

!

!

!

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

no cdp enable

!

interface FastEthernet0/0.1

encapsulation dot1Q 1

ip address 192.168.1.1 255.255.255.0

ip access-group 101 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.3.1 255.255.255.0

ip access-group 103 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.4

encapsulation dot1Q 4

ip address 192.168.4.1 255.255.255.0

ip access-group 104 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.5

encapsulation dot1Q 5

ip address 192.168.5.1 255.255.255.0

ip access-group 105 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.6

encapsulation dot1Q 6

ip address 192.168.6.1 255.255.255.0

ip access-group 106 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.7

encapsulation dot1Q 7

ip address 192.168.7.1 255.255.255.0

ip access-group 107 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.8

encapsulation dot1Q 8

ip address 192.168.8.1 255.255.255.0

ip access-group 108 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.9

encapsulation dot1Q 9

ip address 192.168.9.1 255.255.255.0

ip access-group 109 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.100 255.255.255.0

ip access-group 110 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.11

encapsulation dot1Q 11

ip address 192.168.11.1 255.255.255.0

ip access-group 111 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.12

encapsulation dot1Q 12

ip address 192.168.12.1 255.255.255.0

ip access-group 112 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.13

encapsulation dot1Q 13

ip address 192.168.13.1 255.255.255.0

ip access-group 113 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.14

encapsulation dot1Q 14

ip address 192.168.14.1 255.255.255.0

ip access-group 114 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.15

encapsulation dot1Q 15

ip address 192.168.15.1 255.255.255.0

ip access-group 115 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.16

encapsulation dot1Q 16

ip address 192.168.16.1 255.255.255.0

ip access-group 116 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.17

encapsulation dot1Q 17

ip address 192.168.17.1 255.255.255.0

ip access-group 117 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.18

encapsulation dot1Q 18

ip address 192.168.18.1 255.255.255.0

ip access-group 118 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.19

encapsulation dot1Q 19

ip address 192.168.19.1 255.255.255.0

ip access-group 119 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

ip access-group 120 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.21

encapsulation dot1Q 21

ip address 192.168.21.1 255.255.255.0

ip access-group 121 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.22

encapsulation dot1Q 22

ip address 192.168.22.1 255.255.255.0

ip access-group 122 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.23

encapsulation dot1Q 23

ip address 192.168.23.1 255.255.255.0

ip access-group 123 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.24

encapsulation dot1Q 24

ip address 192.168.24.1 255.255.255.0

ip access-group 124 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.25

encapsulation dot1Q 25

ip address 192.168.25.1 255.255.255.0

ip access-group 125 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.26

encapsulation dot1Q 26

ip address 192.168.26.1 255.255.255.0

ip access-group 126 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.27

encapsulation dot1Q 27

ip address 192.168.27.1 255.255.255.0

ip access-group 127 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.28

encapsulation dot1Q 28

ip address 192.168.28.1 255.255.255.0

ip access-group 128 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.29

encapsulation dot1Q 29

ip address 192.168.29.1 255.255.255.0

ip access-group 129 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

ip access-group 130 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.31

encapsulation dot1Q 31

ip address 192.168.31.1 255.255.255.0

ip access-group 131 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.32

encapsulation dot1Q 32

ip address 192.168.32.1 255.255.255.0

ip access-group 132 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.33

encapsulation dot1Q 33

ip address 192.168.33.1 255.255.255.0

ip access-group 133 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.34

encapsulation dot1Q 34

ip address 192.168.34.1 255.255.255.0

ip access-group 134 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.35

encapsulation dot1Q 35

ip address 192.168.35.1 255.255.255.0

ip access-group 135 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.36

encapsulation dot1Q 36

ip address 192.168.36.1 255.255.255.0

ip access-group 136 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.37

encapsulation dot1Q 37

ip address 192.168.37.1 255.255.255.0

ip access-group 137 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.38

encapsulation dot1Q 38

ip address 192.168.38.1 255.255.255.0

ip access-group 138 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.39

encapsulation dot1Q 39

ip address 192.168.39.1 255.255.255.0

ip access-group 139 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

ip access-group 140 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.41

encapsulation dot1Q 41

ip address 192.168.41.1 255.255.255.0

ip access-group 141 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.42

encapsulation dot1Q 42

ip address 192.168.42.1 255.255.255.0

ip access-group 142 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.43

encapsulation dot1Q 43

ip address 192.168.43.1 255.255.255.0

ip access-group 143 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.44

encapsulation dot1Q 44

ip address 192.168.44.1 255.255.255.0

ip access-group 144 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.45

encapsulation dot1Q 45

ip address 192.168.45.1 255.255.255.0

ip access-group 145 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.46

encapsulation dot1Q 46

ip access-group 146 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.47

ip access-group 147 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/0.48

ip access-group 148 out

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface FastEthernet0/1

ip address 80.4.178.65 255.255.255.192 secondary

ip address 212.43.174.193 255.255.255.192

ip access-group 150 in

no ip directed-broadcast

ip nat outside

no cdp enable

!

ip nat pool internet 80.4.178.66 80.4.178.125 netmask 255.255.255.192

ip nat inside source list 8 pool internet

ip nat inside source static 192.168.5.10 212.43.174.253

ip classless

ip route 0.0.0.0 0.0.0.0 212.43.174.254

ip route 0.0.0.0 0.0.0.0 80.4.178.126

no ip http server

!

access-list 8 deny 192.168.5.10

access-list 8 permit 192.168.0.0 0.0.255.255

access-list 9 permit 192.168.23.0 0.0.0.255

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

access-list 101 deny ip 192.168.0.0 0.0.255.255 any

access-list 101 permit ip any any

access-list 103 permit ip 192.168.3.0 0.0.0.255 any

access-list 103 deny ip 192.168.0.0 0.0.255.255 any

access-list 103 permit ip any any

access-list 104 permit ip 192.168.4.0 0.0.0.255 any

access-list 104 deny ip 192.168.0.0 0.0.255.255 any

access-list 104 permit ip any any

access-list 105 permit ip 192.168.5.0 0.0.0.255 any

access-list 105 deny ip 192.168.0.0 0.0.255.255 any

access-list 105 permit ip any any

access-list 106 permit ip 192.168.6.0 0.0.0.255 any

access-list 106 deny ip 192.168.0.0 0.0.255.255 any

access-list 106 permit ip any any

access-list 107 permit ip 192.168.7.0 0.0.0.255 any

access-list 107 deny ip 192.168.0.0 0.0.255.255 any

access-list 107 permit ip any any

access-list 108 permit ip 192.168.8.0 0.0.0.255 any

access-list 108 deny ip 192.168.0.0 0.0.255.255 any

access-list 108 permit ip any any

access-list 109 permit ip 192.168.9.0 0.0.0.255 any

access-list 109 deny ip 192.168.0.0 0.0.255.255 any

access-list 109 permit ip any any

access-list 110 permit ip 192.168.10.0 0.0.0.255 any

access-list 110 deny ip 192.168.0.0 0.0.255.255 any

access-list 110 permit ip any any

access-list 111 permit ip 192.168.11.0 0.0.0.255 any

access-list 111 deny ip 192.168.0.0 0.0.255.255 any

access-list 111 permit ip any any

access-list 112 permit ip 192.168.12.0 0.0.0.255 any

access-list 112 deny ip 192.168.0.0 0.0.255.255 any

access-list 112 permit ip any any

access-list 113 permit ip 192.168.13.0 0.0.0.255 any

access-list 113 deny ip 192.168.0.0 0.0.255.255 any

access-list 113 permit ip any any

access-list 114 permit ip 192.168.14.0 0.0.0.255 any

access-list 114 deny ip 192.168.0.0 0.0.255.255 any

access-list 114 permit ip any any

access-list 115 permit ip 192.168.15.0 0.0.0.255 any

access-list 115 deny ip 192.168.0.0 0.0.255.255 any

access-list 115 permit ip any any

access-list 116 permit ip 192.168.16.0 0.0.0.255 any

access-list 116 deny ip 192.168.0.0 0.0.255.255 any

access-list 116 permit ip any any

access-list 117 permit ip 192.168.17.0 0.0.0.255 any

access-list 117 deny ip 192.168.0.0 0.0.255.255 any

access-list 117 permit ip any any

access-list 118 permit ip 192.168.18.0 0.0.0.255 any

access-list 118 deny ip 192.168.0.0 0.0.255.255 any

access-list 118 permit ip any any

access-list 119 permit ip 192.168.19.0 0.0.0.255 any

access-list 119 deny ip 192.168.0.0 0.0.255.255 any

access-list 119 permit ip any any

access-list 120 permit ip 192.168.20.0 0.0.0.255 any

access-list 120 deny ip 192.168.0.0 0.0.255.255 any

access-list 120 permit ip any any

access-list 121 permit ip 192.168.21.0 0.0.0.255 any

access-list 121 deny ip 192.168.0.0 0.0.255.255 any

access-list 121 permit ip any any

access-list 122 permit ip 192.168.22.0 0.0.0.255 any

access-list 122 deny ip 192.168.0.0 0.0.255.255 any

access-list 122 permit ip any any

access-list 123 permit ip 192.168.23.0 0.0.0.255 any

access-list 123 deny ip 192.168.0.0 0.0.255.255 any

access-list 123 permit ip any any

access-list 124 permit ip 192.168.24.0 0.0.0.255 any

access-list 124 deny ip 192.168.0.0 0.0.255.255 any

access-list 124 permit ip any any

access-list 125 permit ip 192.168.25.0 0.0.0.255 any

access-list 125 deny ip 192.168.0.0 0.0.255.255 any

access-list 125 permit ip any any

access-list 126 permit ip 192.168.26.0 0.0.0.255 any

access-list 126 deny ip 192.168.0.0 0.0.255.255 any

access-list 126 permit ip any any

access-list 127 permit ip 192.168.27.0 0.0.0.255 any

access-list 127 deny ip 192.168.0.0 0.0.255.255 any

access-list 127 permit ip any any

access-list 128 permit ip 192.168.28.0 0.0.0.255 any

access-list 128 deny ip 192.168.0.0 0.0.255.255 any

access-list 128 permit ip any any

access-list 129 permit ip 192.168.29.0 0.0.0.255 any

access-list 129 deny ip 192.168.0.0 0.0.255.255 any

access-list 129 permit ip any any

access-list 130 permit ip 192.168.30.0 0.0.0.255 any

access-list 130 deny ip 192.168.0.0 0.0.255.255 any

access-list 130 permit ip any any

access-list 131 permit ip 192.168.31.0 0.0.0.255 any

access-list 131 deny ip 192.168.0.0 0.0.255.255 any

access-list 131 permit ip any any

access-list 132 permit ip 192.168.32.0 0.0.0.255 any

access-list 132 deny ip 192.168.0.0 0.0.255.255 any

access-list 132 permit ip any any

access-list 133 permit ip 192.168.33.0 0.0.0.255 any

access-list 133 deny ip 192.168.0.0 0.0.255.255 any

access-list 133 permit ip any any

access-list 134 permit ip 192.168.34.0 0.0.0.255 any

access-list 134 deny ip 192.168.0.0 0.0.255.255 any

access-list 134 permit ip any any

access-list 135 permit ip 192.168.35.0 0.0.0.255 any

access-list 135 deny ip 192.168.0.0 0.0.255.255 any

access-list 135 permit ip any any

access-list 136 permit ip 192.168.36.0 0.0.0.255 any

access-list 136 deny ip 192.168.0.0 0.0.255.255 any

access-list 136 permit ip any any

access-list 137 permit ip 192.168.37.0 0.0.0.255 any

access-list 137 deny ip 192.168.0.0 0.0.255.255 any

access-list 137 permit ip any any

access-list 138 permit ip 192.168.38.0 0.0.0.255 any

access-list 138 deny ip 192.168.0.0 0.0.255.255 any

access-list 138 permit ip any any

access-list 139 permit ip 192.168.39.0 0.0.0.255 any

access-list 139 deny ip 192.168.0.0 0.0.255.255 any

access-list 139 permit ip any any

access-list 140 permit ip 192.168.40.0 0.0.0.255 any

access-list 140 deny ip 192.168.0.0 0.0.255.255 any

access-list 140 permit ip any any

access-list 141 permit ip 192.168.41.0 0.0.0.255 any

access-list 141 deny ip 192.168.0.0 0.0.255.255 any

access-list 141 permit ip any any

access-list 142 permit ip 192.168.42.0 0.0.0.255 any

access-list 142 deny ip 192.168.0.0 0.0.255.255 any

access-list 142 permit ip any any

access-list 143 permit ip 192.168.43.0 0.0.0.255 any

access-list 143 deny ip 192.168.0.0 0.0.255.255 any

access-list 143 permit ip any any

access-list 144 permit ip 192.168.44.0 0.0.0.255 any

access-list 144 deny ip 192.168.0.0 0.0.255.255 any

access-list 144 permit ip any any

access-list 145 permit ip 192.168.45.0 0.0.0.255 any

access-list 145 deny ip 192.168.0.0 0.0.255.255 any

access-list 145 permit ip any any

access-list 146 permit ip 192.168.46.0 0.0.0.255 any

access-list 146 deny ip 192.168.0.0 0.0.255.255 any

access-list 146 permit ip any any

access-list 147 permit ip 192.168.47.0 0.0.0.255 any

access-list 147 deny ip 192.168.0.0 0.0.255.255 any

access-list 147 permit ip any any

access-list 148 permit ip 192.168.48.0 0.0.0.255 any

access-list 148 deny ip 192.168.0.0 0.0.255.255 any

access-list 148 permit ip any any

no cdp run

!

line con 0

exec-timeout 0 0

password

login

transport input none

line aux 0

line vty 0 4

password

login

!

end

Heres the config of the switch....

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

hostname

enable secret

ip subnet-zero

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/2

interface FastEthernet0/3

switchport access vlan 3

interface FastEthernet0/4

switchport access vlan 4

interface FastEthernet0/5

switchport access vlan 5

interface FastEthernet0/6

switchport access vlan 6

interface FastEthernet0/7

switchport access vlan 7

interface FastEthernet0/8

switchport access vlan 8

interface FastEthernet0/9

switchport access vlan 9

interface FastEthernet0/10

switchport access vlan 10

interface FastEthernet0/11

switchport access vlan 11

interface FastEthernet0/12

switchport access vlan 12

interface FastEthernet0/13

switchport access vlan 13

interface FastEthernet0/14

switchport access vlan 14

interface FastEthernet0/15

switchport access vlan 15

interface FastEthernet0/16

switchport access vlan 16

interface FastEthernet0/17

switchport access vlan 17

interface FastEthernet0/18

switchport access vlan 18

interface FastEthernet0/19

switchport access vlan 19

interface FastEthernet0/20

switchport access vlan 20

interface FastEthernet0/21

switchport access vlan 21

interface FastEthernet0/22

switchport access vlan 22

interface FastEthernet0/23

switchport access vlan 23

interface FastEthernet0/24

switchport access vlan 24

interface FastEthernet0/25

switchport access vlan 25

interface FastEthernet0/26

switchport access vlan 26

interface FastEthernet0/27

switchport access vlan 27

interface FastEthernet0/28

switchport access vlan 28

interface FastEthernet0/29

switchport access vlan 29

interface FastEthernet0/30

switchport access vlan 30

interface FastEthernet0/31

switchport access vlan 31

interface FastEthernet0/32

switchport access vlan 32

interface FastEthernet0/33

switchport access vlan 33

interface FastEthernet0/34

switchport access vlan 34

interface FastEthernet0/35

switchport access vlan 35

interface FastEthernet0/36

switchport access vlan 36

interface FastEthernet0/37

switchport access vlan 37

interface FastEthernet0/38

switchport access vlan 38

interface FastEthernet0/39

switchport access vlan 39

interface FastEthernet0/40

switchport access vlan 40

interface FastEthernet0/41

switchport access vlan 41

interface FastEthernet0/42

switchport access vlan 42

interface FastEthernet0/43

switchport access vlan 43

interface FastEthernet0/44

switchport access vlan 44

interface FastEthernet0/45

switchport access vlan 45

interface FastEthernet0/46

switchport access vlan 46

interface FastEthernet0/47

switchport access vlan 47

interface FastEthernet0/48

switchport access vlan 48

interface GigabitEthernet0/1

interface GigabitEthernet0/2

interface VLAN1

ip address 192.168.1.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

ip default-gateway 192.168.1.1

snmp-server engineID local 00000009020000075003DCC0

snmp-server community private RW

snmp-server community public RO

I have obviously taken out passwords etc..

if you need any more info please let me know...

thanks

Community Member

Re: VLAN and router internet browsing failure

PS:- This solution has been in place and working since Nov 2001 without showing the problem mentioned at the start.

There were 65 working users.

Im thinking something became full, stopped something else from working and a reboot of the kit flushed all tables / memory etc.

what do you think ??.

90
Views
0
Helpful
3
Replies
CreatePlease to create content