Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN & Cisco 2900 XL question

Is this possible to take ports 17-19 and set them to another network segement?

interface FastEthernet0/17

port group 2

switchport access vlan 2

switchport multi vlan 2

switchport priority default 2

spanning-tree portfast

!

interface FastEthernet0/18

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/19

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/20

spanning-tree portfast

!

interface FastEthernet0/21

spanning-tree portfast

!

interface FastEthernet0/22

spanning-tree portfast

!

interface FastEthernet0/23

spanning-tree portfast

!

interface FastEthernet0/24

spanning-tree portfast

!

interface VLAN1

ip address 10.0.10.21 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

interface VLAN2

ip address 192.168.1.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown ------>what is this statement?

!

thanks

  • Other Network Infrastructure Subjects
2 REPLIES
New Member

Re: VLAN & Cisco 2900 XL question

By set them to another segment do you mean another

VLAN, Yes assuming that vlan is defined.

the shut down statement keeps vlan 2 from being routed.

New Member

Re: VLAN & Cisco 2900 XL question

What you have configured is enough to have two vlan.

Vlan 1 is the default and you have configured 17-19 ports in vlan 2.

Vlan2 is an XL switch is used if you want to manage the switch using the vlan 2 subnet ip address.

You need only one management interface at a time and hence vlan 2 is shutdown as vlan1 is up.

Please disregard the previous response which said when vlan 2 is shutdown it would prevent vlan 2 being routed. This is a layer 2 switch and there is no routing involved.

You still need a router to route between the vlan 1 and vlan 2. The switch will not do it by defining vlan interfaces.

hope this is clear.

298
Views
0
Helpful
2
Replies