Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN communication between 4507 and 3845

I'm unable to ping vlans between the 4507 and the 3845. Here are the configs:

4507 CONFIG:

interface Vlan3

description Link to Subnet 1

ip address 10.7.129.50 255.255.255.0

ip helper-address 131.68.9.45

no ip redirects

ip pim sparse-mode

ip cgmp

arp timeout 234000

!

interface Vlan5

description User_VLAN

ip address 10.7.130.50 255.255.255.0

ip helper-address 131.68.9.45

no ip redirects

ip pim sparse-mode

ip cgmp

shutdown

arp timeout 234000

!

interface Vlan30

description VTC_VLAN

ip address 10.4.58.50 255.255.255.0

no ip redirects

ip pim sparse-mode

ip cgmp

!

interface Vlan50

description WAN_ACCESS_VLAN

ip address 10.4.61.50 255.255.255.0

no ip redirects

ip pim sparse-mode

ip cgmp

!

interface Vlan100

description Management_VLAN

ip address 10.4.57.50 255.255.255.0

no ip redirects

ip pim sparse-mode

ip cgmp

!

router ospf 100

router-id 10.7.1.50

log-adjacency-changes

area 0 range 10.4.248.0 255.255.248.0

area 7 range 10.7.0.0 255.255.0.0

area 7 range 10.7.128.0 255.255.255.0

area 7 range 10.7.129.0 255.255.255.0

area 7 range 10.4.56.0 255.255.248.0

passive-interface Vlan100

network 10.7.0.0 0.0.255.255 area 7

network 10.7.128.0 0.0.31.255 area 7

network 10.8.96.0 0.0.31.255 area 0

network 10.8.253.0 0.0.0.255 area 0

network 10.4.56.0 0.0.7.255 area 7

network 10.4.248.0 0.0.7.255 area 0

default-metric 110

3845 CONFIG:

interface Loopback0

ip address 10.7.1.2 255.255.255.0

ip pim sparse-mode

!

interface Multilink1

ip address 10.7.159.9 255.255.255.252

ip pim sparse-mode

ppp multilink

ppp multilink group 1

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

description Link to 4507_CR_B G1/1

no ip address

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1.50

description WAN_Access_VLAN

encapsulation dot1Q 50

ip address 10.4.61.2 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet0/1.51

description Area_0_VLAN

encapsulation dot1Q 51

ip address 10.4.250.238 255.255.255.252

no ip redirects

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet0/1.100

description Management_VLAN

encapsulation dot1Q 100

ip address 10.4.57.2 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

!

interface Serial0/0/0

ip address 10.4.250.98 255.255.255.252

!

interface Serial0/1/0

no ip address

!

interface Serial1/0

no ip address

dsu bandwidth 44210

!

interface Serial3/0

dsu bandwidth 44210

!

router ospf 100

router-id 10.7.1.3

log-adjacency-changes

area 0 range 10.4.248.0 255.255.248.0

area 7 range 10.7.0.0 255.255.0.0

area 7 range 10.4.56.0 255.255.248.0

network 10.7.0.0 0.0.255.255 area 7

network 10.7.128.0 0.0.31.255 area 7

network 10.8.96.0 0.0.31.255 area 0

network 10.8.253.0 0.0.0.255 area 0

network 10.4.56.0 0.0.7.255 area 7

network 10.4.248.0 0.0.7.255 area 0

default-metric 110

3 REPLIES
Blue

Re: VLAN communication between 4507 and 3845

where's the trunk configuration for the 4507??

you'll need a dot1q trunk that can carry the vlans you want to communicate between the two devices.

see the following link for more info:

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_book09186a00801d08aa.html

New Member

Re: VLAN communication between 4507 and 3845

Sorry, I didn't include that part.

4507:

interface GigabitEthernet3/1

description LINK TO 3845

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport mode trunk

Re: VLAN communication between 4507 and 3845

Try on the 4507:

showinter gig 3/1 switchport >> Looking for what the native vlan is, should be vlan 1.

On the router try:

conf t

interface gig 0/1.1

encapsulation dot1Q 1 native

Then try pinging from 4507 to the following ip addresses:

10.4.61.2

10.4.57.2

These are the only two interfaces that you should be above to ping since you do not have vlan 51 on 4507.

Please rate all posts

231
Views
0
Helpful
3
Replies