Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VLAN Configuration

I am configuring VLANs on 3560 and 3750 switches but some are coming up while others are as follows:

WILSWOCC011#sh ip int brie

Interface IP-Address OK? Method Status Protocol

Vlan1 10.4.200.11 YES manual up up

Vlan11 10.4.11.5 YES manual up down

Vlan100 10.4.100.11 YES manual down down

Can someone tell me what am doing wrong. Because i have about 3 3560 which are coming on while the other 4 are not. Please advise.

10 REPLIES

Re: VLAN Configuration

Hi,

Do you have Vlans exist in vlan datable.Do a " show vlan ". Make sure that you have a host connected to the vlan, without any host connected, the interface will show your down. If you have a trunk connected on this switch, then it will show you up/up.Also did you give a no shut under the vlan interafce.

Please paste the config.

regards,

-amit singh

VIP Purple

Re: VLAN Configuration

Hello,

do you have a user port assigned to the VLAN (100), and is that port up/up, or is the VLAN carried to the switch through a trunk ?

In case you use VTP, make sure that all switches are in the same VTP domain, use the same VTP version, and that the passwords (if implemented) are identical.

On the switch where the VLAN interface is down/down, you might want to check if the VLAN is in the database, with the ´show vlan´ exec command...

Can you post the output of that command, as well as the output of the ´show vtp status´ command from this and another one of your switches ?

Regards,

GP

New Member

Re: VLAN Configuration

These are the results of the two commands

WILSWOCC001#sh vtp status

VTP Version : 2

Configuration Revision : 0

Maximum VLANs supported locally : 1005

Number of existing VLANs : 7

VTP Operating Mode : Transparent

VTP Domain Name : kq.kenya-airways.com

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xBA 0x1D 0x95 0x5F 0xE6 0xE8 0xD0 0x19

Configuration last modified by 10.4.200.1 at 3-8-93 23:57:13

WILSWOCC001#sh vl

WILSWOCC001#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24

Gi0/1, Gi0/2

10 OCC_Second_Floor active

510 OCC_Second_Floor_Trunk active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

10 enet 100010 1500 - - - - - 0 0

510 enet 100510 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

WILSWOCC001#

New Member

Re: VLAN Configuration

This switch's VLAN works.

User Access Verification

Password:

WILSARR001>en

Password:

WILSARR001#sh vl

WILSARR001#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi0/2, Gi0/3, Gi0/4, Gi0/5

Gi0/6, Gi0/7, Gi0/8, Gi0/9

Gi0/10, Gi0/11, Gi0/12, Gi0/13

Gi0/14, Gi0/15, Gi0/16, Gi0/17

Gi0/18, Gi0/19, Gi0/20, Gi0/21

Gi0/22, Gi0/23, Gi0/24, Gi0/25

Gi0/26, Gi0/27, Gi0/28

14 Int_Arrivals active

514 Int_Arrivals_Trunk active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

14 enet 100014 1500 - - - - - 0 0

514 enet 100514 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

WILSARR001#sh vt

WILSARR001#sh vtp st

WILSARR001#sh vtp status

VTP Version : 2

Configuration Revision : 2

Maximum VLANs supported locally : 1005

Number of existing VLANs : 7

VTP Operating Mode : Server

VTP Domain Name : kq_domain_1

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xF6 0x1B 0x16 0x85 0x3F 0x4C 0x8D 0xB1

Configuration last modified by 10.4.200.40 at 3-3-93 18:05:47

Local updater ID is 10.4.200.40 on interface Vl1 (lowest numbered VLAN interface

found)

Re: VLAN Configuration

Hi,

Just saw the output of your 2 switches. The first switch has a different Domain name and also is configured as trasparent. As you see tha trasparent switches doesnot update their Vlan info via VTP that's why the revisionm number is 0 in first case. In this case this switch will have its own vlan database configured locally on the switch.

I dont see any active host port on any of the vlan. Its vlan interface will come up only, if you have an active host connected in it or there is an interface trunk configured on it.

I beleive you have set up your trunk between your 2 switches to carry the vlan traffic.If you have your trunk setup on negotiation then, Please turn-off the switch negotiation to form the trunk via DTP as, switches with diff domain names doesnot negotiate the trunk over the link..

To turn off the negotation "

conf t

int gig x/y

switch nonegotiate

to check the status of trunk interface use command,

show int gig x/y switchport

Please paste the switch config as well...

regards,

-amit singh

New Member

Re: VLAN Configuration

SWITCH 1 Config

User Access Verification

Password:

WILSWOCC001>en

Password:

WILSWOCC001#sh run

Building configuration...

Current configuration : 6860 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname WILSWOCC001

!

enable password 7 13061E010803

!

no aaa new-model

vtp domain kq.kenya-airways.com

vtp mode transparent

ip subnet-zero

!

!

mls qos map dscp-cos 40 to 3

mls qos map cos-dscp 0 8 16 40 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2 1

!

!

no file verify auto

!

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree uplinkfast

!

vlan internal allocation policy ascending

!

vlan 10

name OCC_Second_Floor

!

vlan 510

name OCC_Second_Floor_Trunk

!

!

!

interface FastEthernet0/23

switchport voice vlan dot1p

priority-queue out

mls qos trust dscp

spanning-tree portfast

!

interface FastEthernet0/24

switchport voice vlan dot1p

priority-queue out

mls qos trust dscp

spanning-tree portfast

!

interface GigabitEthernet0/1

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

!

!

interface Vlan1

description Management IP for 2nd Floor OCC

ip address 10.4.200.1 255.255.0.0

!

interface Vlan10

description Trunk link to OCC Ground Floor

no ip address

!

ip default-gateway 10.4.1.150

ip classless

ip http server

!

snmp-server community out RO

snmp-server location OCC Second Floor Cabinet

!

control-plane

!

!

line con 0

line vty 0 4

password 7 104D000A0618

login

line vty 5 15

no login

!

!

end

WILSWOCC001#

Re: VLAN Configuration

Hi,

You have pasted the output for switch named " WILSWOCC001 " where as above problem mentioned switch " WILSWOCC0011".

Never mind, I still stnad on the same point that you Vlan dtaabase doesnot show any host port listed neither in vlan 10 nor in vlan 510. Also you vlan discription tells that you are using trunk between the switch, in that case the interfaec showuld be up.

Is your trunk wokring ?? Please let em know which port is connecting the diddfrent switches. Is the switch meontioned above in the problem, a stand alsone switch or there is a connection from it to other switches. If yes, what that link access or trunk, let us know teh config on that port.

Paste the output of the interafec that is connecting the switches using command " show int gig x/y switchport ".

regards,

-amit singh

New Member

Re: VLAN Configuration

Cisco 3560 Switch

WILSWOCC001#sh run interface g0/1

Building configuration...

Current configuration : 170 bytes

!

interface GigabitEthernet0/1

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

end

WILSWOCC001#sh run interface g0/2

Building configuration...

Current configuration : 170 bytes

!

interface GigabitEthernet0/2

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

Cisco 3750 Switch

WILSWOCC025#sh run interface gigabitEthernet 1/0/2

Building configuration...

Current configuration : 233 bytes

!

interface GigabitEthernet1/0/2

description Connection to Second Floor OCC Switch 10.4.10.5

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

end

WILSWOCC025#

Re: VLAN Configuration

Hi There,

I see that the config posted above doesnot have any of the interface configured as trunk. All of the interfaces are in defulat vlan i.e. Vlan 1.That's why you see that Vlan 1 interface is up/up. Untill and unless you connect any host to a specfic vlan and set up any port as trunk port you interface vlan will not come up.

HTH,

-amit singh

New Member

Re: VLAN Configuration

Thanks I just missed out on the making the uplink a switch port trunk. It is now working thanks for everyone efforts.

Config is

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

load-interval 30

carrier-delay msec 0

311
Views
0
Helpful
10
Replies
CreatePlease to create content