Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VLAN configuration

I have a router which is connected with a layer 3 switch(3550). On that switch are attached about 20 2950 switches and this number might increase. To increase the bandwith and security of my network i created VLANS. I create subinterfaces on the router interface according to each VLAN. I created also the trunk links between switches and layer 3 switch and the router. My layer 3 switch is running RIP v2 and soon will run EIGRP. It is a base image no ip services.

1. If i run EIGRP on that layer 3 switch and add all the networks for the VLANS, can i have the VLANs work without the encapsulation on the subinterfaces of the Router ?

2. Is there is any other way to run the VLANs more efficient so the router not have to do so much work since the VLANs are increasing.

3. How about the DHCP server. Can i run it on a layer 3 switch.

Thanks

moses

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: VLAN configuration

Moses

Lets say you have the following subinterfaces on your router

int fa0/0.10

encapsulation dot1q 10

ip address 192.168.10.1 255.255.255.0

int fa0/0.20

encapsulation dot1q 20

ip address 192.168.20.1 255.255.255.0

To create the equivalent on the 3550 you need SVI's (Switched Virtual Interfaces) eg.

interface vlan 10

ip address 192.168.10.1 255.255.255.0

no shut

interface vlan 20

ip address 192.168.20.1 255.255.255.0

no shut

HTH

Jon

3 REPLIES
Hall of Fame Super Blue

Re: VLAN configuration

Hi Moses

Yes, you can remove the sub-interfaces off the router and create SVI's on the 3550 switch for all the vlans. This would be preferable to sub-interfaces.

If you have a base image you cannot run full EIGRP on the 3550 but if you have all the vlan interfaces on the 3550 you won't need EIGRP.

HTH

Jon

New Member

Re: VLAN configuration

Jon thanks a lot.

What's the SVI and how you creat those.

Thanks a lot

Hall of Fame Super Blue

Re: VLAN configuration

Moses

Lets say you have the following subinterfaces on your router

int fa0/0.10

encapsulation dot1q 10

ip address 192.168.10.1 255.255.255.0

int fa0/0.20

encapsulation dot1q 20

ip address 192.168.20.1 255.255.255.0

To create the equivalent on the 3550 you need SVI's (Switched Virtual Interfaces) eg.

interface vlan 10

ip address 192.168.10.1 255.255.255.0

no shut

interface vlan 20

ip address 192.168.20.1 255.255.255.0

no shut

HTH

Jon

109
Views
0
Helpful
3
Replies
CreatePlease to create content