Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN E-Mail Problems on 2950 Cluster

We have a multi-tenant building for which I provide voice/data solutions. We decided to implement VLANs to segregate the tenants on the network for security/management purposes and still allow them access to the Internet. I have installed (6) 2950 routers trunked together via the GigabitEthernet ports, routing through a 2801, through a firewall, and out to the Internet. The VLANs have been configured to receive IP addresses from a Win2K DHCP server and all scopes are set up and working properly. When everyone was connected to the new switches straight out of the box, they defaulted to the native VLAN1 and there were no issues. I went in to assign FastEthernet0/10 on Switch5 to Static Access VLAN 16 to place that tenants uplink connection from their switch in VLAN16. All of their PCs received their new IP addresses (192.168.16.X) and they continued to function correctly. The problems arose when they tried to send an email with any size attachment. The send would time out and error with unable to connect to their POP email server. All emails without attachments send/receive without errors. The attachments were only 800k pdf documents. I tested down to a 20k attachment before finally getting the email to pass through. This is occurring in all VLANs regardless of POP, switch, or port.

Anyone have any ideas?

Thank you.

3 REPLIES

Re: VLAN E-Mail Problems on 2950 Cluster

Hi,

this could be a MTU issue. Can you send an extended ping to the default gateway with DF-BIT set and find the MTU along the path?

From a windows PC you might try

ping -f -l 1472

and lower length to a value where you succeed (be aware that 28 Bytes overhead are added so the above would send 1500 Bytes).

Hope this helps

Martin

New Member

Re: VLAN E-Mail Problems on 2950 Cluster

I went to a workstation on the affected VLAN and ran the ping as described. I tried 192.168.16.1 as configured for the VLAN and got:

reply 192.168.16.1 bytes=1472 time=1ms ttl=255

no packet loss

For grins I ran it again against the "true" gateway which is 192.168.10.1 and received the following:

reply 192.168.10.1 bytes=1472 time=3ms ttl=63

no packet loss

So I will assume it is not an MTU issue at this point.

Thank you.

VIP Purple

Re: VLAN E-Mail Problems on 2950 Cluster

Hello,

you could try and change the MSS size on the VLAN and FastEthernet interfaces of your 2801 router, e.g.:

interface Vlan2

ip tcp adjust-mss 1350

!

interface FastEthernet0/0

ip tcp adjust-mss 1350

Regards,

GP

115
Views
0
Helpful
3
Replies
CreatePlease login to create content